summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-05 19:56:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-05 19:56:35 +0000
commit3d93da931da7588aca82465d5e8687703483faf2 (patch)
tree546bda2cafbbb63c43bf4b8886cf3e2582f03134 /app-editors/hteditor
parentFix building with GLIBC 2.10+ wrt #278182. (diff)
downloadgentoo-2-3d93da931da7588aca82465d5e8687703483faf2.tar.gz
gentoo-2-3d93da931da7588aca82465d5e8687703483faf2.tar.bz2
gentoo-2-3d93da931da7588aca82465d5e8687703483faf2.zip
Go and force -O0 -ggdb -g3 to someone else.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/hteditor')
-rw-r--r--app-editors/hteditor/hteditor-2.0.17.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-editors/hteditor/hteditor-2.0.17.ebuild b/app-editors/hteditor/hteditor-2.0.17.ebuild
index 91fb1f0dde5d..3da6db4d27a3 100644
--- a/app-editors/hteditor/hteditor-2.0.17.ebuild
+++ b/app-editors/hteditor/hteditor-2.0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-2.0.17.ebuild,v 1.1 2009/06/28 09:30:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-2.0.17.ebuild,v 1.2 2009/08/05 19:56:35 ssuominen Exp $
MY_PV=${PV/_/}
@@ -22,8 +22,13 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/ht-${MY_PV}
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:-ggdb -g3 -O0:$CFLAGS:' "${S}"/configure || die "sed failed"
+}
+
src_compile() {
- econf --disable-release --enable-maintainer-mode $(use_enable X x11-textmode)
+ econf --disable-release $(use_enable X x11-textmode)
emake || die "emake failed."
}