summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-27 23:25:27 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-27 23:25:27 +0000
commit7214e9dd43181a86863af5f6428e701d36c24613 (patch)
tree8a4a857552f09d1292fd24c8035d3bc0132f21ac /app-editors/hexcurse
parentFix libtool-9999 in preparation for 2.4.3 (diff)
downloadgentoo-2-7214e9dd43181a86863af5f6428e701d36c24613.tar.gz
gentoo-2-7214e9dd43181a86863af5f6428e701d36c24613.tar.bz2
gentoo-2-7214e9dd43181a86863af5f6428e701d36c24613.zip
Fix building against sys-libs/ncurses[tinfo] (bug #527160).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-editors/hexcurse')
-rw-r--r--app-editors/hexcurse/ChangeLog8
-rw-r--r--app-editors/hexcurse/files/1.55-gcc.patch4
-rw-r--r--app-editors/hexcurse/files/1.55-tinfo.patch11
-rw-r--r--app-editors/hexcurse/hexcurse-1.55.ebuild23
4 files changed, 33 insertions, 13 deletions
diff --git a/app-editors/hexcurse/ChangeLog b/app-editors/hexcurse/ChangeLog
index 19c316f9e5e1..1e594743ccfb 100644
--- a/app-editors/hexcurse/ChangeLog
+++ b/app-editors/hexcurse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/hexcurse
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/ChangeLog,v 1.11 2010/01/01 20:59:18 fauli Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/ChangeLog,v 1.12 2014/10/27 23:25:27 jer Exp $
+
+ 27 Oct 2014; Jeroen Roovers <jer@gentoo.org> hexcurse-1.55.ebuild,
+ files/1.55-gcc.patch, +files/1.55-tinfo.patch:
+ Fix building against sys-libs/ncurses[tinfo] (bug #527160).
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> hexcurse-1.55.ebuild:
Transfer Prefix keywords
diff --git a/app-editors/hexcurse/files/1.55-gcc.patch b/app-editors/hexcurse/files/1.55-gcc.patch
index 5e1eade3a467..22b996b3437d 100644
--- a/app-editors/hexcurse/files/1.55-gcc.patch
+++ b/app-editors/hexcurse/files/1.55-gcc.patch
@@ -1,5 +1,5 @@
---- src/getopt.c.orig 2002-03-21 17:55:54.000000000 +0100
-+++ src/getopt.c 2004-08-09 12:52:39.592951560 +0200
+--- a/src/getopt.c
++++ b/src/getopt.c
@@ -36,8 +36,6 @@
* enables hexcurse to be compiled with SGI's proprietary compiler */
#ifdef _SGIAPI
diff --git a/app-editors/hexcurse/files/1.55-tinfo.patch b/app-editors/hexcurse/files/1.55-tinfo.patch
new file mode 100644
index 000000000000..68d89a18e7e2
--- /dev/null
+++ b/app-editors/hexcurse/files/1.55-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -13,7 +13,7 @@
+
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -lncurses:
+-AC_CHECK_LIB(ncurses, initscr,,AC_CHECK_LIB(curses, initscr))
++PKG_CHECK_MODULES(ncurses,ncurses,LIBS="$LIBS $ncurses_LIBS",)
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
diff --git a/app-editors/hexcurse/hexcurse-1.55.ebuild b/app-editors/hexcurse/hexcurse-1.55.ebuild
index fb366df3369f..8da6fd2f9ba1 100644
--- a/app-editors/hexcurse/hexcurse-1.55.ebuild
+++ b/app-editors/hexcurse/hexcurse-1.55.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/hexcurse-1.55.ebuild,v 1.15 2010/01/01 20:59:18 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hexcurse/hexcurse-1.55.ebuild,v 1.16 2014/10/27 23:25:27 jer Exp $
-inherit eutils
+EAPI=5
+inherit autotools eutils
DESCRIPTION="ncurses based hex editor"
HOMEPAGE="http://www.jewfish.net/description.php?title=HexCurse"
@@ -11,14 +12,18 @@ SRC_URI="http://www.jewfish.net/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ppc s390 sh sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-DEPEND=">=sys-libs/ncurses-5.2"
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-gcc.patch
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-gcc.patch \
+ "${FILESDIR}"/${PV}-tinfo.patch
+ eautoreconf
}
src_install() {