summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-19 18:53:19 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-19 18:53:19 +0000
commit99e923d8b50fd2998991c2632c3605a43cc02b60 (patch)
tree94c46b79dc6c9ef7653cfd6d9b1bdd595ffa92be /app-editors/gvim
parentppc stable, bug #237362 (diff)
downloadgentoo-2-99e923d8b50fd2998991c2632c3605a43cc02b60.tar.gz
gentoo-2-99e923d8b50fd2998991c2632c3605a43cc02b60.tar.bz2
gentoo-2-99e923d8b50fd2998991c2632c3605a43cc02b60.zip
Version bump. Fixes #238120.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'app-editors/gvim')
-rw-r--r--app-editors/gvim/gvim-7.2.021.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-7.2.021.ebuild b/app-editors/gvim/gvim-7.2.021.ebuild
new file mode 100644
index 000000000000..edc761f8e7e6
--- /dev/null
+++ b/app-editors/gvim/gvim-7.2.021.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.2.021.ebuild,v 1.1 2008/09/19 18:53:19 hawking Exp $
+
+inherit vim
+
+VIM_VERSION="7.2"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r1"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-extra.tar.gz
+ mirror://gentoo/${VIM_GENTOO_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ x11-libs/libXext
+ !aqua? (
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ virtual/xft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? (
+ motif? (
+ x11-libs/openmotif
+ )
+ !motif? (
+ nextaw? (
+ x11-libs/neXtaw
+ )
+ !nextaw? ( x11-libs/libXaw )
+ )
+ )
+ )"