summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-09-06 17:53:59 +0000
committerTim Harder <radhermit@gentoo.org>2014-09-06 17:53:59 +0000
commit2f8ff1b7d4b6264b4585554530e432457b8f7443 (patch)
treecfc9a125524f449bb6e835df7e300bac27f81cc5 /app-editors/gvim
parentRevert to using a single, compressed patch file. (diff)
downloadgentoo-2-2f8ff1b7d4b6264b4585554530e432457b8f7443.tar.gz
gentoo-2-2f8ff1b7d4b6264b4585554530e432457b8f7443.tar.bz2
gentoo-2-2f8ff1b7d4b6264b4585554530e432457b8f7443.zip
Revert to using a single, compressed patch file.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'app-editors/gvim')
-rw-r--r--app-editors/gvim/ChangeLog6
-rw-r--r--app-editors/gvim/gvim-7.4.430.ebuild36
-rw-r--r--app-editors/gvim/gvim-9999.ebuild36
3 files changed, 31 insertions, 47 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index ab731e2c3d52..85832105bec4 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/gvim
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.436 2014/09/05 22:37:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.437 2014/09/06 17:53:59 radhermit Exp $
+
+ 06 Sep 2014; Tim Harder <radhermit@gentoo.org> gvim-7.4.430.ebuild,
+ gvim-9999.ebuild:
+ Revert to using a single, compressed patch file.
*gvim-7.4.430 (05 Sep 2014)
diff --git a/app-editors/gvim/gvim-7.4.430.ebuild b/app-editors/gvim/gvim-7.4.430.ebuild
index 604abafd23b6..d87f2d578d28 100644
--- a/app-editors/gvim/gvim-7.4.430.ebuild
+++ b/app-editors/gvim/gvim-7.4.430.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.4.430.ebuild,v 1.1 2014/09/05 22:37:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.4.430.ebuild,v 1.2 2014/09/06 17:53:59 radhermit Exp $
EAPI=5
VIM_VERSION="7.4"
@@ -8,22 +8,14 @@ PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
PYTHON_REQ_USE=threads
inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 prefix python-single-r1
-# Used for setting SRC_URI (when $1 is non-zero) and for outputting the patch names (for src_prepare)
-vim_src_uri_patches() {
- local i
- for (( i=1; i <= $(get_version_component_range 3); i++ )); do
- printf "${1:+${VIM_BASE_URI}/patches/${VIM_VERSION}/${VIM_VERSION}.%03d -> } vim-${VIM_VERSION}.%03d.patch\n" ${1:+"${i}"} "${i}"
- done
-}
-
if [[ ${PV} == 9999* ]] ; then
inherit mercurial
EHG_REPO_URI="https://vim.googlecode.com/hg/"
EHG_PROJECT="vim"
else
- VIM_BASE_URI="${VIM_BASE_URI:-ftp://ftp.vim.org/pub/vim}"
- SRC_URI="${VIM_BASE_URI}/unix/vim-${VIM_VERSION}.tar.bz2
- $(vim_src_uri_patches SRC_URI)
+ VIM_ORG_PATCHES="vim-patches-${PV}.patch.bz2"
+ SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ http://dev.gentoo.org/~radhermit/vim/${VIM_ORG_PATCHES}
http://dev.gentoo.org/~radhermit/vim/vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
fi
@@ -98,18 +90,16 @@ pkg_setup() {
src_prepare() {
if [[ ${PV} != 9999* ]] ; then
- # Apply any patches available from vim.org for this version
- local p patches
- for p in $(vim_src_uri_patches); do
- patches+=( "${DISTDIR}"/${p} )
- done
-
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- for p in "${WORKDIR}"/patches/*; do
- patches+=( "${p}" )
- done
+ if [[ -f "${WORKDIR}"/${VIM_ORG_PATCHES%.bz2} ]] ; then
+ # Apply any patches available from vim.org for this version
+ epatch "${WORKDIR}"/${VIM_ORG_PATCHES%.bz2}
+ fi
- epatch "${patches[@]}"
+ if [[ -d "${WORKDIR}"/patches/ ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patches/
+ fi
fi
# Fixup a script to use awk instead of nawk
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index acfcb6b45756..ea9356e31664 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-9999.ebuild,v 1.17 2014/09/05 22:37:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-9999.ebuild,v 1.18 2014/09/06 17:53:59 radhermit Exp $
EAPI=5
VIM_VERSION="7.4"
@@ -8,22 +8,14 @@ PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
PYTHON_REQ_USE=threads
inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 prefix python-single-r1
-# Used for setting SRC_URI (when $1 is non-zero) and for outputting the patch names (for src_prepare)
-vim_src_uri_patches() {
- local i
- for (( i=1; i <= $(get_version_component_range 3); i++ )); do
- printf "${1:+${VIM_BASE_URI}/patches/${VIM_VERSION}/${VIM_VERSION}.%03d -> } vim-${VIM_VERSION}.%03d.patch\n" ${1:+"${i}"} "${i}"
- done
-}
-
if [[ ${PV} == 9999* ]] ; then
inherit mercurial
EHG_REPO_URI="https://vim.googlecode.com/hg/"
EHG_PROJECT="vim"
else
- VIM_BASE_URI="${VIM_BASE_URI:-ftp://ftp.vim.org/pub/vim}"
- SRC_URI="${VIM_BASE_URI}/unix/vim-${VIM_VERSION}.tar.bz2
- $(vim_src_uri_patches SRC_URI)
+ VIM_ORG_PATCHES="vim-patches-${PV}.patch.bz2"
+ SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ http://dev.gentoo.org/~radhermit/vim/${VIM_ORG_PATCHES}
http://dev.gentoo.org/~radhermit/vim/vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
fi
@@ -98,18 +90,16 @@ pkg_setup() {
src_prepare() {
if [[ ${PV} != 9999* ]] ; then
- # Apply any patches available from vim.org for this version
- local p patches
- for p in $(vim_src_uri_patches); do
- patches+=( "${DISTDIR}"/${p} )
- done
-
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- for p in "${WORKDIR}"/patches/*; do
- patches+=( "${p}" )
- done
+ if [[ -f "${WORKDIR}"/${VIM_ORG_PATCHES%.bz2} ]] ; then
+ # Apply any patches available from vim.org for this version
+ epatch "${WORKDIR}"/${VIM_ORG_PATCHES%.bz2}
+ fi
- epatch "${patches[@]}"
+ if [[ -d "${WORKDIR}"/patches/ ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patches/
+ fi
fi
# Fixup a script to use awk instead of nawk