summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-02-21 18:50:14 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-02-21 18:50:14 +0000
commit4eaa423c58e93e2e7874fb163de9e92fed78f40f (patch)
tree4a4d8f4637d6dd30cfd80b28d141138b76489f2c /app-editors/gummi
parentVersion bump: Add a gnome-bluetooth plugin to configure new paired phones (be... (diff)
downloadgentoo-2-4eaa423c58e93e2e7874fb163de9e92fed78f40f.tar.gz
gentoo-2-4eaa423c58e93e2e7874fb163de9e92fed78f40f.tar.bz2
gentoo-2-4eaa423c58e93e2e7874fb163de9e92fed78f40f.zip
Revision bump including a patch sent from upstream developer
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gummi')
-rw-r--r--app-editors/gummi/ChangeLog8
-rw-r--r--app-editors/gummi/files/gummi-0.5.5-halt-on-error.patch10
-rw-r--r--app-editors/gummi/gummi-0.5.5-r1.ebuild49
3 files changed, 66 insertions, 1 deletions
diff --git a/app-editors/gummi/ChangeLog b/app-editors/gummi/ChangeLog
index 08b694839a01..064db1a52bac 100644
--- a/app-editors/gummi/ChangeLog
+++ b/app-editors/gummi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/gummi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.15 2011/01/25 12:49:20 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.16 2011/02/21 18:50:14 hwoarang Exp $
+
+*gummi-0.5.5-r1 (21 Feb 2011)
+
+ 21 Feb 2011; Markos Chandras <hwoarang@gentoo.org> +gummi-0.5.5-r1.ebuild,
+ +files/gummi-0.5.5-halt-on-error.patch:
+ Revision bump including a patch sent from upstream developer
25 Jan 2011; Christian Faulhammer <fauli@gentoo.org> gummi-0.5.5.ebuild:
stable x86, bug 352013
diff --git a/app-editors/gummi/files/gummi-0.5.5-halt-on-error.patch b/app-editors/gummi/files/gummi-0.5.5-halt-on-error.patch
new file mode 100644
index 000000000000..afba65dc790c
--- /dev/null
+++ b/app-editors/gummi/files/gummi-0.5.5-halt-on-error.patch
@@ -0,0 +1,10 @@
+--- src/blaat.c 2011-02-21 11:42:27.338945549 +0100
++++ src/latex.c 2011-02-21 11:34:41.429770215 +0100
+@@ -97,6 +97,7 @@
+ "env openout_any=a %s "
+ "-interaction=nonstopmode "
+ "-file-line-error "
++ "-halt-on-error"
+ "%s "
+ "-output-directory=\"%s\" \"%s\"",
+ dirname,
diff --git a/app-editors/gummi/gummi-0.5.5-r1.ebuild b/app-editors/gummi/gummi-0.5.5-r1.ebuild
new file mode 100644
index 000000000000..4decdee44a3e
--- /dev/null
+++ b/app-editors/gummi/gummi-0.5.5-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/gummi-0.5.5-r1.ebuild,v 1.1 2011/02/21 18:50:14 hwoarang Exp $
+
+EAPI=2
+inherit base eutils
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="http://gummi.midnightcoding.org"
+SRC_URI="http://dev.midnightcoding.org/redmine/attachments/download/111/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="ca da de fr el es it nl pl pt_BR ro ru zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="app-text/gtkspell
+ >=dev-libs/glib-2.16:2
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ >=x11-libs/gtk+-2.16:2
+ x11-libs/gtksourceview"
+DEPEND="${RDEPEND}
+ app-text/poppler[cairo]
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+
+DOCS=( AUTHORS ChangeLog README )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-halt-on-error.patch
+)
+
+src_prepare() {
+ strip-linguas ${LANGS}
+ base_src_prepare
+}
+
+pkg_postinst() {
+ elog "Gummi >=0.4.8 supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-** packages"
+ elog "for your language of choice."
+}