summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-08-27 20:01:57 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-08-27 20:01:57 +0000
commitca110585082534c1030997c4c4ad20439e238d0e (patch)
treec6bcd47a67fdce8fe2376a1180822ea429ab6b61 /app-editors/gphpedit
parentStable for HPPA (bug #145047). (diff)
downloadgentoo-2-ca110585082534c1030997c4c4ad20439e238d0e.tar.gz
gentoo-2-ca110585082534c1030997c4c4ad20439e238d0e.tar.bz2
gentoo-2-ca110585082534c1030997c4c4ad20439e238d0e.zip
version bump; should resolve crasher noted in bug #120727
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'app-editors/gphpedit')
-rw-r--r--app-editors/gphpedit/ChangeLog8
-rw-r--r--app-editors/gphpedit/files/digest-gphpedit-0.9.913
-rw-r--r--app-editors/gphpedit/files/gphpedit-0.9.91-empty-apply-prefs.patch32
-rw-r--r--app-editors/gphpedit/gphpedit-0.9.91.ebuild32
4 files changed, 74 insertions, 1 deletions
diff --git a/app-editors/gphpedit/ChangeLog b/app-editors/gphpedit/ChangeLog
index e8e9404b21da..452aa4a0b97d 100644
--- a/app-editors/gphpedit/ChangeLog
+++ b/app-editors/gphpedit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/gphpedit
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gphpedit/ChangeLog,v 1.12 2006/02/24 00:33:33 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gphpedit/ChangeLog,v 1.13 2006/08/27 20:01:57 compnerd Exp $
+
+*gphpedit-0.9.91 (27 Aug 2006)
+
+ 27 Aug 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/gphpedit-0.9.91-empty-apply-prefs.patch, +gphpedit-0.9.91.ebuild:
+ Version bump; should fix the crasher in 0.9.80
24 Feb 2006; John N. Laliberte <allanonjl@gentoo.org>
gphpedit-0.9.80.ebuild:
diff --git a/app-editors/gphpedit/files/digest-gphpedit-0.9.91 b/app-editors/gphpedit/files/digest-gphpedit-0.9.91
new file mode 100644
index 000000000000..8b28a6215abc
--- /dev/null
+++ b/app-editors/gphpedit/files/digest-gphpedit-0.9.91
@@ -0,0 +1,3 @@
+MD5 eecd29e66b415246408b285f4edcb6a0 gphpedit-0.9.91.tar.gz 3327239
+RMD160 f837c821062722c627465741c0a0d5dc4fc84972 gphpedit-0.9.91.tar.gz 3327239
+SHA256 64b55916747171edf4cc1d90f038ca56b68d56d821e0b6c8f514266abb8e9b39 gphpedit-0.9.91.tar.gz 3327239
diff --git a/app-editors/gphpedit/files/gphpedit-0.9.91-empty-apply-prefs.patch b/app-editors/gphpedit/files/gphpedit-0.9.91-empty-apply-prefs.patch
new file mode 100644
index 000000000000..a7f516a0e0e8
--- /dev/null
+++ b/app-editors/gphpedit/files/gphpedit-0.9.91-empty-apply-prefs.patch
@@ -0,0 +1,32 @@
+--- src/tab.c 2006-08-27 14:29:01.000000000 -0500
++++ src/tab.c 2006-08-27 14:33:10.000000000 -0500
+@@ -759,17 +759,21 @@
+ }
+ gtk_scintilla_get_text(GTK_SCINTILLA(editor->scintilla), text_length+1, buffer);
+ lines = g_strsplit(buffer, "\n", 10);
+- if (lines[0][0] == '#' && lines[0][1] == '!' && strstr(lines[0], "php") != NULL) {
+- is_php = TRUE;
+- }
+- else {
+- for (i = 0; lines[i+1] != NULL; i++) {
+- if (strstr (lines[i], "<?php") != NULL) {
+- is_php = TRUE;
+- break;
++
++ if (lines[0] != NULL) {
++ if (lines[0][0] == '#' && lines[0][1] == '!' && strstr(lines[0], "php") != NULL) {
++ is_php = TRUE;
++ }
++ else {
++ for (i = 0; lines[i+1] != NULL; i++) {
++ if (strstr (lines[i], "<?php") != NULL) {
++ is_php = TRUE;
++ break;
++ }
+ }
+ }
+ }
++
+ g_strfreev(lines);
+ }
+
diff --git a/app-editors/gphpedit/gphpedit-0.9.91.ebuild b/app-editors/gphpedit/gphpedit-0.9.91.ebuild
new file mode 100644
index 000000000000..051ddb8ed817
--- /dev/null
+++ b/app-editors/gphpedit/gphpedit-0.9.91.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gphpedit/gphpedit-0.9.91.ebuild,v 1.1 2006/08/27 20:01:57 compnerd Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="A Gnome2 PHP/HTML source editor"
+HOMEPAGE="http://www.gphpedit.org/"
+SRC_URI="http://www.gphpedit.org/download/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/gnome-vfs-2.0
+ =gnome-extra/gtkhtml-2*"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS ChangeLog README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-0.9.91-empty-apply-prefs.patch
+}