summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-18 09:01:05 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-18 09:01:05 +0000
commitec14dfbc70c5a1104af0e5e8804adcd83de9a13b (patch)
tree8f530e3d670f91b13ef664c1d2cc3d12015185bc /app-editors/gobby
parentRemove old (diff)
downloadgentoo-2-ec14dfbc70c5a1104af0e5e8804adcd83de9a13b.tar.gz
gentoo-2-ec14dfbc70c5a1104af0e5e8804adcd83de9a13b.tar.bz2
gentoo-2-ec14dfbc70c5a1104af0e5e8804adcd83de9a13b.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gobby')
-rw-r--r--app-editors/gobby/ChangeLog7
-rw-r--r--app-editors/gobby/gobby-0.4.93.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/app-editors/gobby/ChangeLog b/app-editors/gobby/ChangeLog
index 181bdb01e322..32d8bcdfac30 100644
--- a/app-editors/gobby/ChangeLog
+++ b/app-editors/gobby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gobby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.38 2010/06/13 09:07:57 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.39 2010/06/18 09:01:05 xarthisius Exp $
+
+*gobby-0.4.93 (18 Jun 2010)
+
+ 18 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> +gobby-0.4.93.ebuild:
+ Version bump
13 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> metadata.xml:
Add dev-zero and myself as maintainers
diff --git a/app-editors/gobby/gobby-0.4.93.ebuild b/app-editors/gobby/gobby-0.4.93.ebuild
new file mode 100644
index 000000000000..25bf4c37f273
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.93.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.93.ebuild,v 1.1 2010/06/18 09:01:05 xarthisius Exp $
+
+EAPI="2"
+
+inherit base eutils
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0.5"
+KEYWORDS="~amd64"
+IUSE="avahi gnome"
+
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/libsigc++:2
+ >=net-libs/libinfinity-0.4[gtk,avahi?]
+ dev-cpp/libxmlpp:2.6
+ x11-libs/gtksourceview:2.0
+ gnome? ( gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# There's only one test and it needs X
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_with gnome)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ domenu contrib/gobby-0.5.desktop
+}