summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-18 11:41:19 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-18 11:41:19 +0000
commit76bb6a006bab41d907e94540200f25d99999a901 (patch)
treee7c190e686c02ce0e132b58630d13a52bbff351a /app-editors/gobby
parentx86 stable wrt bug #323579 (diff)
downloadgentoo-2-76bb6a006bab41d907e94540200f25d99999a901.tar.gz
gentoo-2-76bb6a006bab41d907e94540200f25d99999a901.tar.bz2
gentoo-2-76bb6a006bab41d907e94540200f25d99999a901.zip
Using gnome2-utils instead of gnome2 to update icon cache. Move gettext out of runtime dependencies
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gobby')
-rw-r--r--app-editors/gobby/ChangeLog6
-rw-r--r--app-editors/gobby/gobby-0.4.93.ebuild22
2 files changed, 22 insertions, 6 deletions
diff --git a/app-editors/gobby/ChangeLog b/app-editors/gobby/ChangeLog
index 08074f9e2e7d..636cf004d07a 100644
--- a/app-editors/gobby/ChangeLog
+++ b/app-editors/gobby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/gobby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.41 2010/06/18 10:52:45 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.42 2010/06/18 11:41:19 xarthisius Exp $
+
+ 18 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> gobby-0.4.93.ebuild:
+ Using gnome2-utils instead of gnome2 to update icon cache. Move gettext
+ out of runtime dependencies
18 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> gobby-0.4.93.ebuild:
Updating dependencies, adding gnome2 for icon handling, keywording on ~x86
diff --git a/app-editors/gobby/gobby-0.4.93.ebuild b/app-editors/gobby/gobby-0.4.93.ebuild
index 80d29f6d2182..00419a413b55 100644
--- a/app-editors/gobby/gobby-0.4.93.ebuild
+++ b/app-editors/gobby/gobby-0.4.93.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.93.ebuild,v 1.2 2010/06/18 10:52:45 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.93.ebuild,v 1.3 2010/06/18 11:41:19 xarthisius Exp $
EAPI=2
-inherit eutils gnome2
+inherit eutils gnome2-utils
DESCRIPTION="GTK-based collaborative editor"
HOMEPAGE="http://gobby.0x539.de/"
@@ -19,14 +19,14 @@ RDEPEND="dev-cpp/glibmm:2
dev-libs/libsigc++:2
>=net-libs/libinfinity-0.4[gtk,avahi?]
dev-cpp/libxmlpp:2.6
- x11-libs/gtksourceview:2.0
- nls? ( >=sys-devel/gettext-0.12.1 )"
+ x11-libs/gtksourceview:2.0"
DEPEND="${RDEPEND}
dev-util/pkgconfig
doc? (
app-text/gnome-doc-utils
app-text/scrollkeeper
- )"
+ )
+ nls? ( >=sys-devel/gettext-0.12.1 )"
src_configure() {
econf $(use_enable nls)
@@ -37,3 +37,15 @@ src_install() {
domenu contrib/gobby-0.5.desktop
doicon gobby-0.5.xpm
}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}