summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-26 18:08:28 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-26 18:08:28 +0000
commit89914d5fbc87bf6f67c181de1581cd5c4abdc711 (patch)
treeea20ff3dcc2d81b81ae2e53e162c7a73016c02a6 /app-editors/ghex
parentRemove old (diff)
downloadgentoo-2-89914d5fbc87bf6f67c181de1581cd5c4abdc711.tar.gz
gentoo-2-89914d5fbc87bf6f67c181de1581cd5c4abdc711.tar.bz2
gentoo-2-89914d5fbc87bf6f67c181de1581cd5c4abdc711.zip
Version bump, it finally drops RDEPEND on old libgnomeprint stuff and other deprecated packages.
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/ghex')
-rw-r--r--app-editors/ghex/ChangeLog8
-rw-r--r--app-editors/ghex/ghex-3.0.0.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/app-editors/ghex/ChangeLog b/app-editors/ghex/ChangeLog
index 3eab4451d343..b48be8946fbf 100644
--- a/app-editors/ghex/ChangeLog
+++ b/app-editors/ghex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/ghex
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ChangeLog,v 1.62 2011/01/24 13:12:44 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ChangeLog,v 1.63 2011/09/26 18:08:28 pacho Exp $
+
+*ghex-3.0.0 (26 Sep 2011)
+
+ 26 Sep 2011; Pacho Ramos <pacho@gentoo.org> +ghex-3.0.0.ebuild:
+ Version bump, it finally drops RDEPEND on old libgnomeprint stuff and other
+ deprecated packages.
24 Jan 2011; Gilles Dartiguelongue <eva@gentoo.org> ghex-2.24.0.ebuild:
Pin gtk+ dependency to slot 2. Update ebuild to EAPI 3.
diff --git a/app-editors/ghex/ghex-3.0.0.ebuild b/app-editors/ghex/ghex-3.0.0.ebuild
new file mode 100644
index 000000000000..ec737a9eb125
--- /dev/null
+++ b/app-editors/ghex/ghex-3.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ghex/ghex-3.0.0.ebuild,v 1.1 2011/09/26 18:08:28 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Gnome hexadecimal editor"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-3.0:3
+ dev-libs/popt
+ >=dev-libs/atk-1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.41.1
+ >=app-text/gnome-doc-utils-0.9.0
+ >=sys-devel/gettext-0.17"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="${G2CONF} --disable-static"
+}