summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-22 23:29:43 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-22 23:29:43 +0000
commit9359382ef79ba6f287c729bc9423cf99619835a1 (patch)
tree1fcefab81d3745431cac47051ed46b6b052b2982 /app-editors/gedit
parentVersion bump with some bugfixes and updated python and php highlighting. (diff)
downloadgentoo-2-9359382ef79ba6f287c729bc9423cf99619835a1.tar.gz
gentoo-2-9359382ef79ba6f287c729bc9423cf99619835a1.tar.bz2
gentoo-2-9359382ef79ba6f287c729bc9423cf99619835a1.zip
Version bump with assorted bugfixes and UI improvements.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog8
-rw-r--r--app-editors/gedit/gedit-3.4.1.ebuild (renamed from app-editors/gedit/gedit-3.2.5.ebuild)28
2 files changed, 18 insertions, 18 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index 6f6dfe300f65..f61c6f495a48 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.336 2012/02/07 20:55:15 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.337 2012/04/22 23:29:43 tetromino Exp $
+
+*gedit-3.4.1 (22 Apr 2012)
+
+ 22 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org> -gedit-3.2.5.ebuild,
+ +gedit-3.4.1.ebuild:
+ Version bump with assorted bugfixes and UI improvements.
07 Feb 2012; Alexandre Rostovtsev <tetromino@gentoo.org> gedit-2.30.4.ebuild,
gedit-3.2.5.ebuild, gedit-3.2.6.ebuild:
diff --git a/app-editors/gedit/gedit-3.2.5.ebuild b/app-editors/gedit/gedit-3.4.1.ebuild
index 1ac914862a2b..b826cad47010 100644
--- a/app-editors/gedit/gedit-3.2.5.ebuild
+++ b/app-editors/gedit/gedit-3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.2.5.ebuild,v 1.3 2012/02/07 20:55:15 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.4.1.ebuild,v 1.1 2012/04/22 23:29:43 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.gnome.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc +introspection +python spell"
+IUSE="doc +introspection +python spell zeitgeist"
KEYWORDS="~amd64 ~mips ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
# X libs are not needed for OSX (aqua)
@@ -22,7 +22,7 @@ COMMON_DEPEND="
>=x11-libs/libSM-1.0
>=dev-libs/libxml2-2.5.0:2
>=dev-libs/glib-2.28:2
- >=x11-libs/gtk+-3.1.6:3[introspection?]
+ >=x11-libs/gtk+-3.3.15:3[introspection?]
>=x11-libs/gtksourceview-3.0.0:3.0[introspection?]
>=dev-libs/libpeas-1.1.0[gtk]
@@ -44,35 +44,34 @@ COMMON_DEPEND="
>=dev-python/pygobject-3.0.0:3[cairo] )
spell? (
>=app-text/enchant-1.2
- >=app-text/iso-codes-0.35
- )"
+ >=app-text/iso-codes-0.35 )
+ zeitgeist? ( dev-libs/libzeitgeist )"
RDEPEND="${COMMON_DEPEND}
x11-themes/gnome-icon-theme-symbolic"
DEPEND="${COMMON_DEPEND}
>=sys-devel/gettext-0.17
+ dev-libs/libxml2
>=dev-util/intltool-0.40
+ dev-util/itstool
>=dev-util/pkgconfig-0.9
>=app-text/scrollkeeper-0.3.11
- >=app-text/gnome-doc-utils-0.9.0
~app-text/docbook-xml-dtd-4.1.2
doc? ( >=dev-util/gtk-doc-1 )"
-# gnome-common and gtk-doc-am needed to eautoreconf
+# yelp-tools, gnome-common and gtk-doc-am needed to eautoreconf
pkg_setup() {
DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
- # TODO: Zeitgeist support, if GNOME 3 adds it to moduleset (3.2?)
G2CONF="${G2CONF}
- --disable-zeitgeist
--disable-deprecations
--disable-schemas-compile
- --disable-scrollkeeper
--enable-updater
--enable-gvfs-metadata
$(use_enable introspection)
$(use_enable python)
- $(use_enable spell)"
+ $(use_enable spell)
+ $(use_enable zeitgeist)"
python_set_active_version 2
python_pkg_setup
@@ -81,11 +80,7 @@ pkg_setup() {
src_prepare() {
gnome2_src_prepare
- # disable pyc compiling
- echo > py-compile
-
- # Fix missing file in POTFILES.in
- echo "plugins/quickopen/quickopen/__init__.py" >> po/POTFILES.in
+ use python && python_clean_py-compile_files
}
src_test() {
@@ -102,7 +97,6 @@ pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/gedit/plugins
# FIXME: take care of gi.overrides with USE=introspection
fi
-
}
pkg_postrm() {