summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-16 20:58:56 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-16 20:58:56 +0000
commit17830a8f7f017a46b8d6f6c6d1abf45ea426e2cd (patch)
tree1e3c253104f421423d136793ce140520966dc202 /app-editors/gedit
parentVersion bump. (diff)
downloadgentoo-2-17830a8f7f017a46b8d6f6c6d1abf45ea426e2cd.tar.gz
gentoo-2-17830a8f7f017a46b8d6f6c6d1abf45ea426e2cd.tar.bz2
gentoo-2-17830a8f7f017a46b8d6f6c6d1abf45ea426e2cd.zip
Bump to 3.0.6, from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog8
-rw-r--r--app-editors/gedit/gedit-3.0.6.ebuild109
-rw-r--r--app-editors/gedit/metadata.xml6
3 files changed, 121 insertions, 2 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index 7fa7a63081b2..0a41ea564b5a 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.328 2011/04/08 12:12:35 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.329 2011/08/16 20:58:56 nirbheek Exp $
+
+*gedit-3.0.6 (16 Aug 2011)
+
+ 16 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +gedit-3.0.6.ebuild,
+ metadata.xml:
+ Bump to 3.0.6, from gnome overlay for GNOME 3
08 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org> -gedit-2.30.3.ebuild:
Clean up old revision.
diff --git a/app-editors/gedit/gedit-3.0.6.ebuild b/app-editors/gedit/gedit-3.0.6.ebuild
new file mode 100644
index 000000000000..f64d905d4d07
--- /dev/null
+++ b/app-editors/gedit/gedit-3.0.6.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.0.6.ebuild,v 1.1 2011/08/16 20:58:56 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="xz"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_DEPEND="2"
+
+inherit gnome2 python eutils virtualx
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc +introspection python spell"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+
+# X libs are not needed for OSX (aqua)
+RDEPEND="
+ >=x11-libs/libSM-1.0
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.0:3[introspection?]
+ >=x11-libs/gtksourceview-3.0.0:3.0[introspection?]
+ >=dev-libs/libpeas-0.7.3[gtk]
+
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+
+ net-libs/libsoup:2.4
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ python? (
+ >=dev-libs/gobject-introspection-0.9.3
+ >=x11-libs/gtk+-3.0:3[introspection]
+ >=x11-libs/gtksourceview-2.91.9:3.0[introspection]
+ >=dev-libs/libpeas-0.7.4[gtk]
+ >=dev-python/pygobject-2.28.0[introspection] )
+ spell? (
+ >=app-text/enchant-1.2
+ >=app-text/iso-codes-0.35
+ )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ >=app-text/scrollkeeper-0.3.11
+ >=app-text/gnome-doc-utils-0.9.0
+ ~app-text/docbook-xml-dtd-4.1.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+# gnome-common and gtk-doc-am needed to eautoreconf
+
+pkg_setup() {
+ DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+ # TODO: Zeitgeist support, if GNOME 3 adds it to moduleset (3.2?)
+ G2CONF="${G2CONF}
+ --disable-zeitgeist
+ --disable-deprecations
+ --disable-maintainer-mode
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --enable-updater
+ --enable-gvfs-metadata
+ $(use_enable introspection)
+ $(use_enable spell)"
+
+ if use python || use introspection; then
+ python_set_active_version 2
+ fi
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check || die "make check failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_mod_optimize /usr/$(get_libdir)/gedit/plugins
+ # FIXME: take care of gi.overrides with USE=introspection
+ fi
+
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ if use python; then
+ python_mod_cleanup /usr/$(get_libdir)/gedit/plugins
+ fi
+}
diff --git a/app-editors/gedit/metadata.xml b/app-editors/gedit/metadata.xml
index da6fd63d0085..44825d13c084 100644
--- a/app-editors/gedit/metadata.xml
+++ b/app-editors/gedit/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>gnome</herd>
+ <herd>gnome</herd>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ </use>
</pkgmetadata>