summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-13 17:28:42 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-13 17:28:42 +0000
commit07059a0f0fc17e37cd39a03d100d029a1ee57800 (patch)
tree9eb83a942ed7810dac1b995c6da3a64024b76ffd /app-editors/gedit
parentAdd missing pycairo dep; modernize py-compile fix. (diff)
downloadgentoo-2-07059a0f0fc17e37cd39a03d100d029a1ee57800.tar.gz
gentoo-2-07059a0f0fc17e37cd39a03d100d029a1ee57800.tar.bz2
gentoo-2-07059a0f0fc17e37cd39a03d100d029a1ee57800.zip
Add missing python cairo deps; modernize py-compile idiom.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog8
-rw-r--r--app-editors/gedit/gedit-3.2.3.ebuild10
-rw-r--r--app-editors/gedit/gedit-3.2.5.ebuild10
3 files changed, 16 insertions, 12 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index e3fcf1c81871..c665ee460685 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/gedit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.332 2011/12/21 23:00:58 eva Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.333 2012/01/13 17:28:42 tetromino Exp $
+
+ 13 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org> gedit-3.2.3.ebuild,
+ gedit-3.2.5.ebuild:
+ Add missing python cairo deps; modernize py-compile idiom.
*gedit-3.2.5 (21 Dec 2011)
diff --git a/app-editors/gedit/gedit-3.2.3.ebuild b/app-editors/gedit/gedit-3.2.3.ebuild
index 00ba14d5645f..d4a718d0dd31 100644
--- a/app-editors/gedit/gedit-3.2.3.ebuild
+++ b/app-editors/gedit/gedit-3.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.2.3.ebuild,v 1.1 2011/11/20 22:19:58 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.2.3.ebuild,v 1.2 2012/01/13 17:28:42 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -40,7 +40,8 @@ COMMON_DEPEND="
>=dev-libs/gobject-introspection-0.9.3
>=x11-libs/gtk+-3.0:3[introspection]
>=x11-libs/gtksourceview-2.91.9:3.0[introspection]
- >=dev-python/pygobject-3.0.0:3 )
+ dev-python/pycairo
+ >=dev-python/pygobject-3.0.0:3[cairo] )
spell? (
>=app-text/enchant-1.2
>=app-text/iso-codes-0.35
@@ -81,8 +82,7 @@ src_prepare() {
gnome2_src_prepare
# disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
+ echo > py-compile
}
src_test() {
diff --git a/app-editors/gedit/gedit-3.2.5.ebuild b/app-editors/gedit/gedit-3.2.5.ebuild
index e6dba6a3eeae..f5f2a59a957d 100644
--- a/app-editors/gedit/gedit-3.2.5.ebuild
+++ b/app-editors/gedit/gedit-3.2.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.2.5.ebuild,v 1.1 2011/12/21 23:00:58 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-3.2.5.ebuild,v 1.2 2012/01/13 17:28:42 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -40,7 +40,8 @@ COMMON_DEPEND="
>=dev-libs/gobject-introspection-0.9.3
>=x11-libs/gtk+-3.0:3[introspection]
>=x11-libs/gtksourceview-2.91.9:3.0[introspection]
- >=dev-python/pygobject-3.0.0:3 )
+ dev-python/pycairo
+ >=dev-python/pygobject-3.0.0:3[cairo] )
spell? (
>=app-text/enchant-1.2
>=app-text/iso-codes-0.35
@@ -81,8 +82,7 @@ src_prepare() {
gnome2_src_prepare
# disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
+ echo > py-compile
# Fix missing file in POTFILES.in
echo "plugins/quickopen/quickopen/__init__.py" >> po/POTFILES.in