summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-06-24 13:31:53 +0000
committerPacho Ramos <pacho@gentoo.org>2011-06-24 13:31:53 +0000
commit96dd9e970c46db8b3c8ff8be0389f72a5f390d18 (patch)
tree5389d46c9a205c1e1da9160ffd2ccf358f8231ca /app-editors/gedit-plugins
parentUse chromium-browser instead of chromium for GNOME default applications file.... (diff)
downloadgentoo-2-96dd9e970c46db8b3c8ff8be0389f72a5f390d18.tar.gz
gentoo-2-96dd9e970c46db8b3c8ff8be0389f72a5f390d18.tar.bz2
gentoo-2-96dd9e970c46db8b3c8ff8be0389f72a5f390d18.zip
Version bump and handle plugins better (bug #372511 by Sébastien Wilmet), thanks to Alexandre Rostovtsev for pointing to fixed ebuild. Take maintainership.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/ChangeLog10
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild86
-rw-r--r--app-editors/gedit-plugins/metadata.xml5
3 files changed, 96 insertions, 5 deletions
diff --git a/app-editors/gedit-plugins/ChangeLog b/app-editors/gedit-plugins/ChangeLog
index 4d70729177dd..4fa57d5dc2fc 100644
--- a/app-editors/gedit-plugins/ChangeLog
+++ b/app-editors/gedit-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/gedit-plugins
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.14 2011/05/02 19:12:17 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.15 2011/06/24 13:31:53 pacho Exp $
+
+*gedit-plugins-2.32.0 (24 Jun 2011)
+
+ 24 Jun 2011; Pacho Ramos <pacho@gentoo.org> +gedit-plugins-2.32.0.ebuild,
+ metadata.xml:
+ Version bump and handle plugins better (bug #372511 by Sébastien Wilmet),
+ thanks to Alexandre Rostovtsev for pointing to fixed ebuild. Take
+ maintainership.
02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gedit-plugins-2.30.0.ebuild:
diff --git a/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild
new file mode 100644
index 000000000000..69f4710cefe6
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild,v 1.1 2011/06/24 13:31:53 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="xml"
+PYTHON_USE_WITH_OPT="python"
+
+inherit gnome2 multilib python eutils
+
+DESCRIPTION="Offical plugins for gedit."
+HOMEPAGE="http://live.gnome.org/GeditPlugins"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE_plugins="charmap synctex terminal"
+IUSE="+python ${IUSE_plugins}"
+
+RDEPEND=">=x11-libs/gtk+-2.14:2
+ gnome-base/gconf
+ >=x11-libs/gtksourceview-2.6:2.0
+ >=app-editors/gedit-2.29.3[python]
+ >=dev-python/pygtk-2.14:2
+ python? ( >=dev-python/pygtksourceview-2.2:2 )
+ charmap? ( >=gnome-extra/gucharmap-2.23.0 )
+ synctex? ( >=dev-python/dbus-python-0.82 )
+ terminal? (
+ dev-python/gconf-python
+ >=x11-libs/vte-0.19.4:0[python]
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS ChangeLog*"
+
+ # DEFAULT_PLUGINS from configure.ac
+ # FIXME: 'taglist' breaks configure
+ local myplugins="bookmarks,showtabbar,drawspaces,wordcompletion"
+
+ # python plugins with no extra dependencies beyond what USE=python brings
+ use python && myplugins="${myplugins},bracketcompletion,codecomment,colorpicker,commander,joinlines,multiedit,textsize,sessionsaver,smartspaces"
+
+ # python plugins with extra dependencies
+ for plugin in ${IUSE_plugins/+}; do
+ use ${plugin} || continue
+ # FIXME: put in REQUIRED_USE when python.eclass supports EAPI4
+ if use python; then
+ myplugins="${myplugins},${plugin}"
+ else
+ ewarn "Plugin '${plugin}' auto-disabled due to USE=-python"
+ fi
+ done
+
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --with-plugins=${myplugins}
+ $(use_enable python)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/gedit-2/plugins
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/gedit-2/plugins
+}
diff --git a/app-editors/gedit-plugins/metadata.xml b/app-editors/gedit-plugins/metadata.xml
index 06f9256139af..6de0ab6a3ee8 100644
--- a/app-editors/gedit-plugins/metadata.xml
+++ b/app-editors/gedit-plugins/metadata.xml
@@ -2,10 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gnome</herd>
- <maintainer>
- <email>mrpouet@gentoo.org</email>
- <name>Romain Perier</name>
- </maintainer>
<longdescription>Official plugins for gedit</longdescription>
<use>
<flag name='bookmarks'>Advanced Bookmarking, it remembers all the bookmarks you ever toggled, highlights them in the text and allows you to navigate through a list with the navigation pane</flag>
@@ -16,6 +12,7 @@
<flag name='joinlines'>Join several lines or split long ones</flag>
<flag name='showtabbar'>Add a menu entry to show/hide the tabbar</flag>
<flag name='smartspaces'>Forget you're not using tabulations</flag>
+ <flag name='synctex'>Synchronize between LaTeX and PDF with gedit and evince</flag>
<flag name='terminal'>Embed a terminal in the bottom pane</flag>
</use>
</pkgmetadata>