summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-02-16 08:59:59 +0000
committerSamuli Suominen <drac@gentoo.org>2008-02-16 08:59:59 +0000
commitf14ae18e7ad0f051d46434a7324fb105285e8db3 (patch)
treeaedc3f3b5ed512d7d9235fad721510b510267a4e /app-editors/fte
parentAdd pth USE flag, as most application does not use this anyway (diff)
downloadgentoo-2-f14ae18e7ad0f051d46434a7324fb105285e8db3.tar.gz
gentoo-2-f14ae18e7ad0f051d46434a7324fb105285e8db3.tar.bz2
gentoo-2-f14ae18e7ad0f051d46434a7324fb105285e8db3.zip
Move -slang.patch to -r1, and remove unused versions.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-editors/fte')
-rw-r--r--app-editors/fte/ChangeLog9
-rw-r--r--app-editors/fte/files/configpath.patch13
-rw-r--r--app-editors/fte/fte-20020324-r2.ebuild89
-rw-r--r--app-editors/fte/fte-20051115-r1.ebuild (renamed from app-editors/fte/fte-20050108-r3.ebuild)46
-rw-r--r--app-editors/fte/fte-20051115.ebuild9
5 files changed, 37 insertions, 129 deletions
diff --git a/app-editors/fte/ChangeLog b/app-editors/fte/ChangeLog
index 34579c2cc871..bf5b6d6e278f 100644
--- a/app-editors/fte/ChangeLog
+++ b/app-editors/fte/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/fte
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.43 2008/02/09 11:52:30 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.44 2008/02/16 08:59:59 drac Exp $
+
+*fte-20051115-r1 (16 Feb 2008)
+
+ 16 Feb 2008; Samuli Suominen <drac@gentoo.org> -files/configpath.patch,
+ -fte-20020324-r2.ebuild, -fte-20050108-r3.ebuild, fte-20051115.ebuild,
+ +fte-20051115-r1.ebuild:
+ Move -slang.patch to -r1, and remove unused versions.
09 Feb 2008; Samuli Suominen <drac@gentoo.org> +files/fte-slang.patch,
fte-20051115.ebuild:
diff --git a/app-editors/fte/files/configpath.patch b/app-editors/fte/files/configpath.patch
deleted file mode 100644
index 168974b3f6a1..000000000000
--- a/app-editors/fte/files/configpath.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/cfte.cpp 2002-03-23 00:46:32.000000000 +0100
-+++ src/cfte.cpp.new 2004-03-17 15:25:13.170166354 +0100
-@@ -1756,8 +1756,8 @@
- //fprintf(stderr, "Looking for %s\n", Cfg);
- if (!FileExists(Cfg))
- {
-- // Okay, now try "local config".
-- sprintf(tmp, "%slocalconfig/%s", StartDir, CfgName);
-+ // Try at least one FHS compliant location
-+ sprintf(tmp, "/usr/share/fte/%s", CfgName);
- ExpandPath(tmp, Cfg);
- //fprintf(stderr, "Looking for %s\n", Cfg);
- if (!FileExists(Cfg))
diff --git a/app-editors/fte/fte-20020324-r2.ebuild b/app-editors/fte/fte-20020324-r2.ebuild
deleted file mode 100644
index fdc04682be3f..000000000000
--- a/app-editors/fte/fte-20020324-r2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20020324-r2.ebuild,v 1.10 2007/07/22 08:45:36 omp Exp $
-
-inherit eutils
-
-DESCRIPTION="Lightweight text-mode editor"
-HOMEPAGE="http://fte.sourceforge.net"
-SRC_URI="mirror://sourceforge/fte/${P}-src.zip
- mirror://sourceforge/fte/${P}-common.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="ppc -sparc x86"
-IUSE="gpm slang X"
-
-RDEPEND=">=sys-libs/ncurses-5.2
- X? (
- x11-libs/libXdmcp
- x11-libs/libXau
- x11-libs/libX11
- )
- gpm? ( >=sys-libs/gpm-1.20 )"
-DEPEND="${RDEPEND}
- slang? ( sys-libs/slang )
- app-arch/unzip"
-
-set_targets() {
- export TARGETS=""
- use slang && TARGETS="$TARGETS sfte"
- use X && TARGETS="$TARGETS xfte"
- use gpm && TARGETS="$TARGETS vfte"
-}
-
-src_unpack() {
- unpack fte-20020324-src.zip
- unpack fte-20020324-common.zip
-
- mv fte fte-20020324
-
- cd ${S}
-
- epatch ${FILESDIR}/configpath.patch
-
- set_targets
- sed \
- -e "s:@targets@:${TARGETS}:" \
- -e "s:@cflags@:${CFLAGS}:" \
- -i src/fte-unix.mak
-}
-
-src_compile() {
- DEFFLAGS="PREFIX=/usr CONFIGDIR=/usr/share/fte \
- DEFAULT_FTE_CONFIG=../config/main.fte OPTIMIZE="
-
- set_targets
- emake $DEFFLAGS TARGETS="$TARGETS" all || die
-}
-
-src_install() {
- local files
- into /usr
-
- set_targets
- files="${TARGETS} cfte compkeys"
-
- for i in ${files} ; do
- dobin src/$i ;
- done
-
- dobin ${FILESDIR}/fte
-
- dodoc Artistic CHANGES BUGS HISTORY README TODO
-
- keepdir etc/fte
-
- dodir usr/share/doc/${P}/html
- cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
-
- dodir usr/share/fte
- cp -R config/* ${D}/usr/share/fte
- rm -rf ${D}/usr/share/fte/CVS
-}
-
-pkg_postinst() {
- einfo "Compiling configuration..."
- cd /usr/share/fte
- /usr/bin/cfte main.fte /etc/fte/system.fterc
-}
diff --git a/app-editors/fte/fte-20050108-r3.ebuild b/app-editors/fte/fte-20051115-r1.ebuild
index 7034b5d6c1ab..663e4b512f5b 100644
--- a/app-editors/fte/fte-20050108-r3.ebuild
+++ b/app-editors/fte/fte-20051115-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20050108-r3.ebuild,v 1.6 2007/07/22 08:45:36 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20051115-r1.ebuild,v 1.1 2008/02/16 08:59:59 drac Exp $
inherit eutils
@@ -11,17 +11,19 @@ SRC_URI="mirror://sourceforge/fte/${P}-src.zip
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc -sparc x86"
+KEYWORDS="~alpha ~amd64 ~ppc -sparc ~x86"
IUSE="gpm slang X"
S=${WORKDIR}/${PN}
-RDEPEND="x11-libs/libXdmcp
- x11-libs/libXau
- x11-libs/libX11
- >=sys-libs/ncurses-5.2
+RDEPEND=">=sys-libs/ncurses-5.2
+ X? (
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ x11-libs/libX11
+ )
gpm? ( >=sys-libs/gpm-1.20 )"
DEPEND="${RDEPEND}
- slang? ( sys-libs/slang )
+ slang? ( >=sys-libs/slang-2.1.3 )
app-arch/unzip"
set_targets() {
@@ -36,10 +38,11 @@ src_unpack() {
unpack ${P}-src.zip
unpack ${P}-common.zip
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/fte-gcc34
- epatch ${FILESDIR}/${PN}-new_keyword.patch
+ epatch "${FILESDIR}"/fte-gcc34
+ epatch "${FILESDIR}"/${PN}-new_keyword.patch
+ epatch "${FILESDIR}"/${PN}-slang.patch
set_targets
sed \
@@ -75,32 +78,33 @@ src_compile() {
src_install() {
local files
+
+ keepdir /etc/fte
+
into /usr
set_targets
- files="${TARGETS} cfte compkeys"
+ files="${TARGETS} cfte"
for i in ${files} ; do
dobin src/$i ;
done
- dobin ${FILESDIR}/fte
+ dobin "${FILESDIR}"/fte
dodoc Artistic CHANGES BUGS HISTORY README TODO
-
- keepdir etc/fte
-
- dodir usr/share/doc/${P}/html
- cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
+ dohtml doc/*
dodir usr/share/fte
- cp -R config/* ${D}/usr/share/fte
- rm -rf ${D}/usr/share/fte/CVS
+ insinto /usr/share/fte
+ doins -r config/*
+
+ rm -rf "${D}"/usr/share/fte/CVS
}
pkg_postinst() {
ebegin "Compiling configuration"
- cd /usr/share/fte
+ cd /usr/share/fte || die "missing configuration dir"
/usr/bin/cfte main.fte /etc/fte/system.fterc
eend $?
}
diff --git a/app-editors/fte/fte-20051115.ebuild b/app-editors/fte/fte-20051115.ebuild
index c9ded0462b21..521965b47392 100644
--- a/app-editors/fte/fte-20051115.ebuild
+++ b/app-editors/fte/fte-20051115.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20051115.ebuild,v 1.8 2008/02/09 11:52:30 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20051115.ebuild,v 1.9 2008/02/16 08:59:59 drac Exp $
inherit eutils
@@ -23,7 +23,7 @@ RDEPEND=">=sys-libs/ncurses-5.2
)
gpm? ( >=sys-libs/gpm-1.20 )"
DEPEND="${RDEPEND}
- slang? ( sys-libs/slang )
+ slang? ( =sys-libs/slang-1* )
app-arch/unzip"
set_targets() {
@@ -42,7 +42,6 @@ src_unpack() {
epatch "${FILESDIR}"/fte-gcc34
epatch "${FILESDIR}"/${PN}-new_keyword.patch
- epatch "${FILESDIR}"/${PN}-slang.patch
set_targets
sed \
@@ -90,7 +89,7 @@ src_install() {
dobin src/$i ;
done
- dobin ${FILESDIR}/fte
+ dobin "${FILESDIR}"/fte
dodoc Artistic CHANGES BUGS HISTORY README TODO
dohtml doc/*
@@ -99,7 +98,7 @@ src_install() {
insinto /usr/share/fte
doins -r config/*
- rm -rf ${D}/usr/share/fte/CVS
+ rm -rf "${D}"/usr/share/fte/CVS
}
pkg_postinst() {