summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-05 23:32:28 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-08-05 23:32:28 +0000
commit5d47ce3eb34e8d86fccce74abe0faa67e6988aa4 (patch)
tree2efd4ac2cc6ceca0d937f5cf834feede3f8beda2 /app-editors/fte
parentVersion bump (diff)
downloadgentoo-2-5d47ce3eb34e8d86fccce74abe0faa67e6988aa4.tar.gz
gentoo-2-5d47ce3eb34e8d86fccce74abe0faa67e6988aa4.tar.bz2
gentoo-2-5d47ce3eb34e8d86fccce74abe0faa67e6988aa4.zip
EAPI bumped to 4, add prefix changes
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'app-editors/fte')
-rw-r--r--app-editors/fte/ChangeLog10
-rw-r--r--app-editors/fte/files/fte-interix.patch38
-rw-r--r--app-editors/fte/fte-20051115-r3.ebuild (renamed from app-editors/fte/fte-20051115-r2.ebuild)39
3 files changed, 70 insertions, 17 deletions
diff --git a/app-editors/fte/ChangeLog b/app-editors/fte/ChangeLog
index e0c364d63954..61495d02dcd9 100644
--- a/app-editors/fte/ChangeLog
+++ b/app-editors/fte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/fte
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.50 2011/01/10 16:18:31 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.51 2012/08/05 23:32:28 ottxor Exp $
+
+*fte-20051115-r3 (05 Aug 2012)
+
+ 05 Aug 2012; Christoph Junghans <ottxor@gentoo.org> +files/fte-interix.patch,
+ +fte-20051115-r3.ebuild, -fte-20051115-r2.ebuild:
+ EAPI bumped to 4, add prefix changes
10 Jan 2011; Jeroen Roovers <jer@gentoo.org> fte-20051115-r2.ebuild:
Fix obvious typo thanks to Paul Hartman and Rafał Mużyło (bug #350701).
diff --git a/app-editors/fte/files/fte-interix.patch b/app-editors/fte/files/fte-interix.patch
new file mode 100644
index 000000000000..1df0a49f488a
--- /dev/null
+++ b/app-editors/fte/files/fte-interix.patch
@@ -0,0 +1,38 @@
+https://sourceforge.net/tracker/?func=detail&aid=3554646&group_id=943&atid=100943
+
+diff -ru fte.orig/src/g_unix_pipe.cpp fte/src/g_unix_pipe.cpp
+--- fte.orig/src/g_unix_pipe.cpp 2008-04-03 13:33:49 +0200
++++ fte/src/g_unix_pipe.cpp 2008-04-03 13:34:20 +0200
+@@ -4,6 +4,10 @@
+ #include <signal.h>
+ #include <sys/wait.h>
+
++#ifdef __INTERIX
++# include <sys/time.h>
++#endif
++
+ #include "sysdep.h"
+ #include "c_config.h"
+ #include "console.h"
+diff -ru fte.orig/src/sysdep.h fte/src/sysdep.h
+--- fte.orig/src/sysdep.h 2008-04-03 13:33:58 +0200
++++ fte/src/sysdep.h 2008-04-03 13:30:43 +0200
+@@ -15,7 +15,7 @@
+ #include <stdlib.h>
+ #include <stdarg.h>
+ #include <string.h>
+-#if defined(AIX) || defined(SCO) || defined(NCR)
++#if defined(AIX) || defined(SCO) || defined(NCR) || defined(__INTERIX)
+ #include <strings.h>
+ #endif
+ #include <stdio.h>
+@@ -38,7 +38,8 @@
+ !defined(IRIX) && \
+ !defined(SCO) && \
+ !defined(SUNOS) && \
+- !defined(NCR)
++ !defined(NCR) && \
++ !defined(__INTERIX)
+ # error Target not supported.
+ #endif
+
diff --git a/app-editors/fte/fte-20051115-r2.ebuild b/app-editors/fte/fte-20051115-r3.ebuild
index 7baaecf0cb0f..3edcc66e1b87 100644
--- a/app-editors/fte/fte-20051115-r2.ebuild
+++ b/app-editors/fte/fte-20051115-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20051115-r2.ebuild,v 1.2 2011/01/10 16:18:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20051115-r3.ebuild,v 1.1 2012/08/05 23:32:28 ottxor Exp $
-EAPI="2"
+EAPI=4
inherit eutils toolchain-funcs
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/fte/${P}-src.zip
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc -sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc -sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="gpm slang X"
S="${WORKDIR}/${PN}"
@@ -35,15 +35,19 @@ set_targets() {
use slang && TARGETS="${TARGETS} sfte"
use X && TARGETS="${TARGETS} xfte"
- TARGETS="${TARGETS} vfte"
+ [[ ${CHOST} == *-linux-gnu* ]] \
+ && TARGETS="${TARGETS} vfte" \
+ || TARGETS="${TARGETS} nfte"
}
src_prepare() {
epatch "${FILESDIR}"/fte-gcc34
epatch "${FILESDIR}"/${PN}-new_keyword.patch
epatch "${FILESDIR}"/${PN}-slang.patch
+ epatch "${FILESDIR}"/${PN}-interix.patch
- sed /usr/include/linux/keyboard.h -e '/wait.h/d' > src/hacked_keyboard.h
+ [[ -e /usr/include/linux/keyboard.h ]] && \
+ sed /usr/include/linux/keyboard.h -e '/wait.h/d' > src/hacked_keyboard.h
sed \
-e "s:<linux/keyboard.h>:\"hacked_keyboard.h\":" \
@@ -59,6 +63,9 @@ src_configure() {
set_targets
sed \
-e "s:@targets@:${TARGETS}:" \
+ -e '/^XINCDIR =/c\XINCDIR =' \
+ -e '/^XLIBDIR =/c\XLIBDIR = -lstdc++' \
+ -e '/^SINCDIR =/c\SINCDIR = -I'"${EPREFIX}"'/usr/include/slang' \
-i src/fte-unix.mak || die "sed targets"
if ! use gpm; then
@@ -72,12 +79,14 @@ src_configure() {
}
src_compile() {
- DEFFLAGS="PREFIX=/usr CONFIGDIR=/usr/share/fte \
- DEFAULT_FTE_CONFIG=../config/main.fte"
+ local os="-DLINUX" # by now the default in makefile
+ [[ ${CHOST} == *-interix* ]] && os=
+
+ DEFFLAGS="PREFIX='${EPREFIX}'/usr CONFIGDIR='${EPREFIX}'/usr/share/fte \
+ DEFAULT_FTE_CONFIG=../config/main.fte UOS=${os}"
set_targets
- emake CXX=$(tc-getCXX) OPTIMIZE="${CXXFLAGS}" ${DEFFLAGS} TARGETS="${TARGETS}" \
- all || die "emake failed"
+ emake CXX=$(tc-getCXX) OPTIMIZE="${CXXFLAGS}" ${DEFFLAGS} TARGETS="${TARGETS}" all
}
src_install() {
@@ -91,10 +100,10 @@ src_install() {
files="${TARGETS} cfte"
for i in ${files}; do
- dobin src/$i || die "dobin ${i}"
+ dobin src/$i
done
- dobin "${FILESDIR}"/fte || die "dobin fte"
+ dobin "${FILESDIR}"/fte
dodoc Artistic CHANGES BUGS HISTORY README TODO
dohtml doc/*
@@ -103,12 +112,12 @@ src_install() {
insinto /usr/share/fte
doins -r config/*
- rm -rf "${D}"/usr/share/fte/CVS
+ rm -rf "${ED}"/usr/share/fte/CVS
}
pkg_postinst() {
ebegin "Compiling configuration"
- cd /usr/share/fte || die "missing configuration dir"
- /usr/bin/cfte main.fte /etc/fte/system.fterc
+ cd "${EPREFIX}"/usr/share/fte || die "missing configuration dir"
+ "${EPREFIX}"/usr/bin/cfte main.fte "${EPREFIX}"/etc/fte/system.fterc
eend $?
}