summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-13 22:30:18 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-13 22:30:18 +0000
commit2adaed7ce54e7a910bd2e3e46fd96686c1ea8568 (patch)
treeb2ae84c844e02474f75f423e71015289ba2a128a /app-editors/fte
parentFixed minor repoman warning. (diff)
downloadgentoo-2-2adaed7ce54e7a910bd2e3e46fd96686c1ea8568.tar.gz
gentoo-2-2adaed7ce54e7a910bd2e3e46fd96686c1ea8568.tar.bz2
gentoo-2-2adaed7ce54e7a910bd2e3e46fd96686c1ea8568.zip
Non-maintainer commit, version bump to 20110708.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-editors/fte')
-rw-r--r--app-editors/fte/ChangeLog9
-rw-r--r--app-editors/fte/fte-20110708.ebuild123
2 files changed, 130 insertions, 2 deletions
diff --git a/app-editors/fte/ChangeLog b/app-editors/fte/ChangeLog
index 153b773fecb5..ea5e1e95ac89 100644
--- a/app-editors/fte/ChangeLog
+++ b/app-editors/fte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/fte
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.56 2012/11/21 13:33:03 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/ChangeLog,v 1.57 2013/03/13 22:30:18 tomwij Exp $
+
+*fte-20110708 (13 Mar 2013)
+
+ 13 Mar 2013; Tom Wijsman <TomWij@gentoo.org> +fte-20110708.ebuild:
+ Non-maintainer commit, version bump to 20110708.
21 Nov 2012; Michael Palimaka <kensington@gentoo.org> -fte-20051115-r1.ebuild:
Remove old.
diff --git a/app-editors/fte/fte-20110708.ebuild b/app-editors/fte/fte-20110708.ebuild
new file mode 100644
index 000000000000..853fe3e2993a
--- /dev/null
+++ b/app-editors/fte/fte-20110708.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20110708.ebuild,v 1.1 2013/03/13 22:30:18 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Lightweight text-mode editor"
+HOMEPAGE="http://${PN}.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip
+ mirror://sourceforge/${PN}/${P}-common.zip"
+
+LICENSE="|| ( GPL-2 Artistic )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc -sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="gpm slang X"
+
+S="${WORKDIR}/${PN}"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ X? (
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXpm
+ )
+ gpm? ( >=sys-libs/gpm-1.20 )"
+DEPEND="${RDEPEND}
+ slang? ( >=sys-libs/slang-2.1.3 )
+ app-arch/unzip"
+
+set_targets() {
+ export TARGETS=""
+ use slang && TARGETS="${TARGETS} s${PN}"
+ use X && TARGETS="${TARGETS} x${PN}"
+
+ [[ ${CHOST} == *-linux-gnu* ]] \
+ && TARGETS="${TARGETS} v${PN}" \
+ || TARGETS="${TARGETS} n${PN}"
+}
+
+src_prepare() {
+ # Do not apply anymore, posibly deprecated. TODO: Check and clean up.
+ # epatch "${FILESDIR}"/${PN}-gcc34
+ # epatch "${FILESDIR}"/${PN}-new_keyword.patch
+ # epatch "${FILESDIR}"/${PN}-slang.patch
+ # epatch "${FILESDIR}"/${PN}-interix.patch
+
+ [[ -e /usr/include/linux/keyboard.h ]] && \
+ sed /usr/include/linux/keyboard.h -e '/wait.h/d' > src/hacked_keyboard.h
+
+ sed \
+ -e "s:<linux/keyboard.h>:\"hacked_keyboard.h\":" \
+ -i src/con_linux.cpp || die "sed keyboard"
+ sed \
+ -e 's:^OPTIMIZE:#&:g' \
+ -e '/^LDFLAGS/s:=:+=:g' \
+ -e 's:= g++:= $(CXX):g' \
+ -i src/${PN}-unix.mak || die "sed CFLAGS, LDFLAGS, CC"
+}
+
+src_configure() {
+ set_targets
+ sed \
+ -e "s:@targets@:${TARGETS}:" \
+ -e '/^XINCDIR =/c\XINCDIR =' \
+ -e '/^XLIBDIR =/c\XLIBDIR = -lstdc++' \
+ -e '/^SINCDIR =/c\SINCDIR = -I'"${EPREFIX}"'/usr/include/slang' \
+ -i src/${PN}-unix.mak || die "sed targets"
+
+ if ! use gpm; then
+ sed \
+ -e "s:#define USE_GPM://#define USE_GPM:" \
+ -i src/con_linux.cpp || die "sed USE_GPM"
+ sed \
+ -e "s:-lgpm::" \
+ -i src/fte-unix.mak || die "sed -lgpm"
+ fi
+}
+
+src_compile() {
+ local os="-DLINUX" # by now the default in makefile
+ [[ ${CHOST} == *-interix* ]] && os=
+
+ DEFFLAGS="PREFIX='${EPREFIX}'/usr CONFIGDIR='${EPREFIX}'/usr/share/${PN} \
+ DEFAULT_FTE_CONFIG=../config/main.${PN} UOS=${os}"
+
+ set_targets
+ emake CXX=$(tc-getCXX) OPTIMIZE="${CXXFLAGS}" ${DEFFLAGS} TARGETS="${TARGETS}" all
+}
+
+src_install() {
+ local files
+
+ keepdir /etc/${PN}
+
+ into /usr
+
+ set_targets
+ files="${TARGETS} c${PN}"
+
+ for i in ${files}; do
+ dobin src/$i
+ done
+
+ dobin "${FILESDIR}"/${PN}
+
+ dodoc BUGS README TODO
+ dohtml doc/*
+
+ insinto /usr/share/${PN}
+ doins -r config/*
+
+ rm -rf "${ED}"/usr/share/${PN}/CVS
+}
+
+pkg_postinst() {
+ ebegin "Compiling configuration"
+ cd "${EPREFIX}"/usr/share/${PN} || die "missing configuration dir"
+ "${EPREFIX}"/usr/bin/c${PN} main.${PN} "${EPREFIX}"/etc/${PN}/system.${PN}rc
+ eend $?
+}