summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-16 10:14:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-16 10:14:35 +0000
commit8091b8736a0945513bc827d1eae28d0b720fa2ef (patch)
tree7db3ceaebcb8ae5d9f5c5b5f7a045aed6d2592ed /app-editors/fe
parentBump (diff)
downloadgentoo-2-8091b8736a0945513bc827d1eae28d0b720fa2ef.tar.gz
gentoo-2-8091b8736a0945513bc827d1eae28d0b720fa2ef.tar.bz2
gentoo-2-8091b8736a0945513bc827d1eae28d0b720fa2ef.zip
Bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/fe')
-rw-r--r--app-editors/fe/ChangeLog9
-rw-r--r--app-editors/fe/fe-1.9.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/app-editors/fe/ChangeLog b/app-editors/fe/ChangeLog
index cc2cd84085e8..5cace064e64e 100644
--- a/app-editors/fe/ChangeLog
+++ b/app-editors/fe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/fe
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fe/ChangeLog,v 1.8 2011/08/27 19:12:54 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fe/ChangeLog,v 1.9 2012/03/16 10:14:35 patrick Exp $
+
+*fe-1.9 (16 Mar 2012)
+
+ 16 Mar 2012; Patrick Lauer <patrick@gentoo.org> +fe-1.9.ebuild:
+ Bump
27 Aug 2011; Ulrich Mueller <ulm@gentoo.org> -files/fe-1.6-nostrip.patch,
fe-1.8.ebuild, +files/fe-1.8-makefile.patch:
diff --git a/app-editors/fe/fe-1.9.ebuild b/app-editors/fe/fe-1.9.ebuild
new file mode 100644
index 000000000000..bb22e0f7b5e3
--- /dev/null
+++ b/app-editors/fe/fe-1.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fe/fe-1.9.ebuild,v 1.1 2012/03/16 10:14:35 patrick Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A small and easy to use folding editor"
+HOMEPAGE="http://www.moria.de/~michael/fe/"
+SRC_URI="http://www.moria.de/~michael/fe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sendmail"
+
+DEPEND="sys-libs/ncurses
+ sendmail? ( virtual/mta )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.8-makefile.patch"
+}
+
+src_configure() {
+ econf $(use_enable sendmail)
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ datadir="${D}"/usr/share \
+ MANDIR="${D}"/usr/share/man \
+ install
+
+ dodoc NEWS README
+ dohtml fe.html
+}