summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-06-14 13:15:46 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-06-14 13:15:46 +0000
commite8c28752e34af41b84c4dd31b2577e7f55bee314 (patch)
treec876779b3b35b42c88a1d836deadb773782140ec /app-editors/fb2edit
parenthardened/linux/uclibc/arm: drop support <arm6j, default to hardfloat (diff)
downloadgentoo-2-e8c28752e34af41b84c4dd31b2577e7f55bee314.tar.gz
gentoo-2-e8c28752e34af41b84c4dd31b2577e7f55bee314.tar.bz2
gentoo-2-e8c28752e34af41b84c4dd31b2577e7f55bee314.zip
Version bump
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-editors/fb2edit')
-rw-r--r--app-editors/fb2edit/ChangeLog7
-rw-r--r--app-editors/fb2edit/fb2edit-0.0.8.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/app-editors/fb2edit/ChangeLog b/app-editors/fb2edit/ChangeLog
index 650a312c232d..c8d4166568bd 100644
--- a/app-editors/fb2edit/ChangeLog
+++ b/app-editors/fb2edit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/fb2edit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fb2edit/ChangeLog,v 1.5 2013/04/20 10:11:24 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fb2edit/ChangeLog,v 1.6 2013/06/14 13:15:46 pinkbyte Exp $
+
+*fb2edit-0.0.8 (14 Jun 2013)
+
+ 14 Jun 2013; Sergey Popov <pinkbyte@gentoo.org> +fb2edit-0.0.8.ebuild:
+ Version bump
20 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> metadata.xml:
Add qt herd and upstream contacts to metadata
diff --git a/app-editors/fb2edit/fb2edit-0.0.8.ebuild b/app-editors/fb2edit/fb2edit-0.0.8.ebuild
new file mode 100644
index 000000000000..5ad4d6ab7edf
--- /dev/null
+++ b/app-editors/fb2edit/fb2edit-0.0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fb2edit/fb2edit-0.0.8.ebuild,v 1.1 2013/06/14 13:15:46 pinkbyte Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="a WYSIWYG FictionBook (fb2) editor"
+HOMEPAGE="http://fb2edit.lintest.ru/"
+SRC_URI="http://fb2edit.lintest.ru/pub/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libxml2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtxmlpatterns:4"
+RDEPEND="${DEPEND}
+ x11-themes/hicolor-icon-theme"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ # drop -g from CFLAGS
+ sed -i -e '/^add_definitions(-W/s/-g//' CMakeLists.txt || die 'sed failed'
+
+ cmake-utils_src_prepare
+}