summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-09-16 18:42:39 +0000
committerUlrich Müller <ulm@gentoo.org>2009-09-16 18:42:39 +0000
commitb995eb8be6adf2c355e2d1631f0dd8ade6c977ce (patch)
tree54c41283e4c39213747a52a7abaeadc72b45ce21 /app-editors/emacs
parent-p (diff)
downloadgentoo-2-b995eb8be6adf2c355e2d1631f0dd8ade6c977ce.tar.gz
gentoo-2-b995eb8be6adf2c355e2d1631f0dd8ade6c977ce.tar.bz2
gentoo-2-b995eb8be6adf2c355e2d1631f0dd8ade6c977ce.zip
Support 32 bit build on amd64. Add ~amd64 keyword, bug 166839.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog5
-rw-r--r--app-editors/emacs/emacs-18.59-r6.ebuild24
2 files changed, 21 insertions, 8 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 4edf22cd0927..7f30835d2ed7 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/emacs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.334 2009/09/15 22:57:38 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.335 2009/09/16 18:42:39 ulm Exp $
+
+ 16 Sep 2009; Ulrich Mueller <ulm@gentoo.org> emacs-18.59-r6.ebuild:
+ Support 32 bit build on amd64. Add ~amd64 keyword, bug 166839.
15 Sep 2009; Christian Faulhammer <fauli@gentoo.org> emacs-23.1.ebuild:
x86 stable, bug 285063
diff --git a/app-editors/emacs/emacs-18.59-r6.ebuild b/app-editors/emacs/emacs-18.59-r6.ebuild
index da14b573dbc9..4cf70db6a42c 100644
--- a/app-editors/emacs/emacs-18.59-r6.ebuild
+++ b/app-editors/emacs/emacs-18.59-r6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-18.59-r6.ebuild,v 1.3 2009/05/29 16:14:57 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-18.59-r6.ebuild,v 1.4 2009/09/16 18:42:39 ulm Exp $
EAPI=2
-inherit eutils toolchain-funcs flag-o-matic
+inherit eutils toolchain-funcs flag-o-matic multilib
DESCRIPTION="The extensible self-documenting text editor"
HOMEPAGE="http://www.gnu.org/software/emacs/"
@@ -14,12 +14,16 @@ SRC_URI="mirror://gnu/old-gnu/emacs/${P}.tar.gz
LICENSE="GPL-1 GPL-2 BSD as-is"
SLOT="18"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
IUSE="X"
RDEPEND="sys-libs/ncurses
>=app-admin/eselect-emacs-1.2
- X? ( x11-libs/libX11[-xcb] )"
+ X? ( x11-libs/libX11[-xcb] )
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs
+ X? ( app-emulation/emul-linux-x86-xlibs )
+ )"
DEPEND="${RDEPEND}"
MY_BASEDIR="/usr/share/emacs/${PV}"
@@ -31,11 +35,14 @@ src_prepare() {
}
src_configure() {
+ # Feel free to fix the sources to be 64 bit clean.
+ use amd64 && multilib_toolchain_setup x86
+
# autoconf? What's autoconf? We are living in 1992. ;-)
- local arch
- case ${ARCH} in
+ local arch=$(tc-arch)
+ case ${arch} in
x86) arch=intel386 ;;
- *) die "Architecture ${ARCH} not supported" ;;
+ *) die "Architecture ${arch} not supported" ;;
esac
local cmd="s/\"s-.*\.h\"/\"s-linux.h\"/;s/\"m-.*\.h\"/\"m-${arch}.h\"/"
use X && cmd="${cmd};s/.*\(#define HAVE_X_WINDOWS\).*/\1/"
@@ -48,6 +55,9 @@ src_configure() {
#define PATH_SUPERLOCK "${MY_LOCKDIR}/!!!SuperLock!!!"
END
+ sed -i -e "s:/usr/lib/\([^ ]*\).o:/usr/$(get_libdir)/\1.o:g" \
+ src/s-linux.h || die
+
# -O3 and -finline-functions cause segmentation faults at run time.
filter-flags -finline-functions
replace-flags -O[3-9] -O2