summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-16 05:01:21 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-16 05:01:21 +0000
commit786331c6be7cb34180ce20ad0b489d6304d2350e (patch)
tree3e98df623568a07a89cec024473d2a033bcd690d /app-editors/emacs
parent-ppc marked, subtle flaws here and there (Manifest recommit) (diff)
downloadgentoo-2-786331c6be7cb34180ce20ad0b489d6304d2350e.tar.gz
gentoo-2-786331c6be7cb34180ce20ad0b489d6304d2350e.tar.bz2
gentoo-2-786331c6be7cb34180ce20ad0b489d6304d2350e.zip
Fixed compile problem when lesstif USE flag is set but openmotif is not installed. This closes bug #67492.
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog7
-rw-r--r--app-editors/emacs/emacs-21.3-r3.ebuild5
-rw-r--r--app-editors/emacs/emacs-21.3-r4.ebuild5
3 files changed, 12 insertions, 5 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 7322075899ee..97b5eeb3a060 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.40 2004/10/13 22:22:12 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.41 2004/10/16 05:01:21 usata Exp $
+
+ 16 Oct 2004; Mamoru KOMACHI <usata@gentoo.org> emacs-21.3-r3.ebuild,
+ emacs-21.3-r4.ebuild:
+ Fixed compile problem when lesstif USE flag is set but openmotif is not
+ installed. This closes bug #67492.
14 Oct 2004; Mamoru KOMACHI <usata@gentoo.org> emacs-21.3-r4.ebuild:
Specify alternatives version explicitly.
diff --git a/app-editors/emacs/emacs-21.3-r3.ebuild b/app-editors/emacs/emacs-21.3-r3.ebuild
index 94c673e61355..777a104ef121 100644
--- a/app-editors/emacs/emacs-21.3-r3.ebuild
+++ b/app-editors/emacs/emacs-21.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r3.ebuild,v 1.11 2004/10/06 11:41:44 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r3.ebuild,v 1.12 2004/10/16 05:01:21 usata Exp $
inherit flag-o-matic eutils gcc
@@ -58,7 +58,8 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
if use X ; then
if use motif && use lesstif; then
- export LIBS="-L/usr/X11R6/lib/lesstif/"
+ append-ldflags -L/usr/X11R6/lib/lesstif -R/usr/X11R6/lib/lesstif
+ export CPPFLAGS="${CPPFLAGS} -I/usr/X11R6/include/lesstif"
fi
myconf="${myconf}
--with-x
diff --git a/app-editors/emacs/emacs-21.3-r4.ebuild b/app-editors/emacs/emacs-21.3-r4.ebuild
index 5c50bf2f5b15..defa3cdf96b7 100644
--- a/app-editors/emacs/emacs-21.3-r4.ebuild
+++ b/app-editors/emacs/emacs-21.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r4.ebuild,v 1.10 2004/10/13 22:22:12 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r4.ebuild,v 1.11 2004/10/16 05:01:21 usata Exp $
inherit flag-o-matic eutils alternatives gcc
@@ -61,7 +61,8 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
if use X ; then
if use motif && use lesstif; then
- export LIBS="-L/usr/X11R6/lib/lesstif/"
+ append-ldflags -L/usr/X11R6/lib/lesstif -R/usr/X11R6/lib/lesstif
+ export CPPFLAGS="${CPPFLAGS} -I/usr/X11R6/include/lesstif"
fi
myconf="${myconf}
--with-x