summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-03-19 21:35:54 +0000
committerUlrich Müller <ulm@gentoo.org>2013-03-19 21:35:54 +0000
commit36d3d9a3e8c121ebeeeaf45e01dfcedcca8e6e16 (patch)
treea0b323f7a25d75dc4c73d333580c1963ada91990 /app-editors/emacs
parentPrefer motif to athena if both USE flags are set. (diff)
downloadgentoo-2-36d3d9a3e8c121ebeeeaf45e01dfcedcca8e6e16.tar.gz
gentoo-2-36d3d9a3e8c121ebeeeaf45e01dfcedcca8e6e16.tar.bz2
gentoo-2-36d3d9a3e8c121ebeeeaf45e01dfcedcca8e6e16.zip
Prefer motif to athena if both USE flags are set.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog6
-rw-r--r--app-editors/emacs/emacs-23.4-r5.ebuild30
-rw-r--r--app-editors/emacs/emacs-24.3.ebuild30
3 files changed, 37 insertions, 29 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 4d8602d091cb..62c55ce05868 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.564 2013/03/18 23:13:13 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.565 2013/03/19 21:35:54 ulm Exp $
+
+ 19 Mar 2013; Ulrich Müller <ulm@gentoo.org> emacs-23.4-r5.ebuild,
+ emacs-24.3.ebuild:
+ Prefer motif to athena if both USE flags are set.
18 Mar 2013; Ulrich Müller <ulm@gentoo.org> emacs-18.59-r8.ebuild:
The emul-linux-x86 libs are not needed for the x32 ABI.
diff --git a/app-editors/emacs/emacs-23.4-r5.ebuild b/app-editors/emacs/emacs-23.4-r5.ebuild
index 9c920ae4d5bd..55bea525d838 100644
--- a/app-editors/emacs/emacs-23.4-r5.ebuild
+++ b/app-editors/emacs/emacs-23.4-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.4-r5.ebuild,v 1.14 2013/03/11 08:27:34 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.4-r5.ebuild,v 1.15 2013/03/19 21:35:54 ulm Exp $
EAPI=4
WANT_AUTOMAKE="none"
@@ -49,10 +49,10 @@ RDEPEND="sys-libs/ncurses
)
gtk? ( x11-libs/gtk+:2 )
!gtk? (
- Xaw3d? ( x11-libs/libXaw3d )
- !Xaw3d? (
- athena? ( x11-libs/libXaw )
- !athena? ( motif? ( >=x11-libs/motif-2.3:0 ) )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ Xaw3d? ( x11-libs/libXaw3d )
+ !Xaw3d? ( athena? ( x11-libs/libXaw ) )
)
)
)"
@@ -141,22 +141,24 @@ src_configure() {
# GTK+ is the default toolkit if USE=gtk is chosen with other
# possibilities. Emacs upstream thinks this should be standard
# policy on all distributions
+ local f
if use gtk; then
einfo "Configuring to build with GIMP Toolkit (GTK+)"
myconf="${myconf} --with-x-toolkit=gtk"
- local f
- for f in athena Xaw3d motif; do
- use ${f} && ewarn "USE flag \"${f}\" ignored" \
- "(superseded by \"gtk\")"
+ for f in motif Xaw3d athena; do
+ use ${f} && ewarn \
+ "USE flag \"${f}\" has no effect if \"gtk\" is set."
done
- elif use athena || use Xaw3d; then
- einfo "Configuring to build with Athena/Lucid toolkit"
- myconf="${myconf} --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"
- use motif && ewarn "USE flag \"motif\" ignored" \
- "(superseded by \"athena\" or \"Xaw3d\")"
elif use motif; then
einfo "Configuring to build with Motif toolkit"
myconf="${myconf} --with-x-toolkit=motif"
+ for f in Xaw3d athena; do
+ use ${f} && ewarn \
+ "USE flag \"${f}\" has no effect if \"motif\" is set."
+ done
+ elif use athena || use Xaw3d; then
+ einfo "Configuring to build with Athena/Lucid toolkit"
+ myconf="${myconf} --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"
else
einfo "Configuring to build with no toolkit"
myconf="${myconf} --with-x-toolkit=no"
diff --git a/app-editors/emacs/emacs-24.3.ebuild b/app-editors/emacs/emacs-24.3.ebuild
index 1e0d81ee2e7c..573fa557f672 100644
--- a/app-editors/emacs/emacs-24.3.ebuild
+++ b/app-editors/emacs/emacs-24.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-24.3.ebuild,v 1.2 2013/03/11 19:26:52 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-24.3.ebuild,v 1.3 2013/03/19 21:35:54 ulm Exp $
EAPI=5
@@ -56,10 +56,10 @@ RDEPEND="sys-libs/ncurses
!gtk3? ( x11-libs/gtk+:2 )
)
!gtk? (
- Xaw3d? ( x11-libs/libXaw3d )
- !Xaw3d? (
- athena? ( x11-libs/libXaw )
- !athena? ( motif? ( >=x11-libs/motif-2.3:0 ) )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ Xaw3d? ( x11-libs/libXaw3d )
+ !Xaw3d? ( athena? ( x11-libs/libXaw ) )
)
)
)"
@@ -151,22 +151,24 @@ src_configure() {
"USE flag \"m17n-lib\" has no effect if \"xft\" is not set."
fi
+ local f
if use gtk; then
einfo "Configuring to build with GIMP Toolkit (GTK+)"
myconf+=" --with-x-toolkit=$(usex gtk3 gtk3 gtk2)"
- local f
- for f in athena Xaw3d motif; do
- use ${f} && ewarn "USE flag \"${f}\" ignored" \
- "(superseded by \"gtk\")"
+ for f in motif Xaw3d athena; do
+ use ${f} && ewarn \
+ "USE flag \"${f}\" has no effect if \"gtk\" is set."
done
- elif use athena || use Xaw3d; then
- einfo "Configuring to build with Athena/Lucid toolkit"
- myconf+=" --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"
- use motif && ewarn "USE flag \"motif\" ignored" \
- "(superseded by \"athena\" or \"Xaw3d\")"
elif use motif; then
einfo "Configuring to build with Motif toolkit"
myconf+=" --with-x-toolkit=motif"
+ for f in Xaw3d athena; do
+ use ${f} && ewarn \
+ "USE flag \"${f}\" has no effect if \"motif\" is set."
+ done
+ elif use athena || use Xaw3d; then
+ einfo "Configuring to build with Athena/Lucid toolkit"
+ myconf+=" --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"
else
einfo "Configuring to build with no toolkit"
myconf+=" --with-x-toolkit=no"