summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2002-04-28 08:22:08 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2002-04-28 08:22:08 +0000
commitea37f1954e180023258fc49adc3eb96a57cfd59a (patch)
tree4a3f94e901fc9bb0c635d6ba06fd23cefb57b8a0 /app-editors/emacs/emacs-21.2.ebuild
parent(all-arch) GPL flash plugin (diff)
downloadgentoo-2-ea37f1954e180023258fc49adc3eb96a57cfd59a.tar.gz
gentoo-2-ea37f1954e180023258fc49adc3eb96a57cfd59a.tar.bz2
gentoo-2-ea37f1954e180023258fc49adc3eb96a57cfd59a.zip
PPC fix (bug 2104), new emacs version
Diffstat (limited to 'app-editors/emacs/emacs-21.2.ebuild')
-rw-r--r--app-editors/emacs/emacs-21.2.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/app-editors/emacs/emacs-21.2.ebuild b/app-editors/emacs/emacs-21.2.ebuild
new file mode 100644
index 000000000000..002af04c4f06
--- /dev/null
+++ b/app-editors/emacs/emacs-21.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Mikael Hallendal <micke@hallendal.net>
+# Modified by: Mark Yeun <mark@cs.columbia.edu>
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An incredibly powerful, extensible text editor"
+SRC_URI="ftp://ftp.codefactory.se/pub/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+
+# Never use the sandbox, it causes Emacs to segfault on startup
+SANDBOX_DISABLED="1"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ sys-libs/gdbm
+ X? ( virtual/x11
+ >=media-libs/libungif-4.1.0
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/tiff-3.5.5-r3
+ >=media-libs/libpng-1.2.1 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+
+PROVIDE="virtual/emacs"
+
+src_compile() {
+ local myconf
+
+ use nls \
+ || myconf="${myconf} --disable-nls"
+
+ use X \
+ && myconf="${myconf} \
+ --with-x \
+ --with-xpm \
+ --with-jpeg \
+ --with-tiff \
+ --with-gif \
+ --with-png" \
+ || myconf="${myconf} --without-x"
+
+ use motif \
+ && myconf="${myconf} --with-x-toolkit=motif"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ cd ${D}/usr/share/info
+ rm dir
+
+ for i in *
+ do
+ mv ${i%.info} $i.info
+ done
+
+ dodoc BUGS ChangeLog README
+
+ # Gives a warning if it doesn't exist
+ dodir /usr/share/emacs/21.2/leim
+ touch ${D}/usr/share/emacs/21.2/leim/.keep
+}