summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-08-23 03:59:11 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-08-23 03:59:11 +0000
commite66232dedea8db44bead8003ffaab1e915c8f9cd (patch)
tree221f33929d6dce1b4daf3c67c09da683cf970e7f /app-editors/emacs-cvs
parentapp-editors/emacs-cvs:toolkit-scroll-bars - Use the selected toolkit's scroll... (diff)
downloadgentoo-2-e66232dedea8db44bead8003ffaab1e915c8f9cd.tar.gz
gentoo-2-e66232dedea8db44bead8003ffaab1e915c8f9cd.tar.bz2
gentoo-2-e66232dedea8db44bead8003ffaab1e915c8f9cd.zip
New USE flag toolkit-scroll-bar added; Resolves Bug #83472.
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'app-editors/emacs-cvs')
-rw-r--r--app-editors/emacs-cvs/ChangeLog6
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.50-r3.ebuild7
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.0.ebuild6
3 files changed, 12 insertions, 7 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index 3a22a7c1b94d..97650e7a72a8 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.50 2006/08/21 05:22:40 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.51 2006/08/23 03:59:11 mkennedy Exp $
+
+ 23 Aug 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ emacs-cvs-22.0.50-r3.ebuild, emacs-cvs-23.0.0.ebuild:
+ New USE flag toolkit-scroll-bar added; Resolves Bug #83472.
21 Aug 2006; Matthew Kennedy <mkennedy@gentoo.org>
emacs-cvs-22.0.50-r3.ebuild:
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.50-r3.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.50-r3.ebuild
index d4d915f4e136..1af9929ee892 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.0.50-r3.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.50-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.50-r3.ebuild,v 1.3 2006/08/21 05:22:40 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.50-r3.ebuild,v 1.4 2006/08/23 03:59:11 mkennedy Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -9,7 +9,7 @@ ECVS_BRANCH="HEAD"
inherit elisp-common cvs alternatives flag-o-matic eutils
-IUSE="X Xaw3d aqua gif gtk jpeg png spell tiff source gzip-el"
+IUSE="X Xaw3d aqua gif gtk jpeg png spell tiff source gzip-el toolkit-scroll-bars"
S=${WORKDIR}/emacs
@@ -60,7 +60,8 @@ src_compile() {
if use X; then
myconf="${myconf} --with-x"
- myconf="${myconf} --with-xpm --with-toolkit-scroll-bars"
+ myconf="${myconf} --with-xpm"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
myconf="${myconf} $(use_with gif) $(use_with png)"
if use gtk; then
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.0.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.0.ebuild
index c12388176223..849bb8496133 100644
--- a/app-editors/emacs-cvs/emacs-cvs-23.0.0.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.0.ebuild,v 1.9 2006/06/17 01:50:10 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.0.ebuild,v 1.10 2006/08/23 03:59:11 mkennedy Exp $
ECVS_AUTH="pserver"
export CVS_RSH="ssh"
@@ -14,7 +14,7 @@ ECVS_SSH_HOST_KEY="savannah.gnu.org,199.232.41.3 ssh-rsa AAAAB3NzaC1yc2EAAAABIwA
inherit elisp-common cvs alternatives flag-o-matic eutils
-IUSE="X Xaw3d aqua gif gnome gtk jpeg nls png spell tiff xft"
+IUSE="X Xaw3d aqua gif gnome gtk jpeg nls png spell tiff xft toolkit-scroll-bars"
S=${WORKDIR}/${ECVS_MODULE}
DESCRIPTION="Emacs is the extensible, customizable, self-documenting real-time display editor."
@@ -67,7 +67,7 @@ src_compile() {
if use X; then
myconf="${myconf} --with-x"
- myconf="${myconf} --with-xpm --with-toolkit-scroll-bars"
+ myconf="${myconf} --with-xpm $(use_with toolkit-scroll-bars)"
myconf="${myconf} $(use_enable xft font-backend)"
myconf="${myconf} $(use_with xft freetype)"
myconf="${myconf} $(use_with xft)"