summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-08-18 18:08:20 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-08-18 18:08:20 +0000
commit7230f12bc7e4a61f86bd3b29590cea3664eebfbd (patch)
tree49c855e1bac2c5f0edd093510224f8b74ba2b982 /app-editors/e3
parentMasked out blackdown-1.3.1 for others to test. (diff)
downloadgentoo-2-7230f12bc7e4a61f86bd3b29590cea3664eebfbd.tar.gz
gentoo-2-7230f12bc7e4a61f86bd3b29590cea3664eebfbd.tar.bz2
gentoo-2-7230f12bc7e4a61f86bd3b29590cea3664eebfbd.zip
added some easier-to-remember names for e3 for the build image only.
I don't want to interfere with vim or emacs or pico otherwise.
Diffstat (limited to 'app-editors/e3')
-rw-r--r--app-editors/e3/e3-1.7-r2.ebuild45
-rw-r--r--app-editors/e3/files/emacs17
-rw-r--r--app-editors/e3/files/pico17
-rw-r--r--app-editors/e3/files/vi17
4 files changed, 96 insertions, 0 deletions
diff --git a/app-editors/e3/e3-1.7-r2.ebuild b/app-editors/e3/e3-1.7-r2.ebuild
new file mode 100644
index 000000000000..608045be1d99
--- /dev/null
+++ b/app-editors/e3/e3-1.7-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: tools@gentoo.org
+#
+# NOTE: this is an x86-only ebuild!!!
+#
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r2.ebuild,v 1.7 2001/08/18 18:08:20 chadh Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Super Tiny Editor with wordstar, vi, and emacs key bindings"
+SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
+HOMEPAGE="http://www.sax.de/~adlibit"
+DEPEND="dev-lang/nasm"
+RDEPEND="sys-apps/sed"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ try emake
+}
+
+src_install () {
+ dodir /usr/bin
+ dobin e3
+ dosym e3 /usr/bin/e3vi
+ dosym e3 /usr/bin/e3em
+ dosym e3 /usr/bin/e3ws
+ dosym e3 /usr/bin/e3pi
+ dosym e3 /usr/bin/e3ne
+
+ if [ "`use build`" ]; then
+ # easier-to-remember shell scripts
+ dobin ${FILESDIR}/vi
+ dobin ${FILESDIR}/emacs
+ dobin ${FILESDIR}/pico
+ fi
+
+ cp e3.man e3.1
+ doman e3.1
+}
+
diff --git a/app-editors/e3/files/emacs b/app-editors/e3/files/emacs
new file mode 100644
index 000000000000..41ced9968fdb
--- /dev/null
+++ b/app-editors/e3/files/emacs
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+E3=/usr/bin/e3
+whichE3=${E3}em
+
+if [ -f ${E3} ]; then
+ if [ -f ${whichE3} ]; then
+ for i in $@
+ do
+ ${whichE3} $i
+ done
+ else
+ echo ${whichE3}: file does not exist
+ fi
+else
+ echo "${E3}: file does not exist"
+fi
diff --git a/app-editors/e3/files/pico b/app-editors/e3/files/pico
new file mode 100644
index 000000000000..4fdf2280f181
--- /dev/null
+++ b/app-editors/e3/files/pico
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+E3=/usr/bin/e3
+whichE3=${E3}pi
+
+if [ -f ${E3} ]; then
+ if [ -f ${whichE3} ]; then
+ for i in $@
+ do
+ ${whichE3} $i
+ done
+ else
+ echo ${whichE3}: file does not exist
+ fi
+else
+ echo "${E3}: file does not exist"
+fi
diff --git a/app-editors/e3/files/vi b/app-editors/e3/files/vi
new file mode 100644
index 000000000000..932ba7950bea
--- /dev/null
+++ b/app-editors/e3/files/vi
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+E3=/usr/bin/e3
+whichE3=${E3}vi
+
+if [ -f ${E3} ]; then
+ if [ -f ${whichE3} ]; then
+ for i in $@
+ do
+ ${whichE3} $i
+ done
+ else
+ echo ${whichE3}: file does not exist
+ fi
+else
+ echo "${E3}: file does not exist"
+fi