summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-08-18 01:38:54 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-08-18 01:38:54 +0000
commitc60821416916ce9eab4e704d2176edf0b3d0adfe (patch)
tree3ec6eb528374808b3e2f0e182caad9a6ccb3f7a6 /app-editors/e3/e3-1.7-r2.ebuild
parentnow has a "python" compat. symlink (diff)
downloadgentoo-2-c60821416916ce9eab4e704d2176edf0b3d0adfe.tar.gz
gentoo-2-c60821416916ce9eab4e704d2176edf0b3d0adfe.tar.bz2
gentoo-2-c60821416916ce9eab4e704d2176edf0b3d0adfe.zip
this revision builds the C version, instead of the nasm version.
nasm requires perl which requires ... -- not good for build.
Diffstat (limited to 'app-editors/e3/e3-1.7-r2.ebuild')
-rw-r--r--app-editors/e3/e3-1.7-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/e3/e3-1.7-r2.ebuild b/app-editors/e3/e3-1.7-r2.ebuild
new file mode 100644
index 000000000000..5e8ee1fd1105
--- /dev/null
+++ b/app-editors/e3/e3-1.7-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: tools@cvs.gentoo.org
+#
+# NOTE: this is an x86-only ebuild!!!
+#
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r2.ebuild,v 1.1 2001/08/18 01:38:54 chadh Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Super Tiny Editor with wordstar, vi, and emacs key bindings"
+SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
+HOMEPAGE="http://www.sax.de/~adlibit"
+DEPEND="dev-lang/nasm
+ >=sys-apps/gzip-1.2.4a-r6"
+RDEPEND="sys-apps/sed"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+src_compile() {
+ cd e3c
+ emake || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dobin e3
+ dosym e3 /usr/bin/e3vi
+ dosym e3 /usr/bin/e3em
+ dosym e3 /usr/bin/e3ws
+ dosym e3 /usr/bin/e3pi
+ dosym e3 /usr/bin/e3ne
+
+ cp e3.man e3.1
+ doman e3.1
+}
+