summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-06-12 10:47:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-06-12 10:47:26 +0000
commit0624fad40cd0fe8093dfc749c8ccf95328981c73 (patch)
tree494fc36b2fa02a1bb576ba5018bff2eae42ba7ff /app-editors/amyedit
parentremove old (diff)
downloadgentoo-2-0624fad40cd0fe8093dfc749c8ccf95328981c73.tar.gz
gentoo-2-0624fad40cd0fe8093dfc749c8ccf95328981c73.tar.bz2
gentoo-2-0624fad40cd0fe8093dfc749c8ccf95328981c73.zip
fix build with gcc 4.5, bug #321293
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/amyedit')
-rw-r--r--app-editors/amyedit/ChangeLog6
-rw-r--r--app-editors/amyedit/amyedit-1.0-r1.ebuild5
-rw-r--r--app-editors/amyedit/files/amyedit-1.0-gcc45.patch16
3 files changed, 24 insertions, 3 deletions
diff --git a/app-editors/amyedit/ChangeLog b/app-editors/amyedit/ChangeLog
index 21fa49c44b93..7ea6fa78fed9 100644
--- a/app-editors/amyedit/ChangeLog
+++ b/app-editors/amyedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/amyedit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/amyedit/ChangeLog,v 1.23 2010/06/12 10:44:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/amyedit/ChangeLog,v 1.24 2010/06/12 10:47:26 aballier Exp $
+
+ 12 Jun 2010; Alexis Ballier <aballier@gentoo.org> amyedit-1.0-r1.ebuild,
+ +files/amyedit-1.0-gcc45.patch:
+ fix build with gcc 4.5, bug #321293
12 Jun 2010; Alexis Ballier <aballier@gentoo.org> -amyedit-0.9.ebuild,
-amyedit-1.0.ebuild:
diff --git a/app-editors/amyedit/amyedit-1.0-r1.ebuild b/app-editors/amyedit/amyedit-1.0-r1.ebuild
index df32c425f29f..56ad78656565 100644
--- a/app-editors/amyedit/amyedit-1.0-r1.ebuild
+++ b/app-editors/amyedit/amyedit-1.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/amyedit/amyedit-1.0-r1.ebuild,v 1.6 2008/11/22 15:10:19 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/amyedit/amyedit-1.0-r1.ebuild,v 1.7 2010/06/12 10:47:26 aballier Exp $
inherit eutils autotools
@@ -25,6 +25,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-keyfile.patch"
epatch "${FILESDIR}/${P}-signal.patch"
+ epatch "${FILESDIR}/${P}-gcc45.patch"
eautoreconf
}
diff --git a/app-editors/amyedit/files/amyedit-1.0-gcc45.patch b/app-editors/amyedit/files/amyedit-1.0-gcc45.patch
new file mode 100644
index 000000000000..16db9fd415f5
--- /dev/null
+++ b/app-editors/amyedit/files/amyedit-1.0-gcc45.patch
@@ -0,0 +1,16 @@
+Fix build with gcc 4.5
+https://bugs.gentoo.org/show_bug.cgi?id=321293
+
+Index: amyedit-1.0/src/Preferences.cc
+===================================================================
+--- amyedit-1.0.orig/src/Preferences.cc
++++ amyedit-1.0/src/Preferences.cc
+@@ -211,7 +211,7 @@ int Preferences::run()
+ }
+
+ void Preferences::edit_latex_commands(){
+- EditLatexCommands::EditLatexCommands dialog(this);
++ EditLatexCommands dialog(this);
+ dialog.run();
+ Amy::populate_text_list_model_from_list(previewoptionslist->get_model(), PrefStruct::instance()->get_keys("Commands"), true);
+ previewoptionslist->select(PrefStruct::instance()->get<Glib::ustring>("General", "preview_combo"));