summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-02-14 13:37:27 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-02-14 13:37:27 +0000
commit41187eeff0d37118f73dfeabbfb18ebc002303f2 (patch)
treeab2b5579162dab6a4fe9cb071b664374efb9832c /app-doc
parentRequire python[ssl] for bug #403201. (diff)
downloadgentoo-2-41187eeff0d37118f73dfeabbfb18ebc002303f2.tar.gz
gentoo-2-41187eeff0d37118f73dfeabbfb18ebc002303f2.tar.bz2
gentoo-2-41187eeff0d37118f73dfeabbfb18ebc002303f2.zip
Version bump: EAPI4, reorder vars, initial support for LINGUAS, use 'dot' instead of 'nodot', add missing dependencies on perl and bison (fixes bug #399349 by bay), respect CC and CXX, call eqmake4 for doxywizard, always use emake, simplify latex+doc logic. Add myself as a maintainer
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog13
-rw-r--r--app-doc/doxygen/doxygen-1.7.6.1.ebuild226
-rw-r--r--app-doc/doxygen/metadata.xml5
3 files changed, 242 insertions, 2 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index 6e73e4d22b4e..98743a5ab78f 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-doc/doxygen
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.206 2011/11/05 21:30:54 nerdboy Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.207 2012/02/14 13:37:27 xarthisius Exp $
+
+*doxygen-1.7.6.1 (14 Feb 2012)
+
+ 14 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> +doxygen-1.7.6.1.ebuild,
+ metadata.xml:
+ Version bump: EAPI4, reorder vars, initial support for LINGUAS, use 'dot'
+ instead of 'nodot', add missing dependencies on perl and bison (fixes bug
+ #399349 by bay), respect CC and CXX, call eqmake4 for doxywizard, always use
+ emake, simplify latex+doc logic. Add myself as maintainer.
*doxygen-1.7.5.1 (05 Nov 2011)
diff --git a/app-doc/doxygen/doxygen-1.7.6.1.ebuild b/app-doc/doxygen/doxygen-1.7.6.1.ebuild
new file mode 100644
index 000000000000..256f5c1f4dcd
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.7.6.1.ebuild
@@ -0,0 +1,226 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.7.6.1.ebuild,v 1.1 2012/02/14 13:37:27 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs qt4-r2 fdo-mime
+
+DESCRIPTION="Documentation system for most programming languages"
+HOMEPAGE="http://www.doxygen.org/"
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
+ ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc dot qt4 latex elibc_FreeBSD"
+
+#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
+
+LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
+nl nb pl pt ro ru sl sk sr sv tr uk vi af)
+for X in "${LANGS[@]}" ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="qt4? ( x11-libs/qt-gui:4 )
+ latex? ( app-text/texlive[extra] )
+ dev-lang/python
+ dev-lang/perl
+ virtual/libiconv
+ media-libs/libpng
+ app-text/ghostscript-gpl
+ dot? (
+ media-gfx/graphviz
+ media-libs/freetype
+ )"
+
+DEPEND="sys-apps/sed
+ sys-devel/flex
+ sys-devel/bison
+ ${RDEPEND}"
+
+RESTRICT="mirror"
+EPATCH_SUFFIX="patch"
+
+get_langs() {
+ # using only user set linguas also fixes #263641
+ my_linguas=()
+ for lingua in ${LINGUAS}; do
+ if has ${lingua} "${LANGS[@]}"; then
+ case ${lingua} in
+ hy) lingua=am ;;
+ pt_BR) lingua=br ;;
+ zh*) lingua=cn ;;
+ cs) lingua=cz ;;
+ da) lingua=dk ;;
+ el*) lingua=gr ;;
+ ja*) lingua=jp ;;
+ ko) lingua=kr ;;
+ nb) lingua=no ;;
+ sl) lingua=si ;;
+ tr*) lingua=tr ;;
+ uk) lingua=ua ;;
+ af) lingua=za ;;
+ esac
+ has ${lingua} "${my_linguas[@]}" ||
+ my_linguas+=(${lingua})
+ fi
+ done
+ f_langs="${my_linguas[@]}"
+ echo ${f_langs// /,}
+}
+
+pkg_setup() {
+ tc-export CC CXX
+}
+
+src_prepare() {
+ # use CFLAGS, CXXFLAGS, LDFLAGS
+ export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
+
+ sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
+ -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
+ -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
+ -e "s:^\(TMAKE_CXX\s*\)=.*$:\1= $(tc-getCXX):" \
+ -e "s:^\(TMAKE_LINK\s*\)=.*$:\1= $(tc-getCXX):" \
+ -e "s:^\(TMAKE_LINK_SHLIB\s*\)=.*$:\1= $(tc-getCXX):" \
+ -e "s:^\(TMAKE_CXX\s*\)=.*$:\1= $(tc-getCC):" \
+ tmake/lib/{{linux,gnu,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++,linux-64}/tmake.conf \
+ || die
+
+ # Ensure we link to -liconv
+ if use elibc_FreeBSD; then
+ for pro in */*.pro.in */*/*.pro.in; do
+ echo "unix:LIBS += -liconv" >> "${pro}"
+ done
+ fi
+
+ # Call dot with -Teps instead of -Tps for EPS generation - bug #282150
+ sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die
+
+ # prefix search tools patch, plus OSX fixes
+ epatch "${FILESDIR}"/${PN}-1.5.6-prefix-misc-alt.patch
+
+ # fix final DESTDIR issue
+ sed -i.orig -e "s:\$(INSTALL):\$(DESTDIR)/\$(INSTALL):g" \
+ -e "s/all: Makefile.doxywizard/all:/g" \
+ addon/doxywizard/Makefile.in || die
+
+ # fix pdf doc
+ sed -i.orig -e "s:g_kowal:g kowal:" \
+ doc/maintainers.txt || die
+
+ if is-flagq "-O3" ; then
+ echo
+ ewarn "Compiling with -O3 is known to produce incorrectly"
+ ewarn "optimized code which breaks doxygen."
+ echo
+ elog "Continuing with -O2 instead ..."
+ echo
+ replace-flags "-O3" "-O2"
+ fi
+}
+
+src_configure() {
+ # set ./configure options (prefix, Qt based wizard, docdir)
+
+ local my_conf="--shared --enable-langs $(get_langs)"
+
+ if use debug ; then
+ my_conf="${my_conf} --debug"
+ else
+ my_conf="${my_conf} --release "
+ fi
+
+ use ppc64 && my_conf="${my_conf} --english-only" #263641
+
+ use qt4 && my_conf="${my_conf} --with-doxywizard"
+
+ export LINK="${QMAKE_LINK}"
+ export LINK_SHLIB="${QMAKE_CXX}"
+
+ if use qt4 ; then
+ pushd addon/doxywizard &> /dev/null
+ eqmake4 doxywizard.pro -o Makefile.doxywizard
+ popd &> /dev/null
+ fi
+
+ ./configure --prefix "${EPREFIX}/usr" ${my_conf} \
+ || die
+}
+
+src_compile() {
+
+ emake CFLAGS+="${ECFLAGS}" CXXFLAGS+="${ECXXFLAGS}" \
+ LFLAGS+="${ELDFLAGS}" all
+
+ # generate html and pdf (if tetex in use) documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ if ! use dot; then
+ sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
+ {Doxyfile,doc/Doxyfile} \
+ || ewarn "disabling dot failed"
+ fi
+ if use latex; then
+ addwrite /var/cache/fonts
+ addwrite /var/cache/fontconfig
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make pdf docs" failed.'
+ else
+ cp doc/Doxyfile doc/Doxyfile.orig
+ cp doc/Makefile doc/Makefile.orig
+ sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" \
+ doc/Doxyfile
+ sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
+ -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
+ -e "s/@sed/# @sed/" doc/Makefile
+ make docs || ewarn '"make docs" failed.'
+ fi
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" MAN1DIR=share/man/man1 install
+
+ if use qt4; then
+ doicon "${FILESDIR}/doxywizard.png"
+ make_desktop_entry doxywizard "DoxyWizard ${PV}" \
+ "/usr/share/pixmaps/doxywizard.png" \
+ "Application;Development"
+ fi
+
+ dodoc INSTALL LANGUAGE.HOWTO README
+
+ # pdf and html manuals
+ if use doc; then
+ dohtml -r html/*
+ use latex && dodoc latex/doxygen_manual.pdf
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ elog
+ elog "The USE flags qt4, doc, and latex will enable doxywizard, or"
+ elog "the html and pdf documentation, respectively. For examples"
+ elog "and other goodies, see the source tarball. For some example"
+ elog "output, run doxygen on the doxygen source using the Doxyfile"
+ elog "provided in the top-level source dir."
+ elog
+ elog "Disabling the dot USE flag will remove the GraphViz dependency,"
+ elog "along with Doxygen's ability to generate diagrams in the docs."
+ elog "See the Doxygen homepage for additional helper tools to parse"
+ elog "more languages."
+ elog
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-doc/doxygen/metadata.xml b/app-doc/doxygen/metadata.xml
index 6098d4692695..313f6613d0b7 100644
--- a/app-doc/doxygen/metadata.xml
+++ b/app-doc/doxygen/metadata.xml
@@ -6,6 +6,10 @@
<email>nerdboy@gentoo.org</email>
<name>Steve Arnold</name>
</maintainer>
+<maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+</maintainer>
<longdescription>Doxygen is a tool for analyzing, documenting, and reverse-engineering
source code of various languages using a variety of output formats
(try it and see). Doxygen supports C++, C, Java, Objective-C, Python,
@@ -14,6 +18,7 @@
</longdescription>
<use>
<flag name='nodot'>removes graphviz dependency, along with dot graphs</flag>
+ <flag name='dot'>allow to create dot graphs using <pkg>media-gfx/graphviz</pkg></flag>
<flag name='tcl'>adds experimental support for parsing/documenting Tcl source code</flag>
</use>
</pkgmetadata>