summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-14 16:30:32 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-14 16:30:32 +0000
commit2233427ca618b9a84543b9f6ac194538034fba9a (patch)
treecb7f21342881067124e98dfa79870007ac978673 /app-doc
parentrc1 is final (diff)
downloadgentoo-2-2233427ca618b9a84543b9f6ac194538034fba9a.tar.gz
gentoo-2-2233427ca618b9a84543b9f6ac194538034fba9a.tar.bz2
gentoo-2-2233427ca618b9a84543b9f6ac194538034fba9a.zip
ditto, last commit of the bunch
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/winex-doc/ChangeLog10
-rw-r--r--app-doc/winex-doc/files/81winex-doc1
-rw-r--r--app-doc/winex-doc/files/digest-winex-doc-200205111
-rw-r--r--app-doc/winex-doc/winex-doc-20020511.ebuild54
4 files changed, 66 insertions, 0 deletions
diff --git a/app-doc/winex-doc/ChangeLog b/app-doc/winex-doc/ChangeLog
new file mode 100644
index 000000000000..110eedb01f90
--- /dev/null
+++ b/app-doc/winex-doc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-doc/.
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-doc/winex-doc/ChangeLog,v 1.1 2002/06/14 16:30:32 danarmak Exp $
+
+*.-20020511 (14 Jun 2002)
+
+ 14 Jun 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Separated from app-emualtion/winex, installs just the manpages and other
+ documentation.
diff --git a/app-doc/winex-doc/files/81winex-doc b/app-doc/winex-doc/files/81winex-doc
new file mode 100644
index 000000000000..549b7aeedc08
--- /dev/null
+++ b/app-doc/winex-doc/files/81winex-doc
@@ -0,0 +1 @@
+MANPATH=/usr/winex/man
diff --git a/app-doc/winex-doc/files/digest-winex-doc-20020511 b/app-doc/winex-doc/files/digest-winex-doc-20020511
new file mode 100644
index 000000000000..8e0faf98db46
--- /dev/null
+++ b/app-doc/winex-doc/files/digest-winex-doc-20020511
@@ -0,0 +1 @@
+MD5 a535fe3a53722530e69065c974331e28 winex-20020511.tar.bz2 6043424
diff --git a/app-doc/winex-doc/winex-doc-20020511.ebuild b/app-doc/winex-doc/winex-doc-20020511.ebuild
new file mode 100644
index 000000000000..7a3381e4afb4
--- /dev/null
+++ b/app-doc/winex-doc/winex-doc-20020511.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-doc/winex-doc/winex-doc-20020511.ebuild,v 1.1 2002/06/14 16:30:32 danarmak Exp $
+
+S=${WORKDIR}/wine
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+SRC_URI="ftp:/www.ibiblio.org/gentoo/distfiles/winex-$PV.tar.bz2"
+HOMEPAGE="http://www.transgaming.com/"
+
+DEPEND=""
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --exec_prefix=/usr/winex \
+ --sysconfdir=/etc/winex \
+ --mandir=/usr/winex/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make manpages || die
+
+}
+
+src_install () {
+
+ cd ${S}/documentation
+ DESTTREE=/usr/winex doman man3w/*
+ # sgml was being filtered without -a sgml
+ dohtml -a sgml *.sgml
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/81winex-doc
+
+}
+