summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-03-12 04:49:50 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-03-12 04:49:50 +0000
commit19fc19f3fa4103843ca0990d6604e6a7f9310f09 (patch)
tree887f226e994ee32b7c5bc8e5d648eed52a216869 /app-doc
parentRemove. (diff)
downloadgentoo-2-19fc19f3fa4103843ca0990d6604e6a7f9310f09.tar.gz
gentoo-2-19fc19f3fa4103843ca0990d6604e6a7f9310f09.tar.bz2
gentoo-2-19fc19f3fa4103843ca0990d6604e6a7f9310f09.zip
Version bump.
(Portage version: 2.2_rc24/cvs/Linux x86_64)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/linuxfromscratch/ChangeLog10
-rw-r--r--app-doc/linuxfromscratch/linuxfromscratch-6.4.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/app-doc/linuxfromscratch/ChangeLog b/app-doc/linuxfromscratch/ChangeLog
index 5ce9e8415ab6..e575c64df3b1 100644
--- a/app-doc/linuxfromscratch/ChangeLog
+++ b/app-doc/linuxfromscratch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-doc/linuxfromscratch
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/linuxfromscratch/ChangeLog,v 1.2 2008/07/24 21:47:37 cardoe Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/linuxfromscratch/ChangeLog,v 1.3 2009/03/12 04:49:50 dirtyepic Exp $
+
+*linuxfromscratch-6.4 (12 Mar 2009)
+
+ 12 Mar 2009; Ryan Hill <dirtyepic@gentoo.org>
+ +linuxfromscratch-6.4.ebuild:
+ Version bump.
24 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-doc/linuxfromscratch/linuxfromscratch-6.4.ebuild b/app-doc/linuxfromscratch/linuxfromscratch-6.4.ebuild
new file mode 100644
index 000000000000..490a87f2b871
--- /dev/null
+++ b/app-doc/linuxfromscratch/linuxfromscratch-6.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/linuxfromscratch/linuxfromscratch-6.4.ebuild,v 1.1 2009/03/12 04:49:50 dirtyepic Exp $
+
+MY_SRC="http://www.linuxfromscratch.org/lfs/downloads/${PV}"
+
+BOOTSCRIPT_PV="20081031"
+UDEV_PV="20081015"
+
+
+DESCRIPTION="LFS documents building a Linux system entirely from source."
+HOMEPAGE="http://www.linuxfromscratch.org/lfs"
+SRC_URI="${MY_SRC}/LFS-BOOK-${PV}-HTML.tar.bz2
+ ${MY_SRC}/lfs-bootscripts-${BOOTSCRIPT_PV}.tar.bz2
+ ${MY_SRC}/udev-config-${UDEV_PV}.tar.bz2
+ htmlsingle? ( ${MY_SRC}/LFS-BOOK-${PV}-NOCHUNKS.html.bz2 )
+ pdf? ( ${MY_SRC}/LFS-BOOK-${PV}.pdf.bz2 )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="htmlsingle pdf"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ # We don't want this stuff compressed
+ insinto /usr/share/doc/${PF}
+ doins -r * || die "Install failed."
+}