summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:51:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:51:28 +0000
commit14b57f4869a4c52051211b8bc42166a95a6cb602 (patch)
tree9762a437d55fb47024c95fcd4012d884f0911bce /app-doc
parentarm/ia64/sh stable wrt #266913 (diff)
downloadgentoo-2-14b57f4869a4c52051211b8bc42166a95a6cb602.tar.gz
gentoo-2-14b57f4869a4c52051211b8bc42166a95a6cb602.tar.bz2
gentoo-2-14b57f4869a4c52051211b8bc42166a95a6cb602.zip
Move use_ functions out of global scope.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/xorg-docs/ChangeLog6
-rw-r--r--app-doc/xorg-docs/xorg-docs-1.4-r1.ebuild19
-rw-r--r--app-doc/xorg-docs/xorg-docs-1.4.ebuild26
3 files changed, 30 insertions, 21 deletions
diff --git a/app-doc/xorg-docs/ChangeLog b/app-doc/xorg-docs/ChangeLog
index efc2b5a541af..792b2aa2bdf7 100644
--- a/app-doc/xorg-docs/ChangeLog
+++ b/app-doc/xorg-docs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-doc/xorg-docs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/xorg-docs/ChangeLog,v 1.50 2009/01/05 21:43:27 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/xorg-docs/ChangeLog,v 1.51 2009/05/04 15:51:28 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org> xorg-docs-1.4.ebuild,
+ xorg-docs-1.4-r1.ebuild:
+ Move use_ functions out of global scope.
05 Jan 2009; Javier Villavicencio <the_paya@gentoo.org>
+files/1.4-rename-security.man.patch.bz2, xorg-docs-1.4-r1.ebuild:
diff --git a/app-doc/xorg-docs/xorg-docs-1.4-r1.ebuild b/app-doc/xorg-docs/xorg-docs-1.4-r1.ebuild
index 8a1a9bfca736..d0f0015da721 100644
--- a/app-doc/xorg-docs/xorg-docs-1.4-r1.ebuild
+++ b/app-doc/xorg-docs/xorg-docs-1.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/xorg-docs/xorg-docs-1.4-r1.ebuild,v 1.12 2009/01/05 21:43:27 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/xorg-docs/xorg-docs-1.4-r1.ebuild,v 1.13 2009/05/04 15:51:28 ssuominen Exp $
# Must be before x-modular eclass is inherited
SNAPSHOT="yes"
@@ -28,12 +28,15 @@ PATCHES="${FILESDIR}/1.1-allow_manpages_only.patch
${FILESDIR}/1.4-sgml-fixes.patch
${FILESDIR}/1.4-rename-security.man.patch.bz2"
-CONFIGURE_OPTIONS="--with-x11docdir=/usr/share/doc/${PF}
- $(use_enable doc non-man-docs)
- $(use_enable doc txt)
- $(use_enable doc pdf)
- $(use_enable doc html)
- $(use_enable doc ps)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="--with-x11docdir=/usr/share/doc/${PF}
+ $(use_enable doc non-man-docs)
+ $(use_enable doc txt)
+ $(use_enable doc pdf)
+ $(use_enable doc html)
+ $(use_enable doc ps)"
+
+ # parallel build broken -- https://bugs.gentoo.org/show_bug.cgi?id=170798
+}
-# parallel build broken -- https://bugs.gentoo.org/show_bug.cgi?id=170798
MAKEOPTS="${MAKEOPTS} -j1"
diff --git a/app-doc/xorg-docs/xorg-docs-1.4.ebuild b/app-doc/xorg-docs/xorg-docs-1.4.ebuild
index e539fbeee665..0dec675823ca 100644
--- a/app-doc/xorg-docs/xorg-docs-1.4.ebuild
+++ b/app-doc/xorg-docs/xorg-docs-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/xorg-docs/xorg-docs-1.4.ebuild,v 1.14 2008/04/25 20:29:20 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/xorg-docs/xorg-docs-1.4.ebuild,v 1.15 2009/05/04 15:51:28 ssuominen Exp $
# Must be before x-modular eclass is inherited
SNAPSHOT="yes"
@@ -20,13 +20,15 @@ IUSE="doc"
PATCHES="${FILESDIR}/1.1-allow_manpages_only.patch"
-CONFIGURE_OPTIONS="--with-x11docdir=/usr/share/doc/${PF}
- $(use_enable doc non-man-docs)
- --disable-txt
- --disable-pdf
- --disable-html
- --disable-ps"
-# $(use_enable doc txt)"
-# $(use_enable doc pdf)
-# $(use_enable doc html)
-# $(use_enable doc ps)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="--with-x11docdir=/usr/share/doc/${PF}
+ $(use_enable doc non-man-docs)
+ --disable-txt
+ --disable-pdf
+ --disable-html
+ --disable-ps"
+ # $(use_enable doc txt)"
+ # $(use_enable doc pdf)
+ # $(use_enable doc html)
+ # $(use_enable doc ps)"
+}