summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé Luis Rivero <yoswink@gentoo.org>2007-05-07 22:56:06 +0000
committerJosé Luis Rivero <yoswink@gentoo.org>2007-05-07 22:56:06 +0000
commitd5b891f60b8e17bdd6b514a65e033ec312698d44 (patch)
tree6f08c23bb89e5136d874914ab6c33c5a78b04558 /app-doc/repodoc/repodoc-9999.ebuild
parentDisable building javadocs using new features from java-pkg-2.eclass. (diff)
downloadgentoo-2-d5b891f60b8e17bdd6b514a65e033ec312698d44.tar.gz
gentoo-2-d5b891f60b8e17bdd6b514a65e033ec312698d44.tar.bz2
gentoo-2-d5b891f60b8e17bdd6b514a65e033ec312698d44.zip
Initial import.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-doc/repodoc/repodoc-9999.ebuild')
-rw-r--r--app-doc/repodoc/repodoc-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-doc/repodoc/repodoc-9999.ebuild b/app-doc/repodoc/repodoc-9999.ebuild
new file mode 100644
index 000000000000..c8cb1358d4ec
--- /dev/null
+++ b/app-doc/repodoc/repodoc-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/repodoc/repodoc-9999.ebuild,v 1.1 2007/05/07 22:56:05 yoswink Exp $
+
+EGIT_REPO_URI="git://git.ferdyx.org/repodoc.git"
+EGIT_BRANCH="next"
+EGIT_BOOTSTRAP="./autogen.bash"
+
+inherit git mono
+
+DESCRIPTION="A tool designed to make checks on Gentoo official docs"
+HOMEPAGE="http://dev.gentoo.org/~yoswink/repodoc/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gtk"
+
+RDEPEND="${DEPEND}
+ || ( sys-apps/gawk sys-apps/mawk sys-apps/busybox )"
+
+DEPEND="dev-libs/libxml2
+ app-text/txt2tags
+ gtk? ( dev-dotnet/gtk-sharp )"
+
+src_compile() {
+ econf $(use_enable gtk) || die 'econf failed!'
+ emake || die 'emake failed!'
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die 'install failed!'
+ dodoc AUTHORS ChangeLog
+}