summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElfyn McBratney <beu@gentoo.org>2007-02-03 00:59:14 +0000
committerElfyn McBratney <beu@gentoo.org>2007-02-03 00:59:14 +0000
commit89d891c7d651256b616cdbb999911c505908bfb5 (patch)
tree271af311482d94864507b2251a4fe7bf3a15fae9 /app-doc/php-docs/php-docs-20070202-r1.ebuild
parentFix clause_reference hashing in debug mode. (diff)
downloadgentoo-2-89d891c7d651256b616cdbb999911c505908bfb5.tar.gz
gentoo-2-89d891c7d651256b616cdbb999911c505908bfb5.tar.bz2
gentoo-2-89d891c7d651256b616cdbb999911c505908bfb5.zip
Fix bug #120753.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-doc/php-docs/php-docs-20070202-r1.ebuild')
-rw-r--r--app-doc/php-docs/php-docs-20070202-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-doc/php-docs/php-docs-20070202-r1.ebuild b/app-doc/php-docs/php-docs-20070202-r1.ebuild
new file mode 100644
index 000000000000..ea17f1bf5e43
--- /dev/null
+++ b/app-doc/php-docs/php-docs-20070202-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/php-docs/php-docs-20070202-r1.ebuild,v 1.1 2007/02/03 00:59:14 beu Exp $
+
+DESCRIPTION="HTML documentation for PHP"
+HOMEPAGE="http://www.php.net/download-docs.php"
+SRC_URI="mirror://gentoo/php-docs-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/html
+
+src_install() {
+ # the whole structure is too much to do with a simple dohtml *
+ for x in a b c d e f g h i j k l m n o p q r s t u v w x y z ; do
+ files="$(echo function.${x}*)"
+ [[ -n ${files} ]] || continue;
+
+ dohtml function.${x}*
+ rm function.${x}*
+ done
+
+ # what's left will fit into a single dohtml *
+ dohtml *.html
+ mv * "${D}"/usr/share/doc/php-docs-${PVR}/html/ || die "bad mv"
+}
+
+pkg_postinst() {
+ einfo "Creating symlink to PHP manual at /usr/share/php-docs"
+ [[ -e /usr/share/php-docs ]] && rm -f /usr/share/php-docs
+ ln -s /usr/share/doc/php-docs-${PVR}/html /usr/share/php-docs
+}