summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-05-27 15:37:53 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-05-27 15:37:53 +0000
commite0d676e5e933afedd061b7694f213a1630b2eb82 (patch)
tree41742e8b1c4c2097231b55b83c619d1fe15d9563 /app-dicts
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-e0d676e5e933afedd061b7694f213a1630b2eb82.tar.gz
gentoo-2-e0d676e5e933afedd061b7694f213a1630b2eb82.tar.bz2
gentoo-2-e0d676e5e933afedd061b7694f213a1630b2eb82.zip
Convert to ruby-ng. Removed old versions.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/fantasdic/ChangeLog9
-rw-r--r--app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild34
-rw-r--r--app-dicts/fantasdic/fantasdic-1.0_beta7-r2.ebuild43
-rw-r--r--app-dicts/fantasdic/fantasdic-1.0_beta7.ebuild34
4 files changed, 51 insertions, 69 deletions
diff --git a/app-dicts/fantasdic/ChangeLog b/app-dicts/fantasdic/ChangeLog
index 6c08b8d70de2..92e438fe9aa5 100644
--- a/app-dicts/fantasdic/ChangeLog
+++ b/app-dicts/fantasdic/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-dicts/fantasdic
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/fantasdic/ChangeLog,v 1.6 2010/01/23 07:30:39 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/fantasdic/ChangeLog,v 1.7 2010/05/27 15:37:53 matsuu Exp $
+
+*fantasdic-1.0_beta7-r2 (27 May 2010)
+
+ 27 May 2010; MATSUU Takuto <matsuu@gentoo.org>
+ -fantasdic-1.0_beta6.ebuild, -fantasdic-1.0_beta7.ebuild,
+ +fantasdic-1.0_beta7-r2.ebuild:
+ Convert to ruby-ng. Removed old versions.
*fantasdic-1.0_beta7-r1 (23 Jan 2010)
diff --git a/app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild b/app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild
deleted file mode 100644
index 82f6cbd8e9aa..000000000000
--- a/app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild,v 1.1 2008/12/05 23:03:07 matsuu Exp $
-
-inherit eutils ruby
-
-MY_P="${P/_/-}"
-DESCRIPTION="Fantasdic is a client for the DICT protocol"
-HOMEPAGE="http://www.gnome.org/projects/fantasdic/"
-SRC_URI="http://www.mblondel.org/files/fantasdic/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gnome nls"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=">=dev-lang/ruby-1.8"
-RDEPEND="${DEPEND}
- >=dev-ruby/ruby-libglade2-0.14.1
- gnome? (
- >=dev-ruby/ruby-gnome2-0.14.1
- >=dev-ruby/ruby-gconf2-0.14.1
- )
- nls? ( >=dev-ruby/ruby-gettext-0.6.1 )"
-
-src_install() {
- ${RUBY} setup.rb install --prefix="${D}" || die
-
- domenu fantasdic.desktop
-
- erubydoc
-}
diff --git a/app-dicts/fantasdic/fantasdic-1.0_beta7-r2.ebuild b/app-dicts/fantasdic/fantasdic-1.0_beta7-r2.ebuild
new file mode 100644
index 000000000000..b93f5a90a694
--- /dev/null
+++ b/app-dicts/fantasdic/fantasdic-1.0_beta7-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/fantasdic/fantasdic-1.0_beta7-r2.ebuild,v 1.1 2010/05/27 15:37:53 matsuu Exp $
+
+EAPI="2"
+#USE_RUBY="ruby18 ree18 jruby"
+USE_RUBY="ruby18"
+inherit eutils ruby-ng
+
+MY_P="${P/_/-}"
+DESCRIPTION="Fantasdic is a client for the DICT protocol"
+HOMEPAGE="http://www.gnome.org/projects/fantasdic/"
+SRC_URI="http://www.mblondel.org/files/fantasdic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome nls"
+
+S="${WORKDIR}/${MY_P}"
+
+ruby_add_rdepend ">=dev-ruby/ruby-libglade2-0.14.1"
+ruby_add_rdepend gnome ">=dev-ruby/ruby-gnome2-0.14.1
+ >=dev-ruby/ruby-gconf2-0.14.1"
+ruby_add_rdepend nls ">=dev-ruby/ruby-gettext-0.6.1"
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
+}
+
+all_ruby_install() {
+ domenu fantasdic.desktop || die
+
+ # bug #298866
+ rm -r "${D}usr/share/doc/fantasdic" || die
+}
diff --git a/app-dicts/fantasdic/fantasdic-1.0_beta7.ebuild b/app-dicts/fantasdic/fantasdic-1.0_beta7.ebuild
deleted file mode 100644
index 938c3b184eec..000000000000
--- a/app-dicts/fantasdic/fantasdic-1.0_beta7.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/fantasdic/fantasdic-1.0_beta7.ebuild,v 1.1 2009/05/19 14:39:02 matsuu Exp $
-
-inherit eutils ruby
-
-MY_P="${P/_/-}"
-DESCRIPTION="Fantasdic is a client for the DICT protocol"
-HOMEPAGE="http://www.gnome.org/projects/fantasdic/"
-SRC_URI="http://www.mblondel.org/files/fantasdic/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gnome nls"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=">=dev-lang/ruby-1.8"
-RDEPEND="${DEPEND}
- >=dev-ruby/ruby-libglade2-0.14.1
- gnome? (
- >=dev-ruby/ruby-gnome2-0.14.1
- >=dev-ruby/ruby-gconf2-0.14.1
- )
- nls? ( >=dev-ruby/ruby-gettext-0.6.1 )"
-
-src_install() {
- ${RUBY} setup.rb install --prefix="${D}" || die
-
- domenu fantasdic.desktop
-
- erubydoc
-}