summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2006-05-05 14:55:30 +0000
committerLars Weiler <pylon@gentoo.org>2006-05-05 14:55:30 +0000
commitd267e7785e182bd313c10b5eff121ee0729e1828 (patch)
treedeccea8949ed9498bcdc3e10963dd8fd6bc8f0b7 /app-dicts
parentVersion bump. (diff)
downloadgentoo-2-d267e7785e182bd313c10b5eff121ee0729e1828.tar.gz
gentoo-2-d267e7785e182bd313c10b5eff121ee0729e1828.tar.bz2
gentoo-2-d267e7785e182bd313c10b5eff121ee0729e1828.zip
Version bump; thanks to Philipp Edelmann in bug #128250.
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/qvortaro/ChangeLog9
-rw-r--r--app-dicts/qvortaro/files/digest-qvortaro-0.3.13
-rw-r--r--app-dicts/qvortaro/qvortaro-0.3.1.ebuild33
3 files changed, 43 insertions, 2 deletions
diff --git a/app-dicts/qvortaro/ChangeLog b/app-dicts/qvortaro/ChangeLog
index 0c8468755e28..25617cdc8f96 100644
--- a/app-dicts/qvortaro/ChangeLog
+++ b/app-dicts/qvortaro/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-dicts/qvortaro
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/qvortaro/ChangeLog,v 1.3 2005/07/25 18:00:21 caleb Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/qvortaro/ChangeLog,v 1.4 2006/05/05 14:55:30 pylon Exp $
+
+*qvortaro-0.3.1 (05 May 2006)
+
+ 05 May 2006; Lars Weiler <pylon@gentoo.org> +qvortaro-0.3.1.ebuild:
+ Version bump; thanks to Philipp Edelmann in bug #128250.
25 Jul 2005; Caleb Tennis <caleb@gentoo.org> qvortaro-0.3.0.ebuild:
Change qt dep per bug #100235
diff --git a/app-dicts/qvortaro/files/digest-qvortaro-0.3.1 b/app-dicts/qvortaro/files/digest-qvortaro-0.3.1
new file mode 100644
index 000000000000..6e8cb2521db3
--- /dev/null
+++ b/app-dicts/qvortaro/files/digest-qvortaro-0.3.1
@@ -0,0 +1,3 @@
+MD5 a5231040bcba57bc88a51bb67d80d4bb qVortaro-0.3.1.tar.bz2 1542310
+RMD160 1fbecc15a4826636029946bea767f8603faa6c07 qVortaro-0.3.1.tar.bz2 1542310
+SHA256 319bff66d1dcee1eeb75d1472fdfdcbb5fd6d0c23f107dc398457ad67de7c49f qVortaro-0.3.1.tar.bz2 1542310
diff --git a/app-dicts/qvortaro/qvortaro-0.3.1.ebuild b/app-dicts/qvortaro/qvortaro-0.3.1.ebuild
new file mode 100644
index 000000000000..4b70c3480088
--- /dev/null
+++ b/app-dicts/qvortaro/qvortaro-0.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/qvortaro/qvortaro-0.3.1.ebuild,v 1.1 2006/05/05 14:55:30 pylon Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="An Esperanto dictionary (currently only German)"
+SRC_URI="http://download.berlios.de/qvortaro/qVortaro-${PV}.tar.bz2"
+HOMEPAGE="http://qvortaro.berlios.de"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/libc
+ $(qt_min_version 3.1)"
+
+S=${WORKDIR}/qVortaro-${PV}
+
+src_compile() {
+ cd ${S}
+ ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake || die "qmake failed"
+ emake || die "emake failed"
+}
+src_install() {
+ make INSTALL_ROOT=${D} install
+ doicon src/icon/${PN}.png
+ make_desktop_entry qvortaro "qVortaro"
+}
+pkg_postinst() {
+ einfo "additional dictionaries at http://qvortaro.berlios.de/dictionaries.php"
+}