summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-23 13:04:14 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-23 13:04:14 +0000
commitccebd481cb95a8b85ad7173d6dbe5effc45e4558 (patch)
treef59b4e8bf9c2ab856c696519fa3015bfd3ac97ab /app-dicts
parentUnmask mozilla-thunderbird-bin-3.0 (diff)
downloadgentoo-2-ccebd481cb95a8b85ad7173d6dbe5effc45e4558.tar.gz
gentoo-2-ccebd481cb95a8b85ad7173d6dbe5effc45e4558.tar.bz2
gentoo-2-ccebd481cb95a8b85ad7173d6dbe5effc45e4558.zip
Initial ebuild of goldendict. Bug #264631
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/goldendict/ChangeLog11
-rw-r--r--app-dicts/goldendict/files/goldendict-0.9.0-gcc4.4.patch11
-rw-r--r--app-dicts/goldendict/goldendict-0.9.0.ebuild64
-rw-r--r--app-dicts/goldendict/metadata.xml6
4 files changed, 92 insertions, 0 deletions
diff --git a/app-dicts/goldendict/ChangeLog b/app-dicts/goldendict/ChangeLog
new file mode 100644
index 000000000000..1160004badaf
--- /dev/null
+++ b/app-dicts/goldendict/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-dicts/goldendict
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/goldendict/ChangeLog,v 1.1 2010/01/23 13:04:13 hwoarang Exp $
+
+*goldendict-0.9.0 (23 Jan 2010)
+
+ 23 Jan 2010; Markos Chandras <hwoarang@gentoo.org>
+ +goldendict-0.9.0.ebuild, +files/goldendict-0.9.0-gcc4.4.patch,
+ +metadata.xml:
+ Initial ebuild of goldendict. Bug #264631
+
diff --git a/app-dicts/goldendict/files/goldendict-0.9.0-gcc4.4.patch b/app-dicts/goldendict/files/goldendict-0.9.0-gcc4.4.patch
new file mode 100644
index 000000000000..80d4551389de
--- /dev/null
+++ b/app-dicts/goldendict/files/goldendict-0.9.0-gcc4.4.patch
@@ -0,0 +1,11 @@
+diff -Nuar goldendict-0.9.0-src.orig/chunkedstorage.hh goldendict-0.9.0-src/chunkedstorage.hh
+--- goldendict-0.9.0-src.orig/chunkedstorage.hh 2009-09-24 20:20:56.000000000 +0600
++++ goldendict-0.9.0-src/chunkedstorage.hh 2009-09-24 20:22:22.000000000 +0600
+@@ -8,6 +8,7 @@
+ #include "file.hh"
+
+ #include <vector>
++#include <stdint.h>
+
+ #ifdef _MSC_VER
+ #include <stdint_msvc.h>
diff --git a/app-dicts/goldendict/goldendict-0.9.0.ebuild b/app-dicts/goldendict/goldendict-0.9.0.ebuild
new file mode 100644
index 000000000000..a25ddf0a67b2
--- /dev/null
+++ b/app-dicts/goldendict/goldendict-0.9.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/goldendict/goldendict-0.9.0.ebuild,v 1.1 2010/01/23 13:04:13 hwoarang Exp $
+
+EAPI="2"
+LANGS="ru"
+inherit qt4-r2 eutils
+
+DESCRIPTION="Feature-rich dictionary lookup program"
+HOMEPAGE="http://goldendict.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}-src-x11.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}/${P}-src"
+
+RDEPEND=">=app-text/hunspell-1.2
+ dev-libs/libzip
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-libs/libXtst
+ >=x11-libs/qt-webkit-4.5:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc4.4.patch"
+ # duplicates stuff into a directory we don't use
+ sed -i \
+ -e s/INSTALLS\ \+=\ desktops2//g \
+ -e s/INSTALLS\ \+=\ icons2//g \
+ "${S}"/goldendict.pro || die 'sed failed'
+}
+
+src_configure() {
+ PREFIX=/usr eqmake4
+}
+
+src_compile() {
+ if use linguas_ru ; then
+ einfo 'Preparing translations...'
+ lrelease ${PN}.pro || die 'lrelease failed'
+ fi
+ emake || die 'emake failed'
+}
+
+src_install() {
+ qt4-r2_src_install
+ for X in ${LINGUAS} ; do
+ for Z in ${LANGS}; do
+ if [[ ${X} == ${Z} ]]; then
+ insinto /usr/share/apps/${PN}/locale
+ doins locale/ru.qm || die 'doins failed'
+ fi
+ done
+ done
+}
+
+pkg_postinst() {
+ elog 'The portage tree contains various stardict and dictd dictionaries, which'
+ elog 'GoldenDict can use. Also, check http://goldendict.berlios.de/dictionaries.php'
+ elog 'for more options. The myspell packages can also be useful.'
+}
diff --git a/app-dicts/goldendict/metadata.xml b/app-dicts/goldendict/metadata.xml
new file mode 100644
index 000000000000..c4db62280a40
--- /dev/null
+++ b/app-dicts/goldendict/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+</pkgmetadata>
+