summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-02-25 14:45:56 +0000
committerPeter Volkov <pva@gentoo.org>2008-02-25 14:45:56 +0000
commit6b315f80c529cad9ce0f842da2a0375046b25911 (patch)
tree70a467088c174dfff17834eaf889229faccb83d2 /app-dicts
parentOld. (diff)
downloadgentoo-2-6b315f80c529cad9ce0f842da2a0375046b25911.tar.gz
gentoo-2-6b315f80c529cad9ce0f842da2a0375046b25911.tar.bz2
gentoo-2-6b315f80c529cad9ce0f842da2a0375046b25911.zip
Version bump, finally startdict-3.0.1 is in the tree. Thank you Zhang Le, jjmmma, Pro and others for work in bug #188684! Fixed compile problem and popup window "jumping away" problem, bug #188827 and #195882, thank Ed Catmur, Evgeniy Dushistov and other people for help, fix and investigations of these bugs.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/stardict/ChangeLog18
-rw-r--r--app-dicts/stardict/files/stardict-2.4.8-ClipboardReceivedCallback.patch20
-rw-r--r--app-dicts/stardict/files/stardict-2.4.8-floatwin-disappear.patch13
-rw-r--r--app-dicts/stardict/metadata.xml4
-rw-r--r--app-dicts/stardict/stardict-2.4.2.ebuild8
-rw-r--r--app-dicts/stardict/stardict-2.4.8-r1.ebuild (renamed from app-dicts/stardict/stardict-2.4.8.ebuild)8
-rw-r--r--app-dicts/stardict/stardict-3.0.1.ebuild73
7 files changed, 136 insertions, 8 deletions
diff --git a/app-dicts/stardict/ChangeLog b/app-dicts/stardict/ChangeLog
index 35893dc9e1dd..e5043391bb0b 100644
--- a/app-dicts/stardict/ChangeLog
+++ b/app-dicts/stardict/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for app-dicts/stardict
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/ChangeLog,v 1.35 2007/08/30 12:22:44 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/ChangeLog,v 1.36 2008/02/25 14:45:56 pva Exp $
+
+*stardict-3.0.1 (25 Feb 2008)
+*stardict-2.4.8-r1 (25 Feb 2008)
+
+ 25 Feb 2008; <pva@gentoo.org>
+ +files/stardict-2.4.8-ClipboardReceivedCallback.patch,
+ +files/stardict-2.4.8-floatwin-disappear.patch, metadata.xml,
+ stardict-2.4.2.ebuild, -stardict-2.4.8.ebuild, +stardict-2.4.8-r1.ebuild,
+ +stardict-3.0.1.ebuild:
+ Version bump, finally startdict-3.0.1 is in the tree. Thank you Zhang Le,
+ jjmmma, Pro and others for work in bug #188684! Fixed compile problem and
+ popup window "jumping away" problem, bug #188827 and #195882, thank Ed
+ Catmur, Evgeniy Dushistov and other people for help, fix and investigations
+ of these bugs.
30 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing liquidx from metadata due to his retirement (see #171155 for
diff --git a/app-dicts/stardict/files/stardict-2.4.8-ClipboardReceivedCallback.patch b/app-dicts/stardict/files/stardict-2.4.8-ClipboardReceivedCallback.patch
new file mode 100644
index 000000000000..630da35e83ff
--- /dev/null
+++ b/app-dicts/stardict/files/stardict-2.4.8-ClipboardReceivedCallback.patch
@@ -0,0 +1,20 @@
+--- trunk/src/mainwin.h 2006/08/08 12:44:42 1
++++ trunk/src/mainwin.h 2006/08/09 19:00:35 2
+@@ -68,8 +68,6 @@
+ static void on_main_menu_about_activate(GtkMenuItem *menuitem, TopWin *oTopWin);
+ static void on_main_menu_quit_activate(GtkMenuItem *menuitem, TopWin *oTopWin);
+
+- static void ClipboardReceivedCallback(GtkClipboard *clipboard, const gchar *text, gpointer data);
+-
+ void LoadHistory(void);
+ void SaveHistory(void);
+ public:
+@@ -97,7 +95,7 @@
+ bool HasFocus() {
+ return GTK_WIDGET_HAS_FOCUS(GTK_COMBO(WordCombo)->entry);
+ }
+-
++ static void ClipboardReceivedCallback(GtkClipboard *clipboard, const gchar *text, gpointer data);
+ };
+
+ class ListWin
diff --git a/app-dicts/stardict/files/stardict-2.4.8-floatwin-disappear.patch b/app-dicts/stardict/files/stardict-2.4.8-floatwin-disappear.patch
new file mode 100644
index 000000000000..44f92ee9884a
--- /dev/null
+++ b/app-dicts/stardict/files/stardict-2.4.8-floatwin-disappear.patch
@@ -0,0 +1,13 @@
+Index: stardict-2.4.8/src/floatwin.cpp
+===================================================================
+--- stardict-2.4.8.orig/src/floatwin.cpp
++++ stardict-2.4.8/src/floatwin.cpp
+@@ -788,7 +788,7 @@ gboolean FloatWin::vButtonReleaseCallbac
+
+ gboolean FloatWin::vMotionNotifyCallback (GtkWidget * widget, GdkEventMotion * event , FloatWin *oFloatWin)
+ {
+- if (event->window == oFloatWin->FloatWindow->window || (event->state & GDK_BUTTON1_MASK))
++ if (event->state & GDK_BUTTON1_MASK)
+ {
+ gint x,y;
+ x = oFloatWin->press_window_x + (gint)(event->x_root) - oFloatWin->press_x_root;
diff --git a/app-dicts/stardict/metadata.xml b/app-dicts/stardict/metadata.xml
index aef01fc3d591..9ec38e237a80 100644
--- a/app-dicts/stardict/metadata.xml
+++ b/app-dicts/stardict/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>cjk</herd>
+ <maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+ </maintainer>
</pkgmetadata>
diff --git a/app-dicts/stardict/stardict-2.4.2.ebuild b/app-dicts/stardict/stardict-2.4.2.ebuild
index 0469d4f2c3d7..73d7fafc25c6 100644
--- a/app-dicts/stardict/stardict-2.4.2.ebuild
+++ b/app-dicts/stardict/stardict-2.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.2.ebuild,v 1.16 2007/07/11 05:41:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.2.ebuild,v 1.17 2008/02/25 14:45:56 pva Exp $
inherit gnome2 eutils
@@ -37,14 +37,14 @@ src_unpack() {
gnome2_omf_fix
# Fix gtk-2.4 deprecation issues
- epatch ${FILESDIR}/stardict-gtk24.patch
+ epatch "${FILESDIR}"/stardict-gtk24.patch
}
src_install() {
gnome2_src_install
# dictionary index generation files
exeinto /usr/share/stardict/tools
- doexe ${S}/src/tools/{dictd2dic,directory2dict,olddic2newdic,oxford2dic,pydict2dict,wquick2dict,stardict_dict_update}
+ doexe "${S}"/src/tools/{dictd2dic,directory2dict,olddic2newdic,oxford2dic,pydict2dict,wquick2dict,stardict_dict_update}
}
pkg_postinst() {
diff --git a/app-dicts/stardict/stardict-2.4.8.ebuild b/app-dicts/stardict/stardict-2.4.8-r1.ebuild
index dd4dd5125012..b7d3b494f85a 100644
--- a/app-dicts/stardict/stardict-2.4.8.ebuild
+++ b/app-dicts/stardict/stardict-2.4.8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.8.ebuild,v 1.4 2007/07/11 05:41:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.8-r1.ebuild,v 1.1 2008/02/25 14:45:56 pva Exp $
inherit gnome2 eutils
@@ -35,6 +35,10 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
+
+ cd "${S}"/src
+ epatch "${FILESDIR}"/${P}-ClipboardReceivedCallback.patch
+ epatch "${FILESDIR}"/${P}-floatwin-disappear.patch
gnome2_omf_fix
}
diff --git a/app-dicts/stardict/stardict-3.0.1.ebuild b/app-dicts/stardict/stardict-3.0.1.ebuild
new file mode 100644
index 000000000000..1915118bbdaa
--- /dev/null
+++ b/app-dicts/stardict/stardict-3.0.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-3.0.1.ebuild,v 1.1 2008/02/25 14:45:56 pva Exp $
+
+inherit gnome2 eutils autotools
+
+# NOTE: Even though the *.dict.dz are the same as dictd/freedict's files,
+# their indexes seem to be in a different format. So we'll keep them
+# seperate for now.
+
+IUSE="festival espeak gnome gucharmap spell"
+DESCRIPTION="A GNOME2 international dictionary supporting fuzzy and glob style matching"
+HOMEPAGE="http://stardict.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stardict/${P}.tar.bz2"
+
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+# when adding keywords, remember to add to stardict.eclass
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEP="gnome? ( >=gnome-base/libbonobo-2.2.0
+ >=gnome-base/libgnome-2.2.0
+ >=gnome-base/libgnomeui-2.2.0
+ >=gnome-base/gconf-2
+ >=gnome-base/orbit-2.6
+ app-text/scrollkeeper )
+ spell? ( app-text/enchant )
+ gucharmap? ( >=gnome-extra/gucharmap-1.4.0 )
+ >=sys-libs/zlib-1.1.4
+ >=x11-libs/gtk+-2.12"
+
+RDEPEND="${DEP}
+ espeak? ( >=app-accessibility/espeak-1.29 )
+ festival? ( =app-accessibility/festival-1.96_beta )"
+
+DEPEND="${DEP}
+ >=dev-util/intltool-0.22
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.in-EST.diff
+ epatch "${FILESDIR}"/${P}-gconf-m4.diff
+ AT_M4DIR="m4" eautoreconf
+ gnome2_omf_fix
+}
+
+src_compile() {
+ export PKG_CONFIG=$(type -P pkg-config)
+ # Festival plugin crashes, bug 188684. Disable for now.
+ G2CONF="$(use_enable gnome gnome-support)
+ $(use_enable spell)
+ $(use_enable gucharmap)
+ $(use_enable espeak espeak)
+ --disable-festival
+ --disable-advertisement
+ --disable-updateinfo"
+ gnome2_src_compile
+}
+
+pkg_postinst() {
+ elog "Note: festival text to speach (TTS) plugin is not built. To use festival"
+ elog 'TTS plugin, please, enable "Use TTS program." at:'
+ elog '"Preferences -> Dictionary -> Sound" and fill in "Commandline" with:'
+ elog '"echo %s | festival --tts"'
+ elog
+ elog "You will now need to install stardict dictionary files. If"
+ elog "you have not, execute the below to get a list of dictionaries:"
+ elog
+ elog " emerge -s stardict-"
+}