summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2005-11-12 17:50:44 +0000
committerFabian Groffen <grobian@gentoo.org>2005-11-12 17:50:44 +0000
commit4aea94d3368cd6d9479c12b353fbdb2c3221e329 (patch)
tree9039630c885ae384b425fcfc22aca3a59835ac1c /app-dicts
parentFix segfault on amd64 by adding a patch from AJ Frantz <ajfrantz@umich.edu>. ... (diff)
downloadgentoo-2-4aea94d3368cd6d9479c12b353fbdb2c3221e329.tar.gz
gentoo-2-4aea94d3368cd6d9479c12b353fbdb2c3221e329.tar.bz2
gentoo-2-4aea94d3368cd6d9479c12b353fbdb2c3221e329.zip
Added patch supplied by dirk {dot] schoenberger |at: freenet.de to compile on OSX, marked ~ppc-macos
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/wordnet/ChangeLog7
-rw-r--r--app-dicts/wordnet/Manifest13
-rw-r--r--app-dicts/wordnet/files/wordnet-2.0-macos.patch11
-rw-r--r--app-dicts/wordnet/wordnet-2.0.ebuild5
4 files changed, 22 insertions, 14 deletions
diff --git a/app-dicts/wordnet/ChangeLog b/app-dicts/wordnet/ChangeLog
index e40ceea67c88..f5f9c292bccb 100644
--- a/app-dicts/wordnet/ChangeLog
+++ b/app-dicts/wordnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-dicts/wordnet
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/ChangeLog,v 1.5 2005/04/23 11:23:01 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/ChangeLog,v 1.6 2005/11/12 17:50:44 grobian Exp $
+
+ 12 Nov 2005; Fabian Groffen <grobian@gentoo.org>
+ +files/wordnet-2.0-macos.patch, wordnet-2.0.ebuild:
+ Added patch supplied by dirk {dot] schoenberger |at: freenet.de to compile on
+ OSX, marked ~ppc-macos
23 Apr 2005; Jan Brinkmann <luckyduck@gentoo.org> wordnet-2.0.ebuild:
added ~amd64 to KEYWORDS, fixes #90093
diff --git a/app-dicts/wordnet/Manifest b/app-dicts/wordnet/Manifest
index 0d397eabae2b..85276d9d28eb 100644
--- a/app-dicts/wordnet/Manifest
+++ b/app-dicts/wordnet/Manifest
@@ -1,15 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 2e966310c397cd365610cfc6b8c2b01e wordnet-2.0.ebuild 925
+MD5 4ab5b2a53811995253b4c5382ee310f2 wordnet-2.0.ebuild 975
MD5 547ea0d4e8412cfb88940286834867f7 ChangeLog 829
MD5 eb03775ece62e57725480e782cd84ee8 metadata.xml 162
+MD5 6c0a2d852702e5e23085ce1cbe80c665 files/wordnet-2.0-macos.patch 287
MD5 295bc3b2d65fc6db177d69c4e54491a5 files/Makefiles.diff 2633
MD5 660184f847c527e0e6a1024bb0c44318 files/digest-wordnet-2.0 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCajAt06ebR+OMO78RAm9nAJ4mu4Kur+nA2p+xwM+COnmRFgmkPgCggIK+
-nOhWwXs+Y+NmmtxZ26yetUw=
-=gw9d
------END PGP SIGNATURE-----
diff --git a/app-dicts/wordnet/files/wordnet-2.0-macos.patch b/app-dicts/wordnet/files/wordnet-2.0-macos.patch
new file mode 100644
index 000000000000..555312d091bf
--- /dev/null
+++ b/app-dicts/wordnet/files/wordnet-2.0-macos.patch
@@ -0,0 +1,11 @@
+--- WordNet-2.0/src/lib/wnutil.c.orig 2005-11-12 15:52:07.000000000 +0100
++++ WordNet-2.0/src/lib/wnutil.c 2005-11-12 15:52:51.000000000 +0100
+@@ -7,7 +7,7 @@
+ #include <stdio.h>
+ #include <ctype.h>
+
+-#ifdef UNIX
++#if defined(UNIX) && !defined(__APPLE__)
+ #include <malloc.h>
+ #endif
+
diff --git a/app-dicts/wordnet/wordnet-2.0.ebuild b/app-dicts/wordnet/wordnet-2.0.ebuild
index 67f5004ad5a4..22b6588a0961 100644
--- a/app-dicts/wordnet/wordnet-2.0.ebuild
+++ b/app-dicts/wordnet/wordnet-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/wordnet-2.0.ebuild,v 1.5 2005/04/23 11:23:01 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/wordnet-2.0.ebuild,v 1.6 2005/11/12 17:50:44 grobian Exp $
inherit eutils
@@ -12,12 +12,13 @@ DEPEND="dev-lang/tcl
LICENSE="Princeton"
IUSE=""
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
S=${WORKDIR}/WordNet-${PV}
src_unpack() {
unpack $A
epatch ${FILESDIR}/Makefiles.diff
+ epatch "${FILESDIR}/${P}"-macos.patch
}
src_compile() {