summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-18 22:45:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-18 22:45:45 +0000
commitfec3e251a084c3d947d8b402ebfa936aaef8f59b (patch)
treedfbc9ca22255b584604f934f01f29a41915cccb1 /app-dicts/stardict
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-fec3e251a084c3d947d8b402ebfa936aaef8f59b.tar.gz
gentoo-2-fec3e251a084c3d947d8b402ebfa936aaef8f59b.tar.bz2
gentoo-2-fec3e251a084c3d947d8b402ebfa936aaef8f59b.zip
Add gucharmap2 compatibility patch, bug #240728. Fix typoe, bug #253438.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts/stardict')
-rw-r--r--app-dicts/stardict/ChangeLog10
-rw-r--r--app-dicts/stardict/files/stardict-3.0.1-gucharmap2.patch46
-rw-r--r--app-dicts/stardict/stardict-3.0.1-r2.ebuild106
3 files changed, 160 insertions, 2 deletions
diff --git a/app-dicts/stardict/ChangeLog b/app-dicts/stardict/ChangeLog
index c5b39c580ac5..6b0051995ab7 100644
--- a/app-dicts/stardict/ChangeLog
+++ b/app-dicts/stardict/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-dicts/stardict
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/ChangeLog,v 1.50 2008/08/31 15:43:38 ranger Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/ChangeLog,v 1.51 2009/02/18 22:45:44 eva Exp $
+
+*stardict-3.0.1-r2 (18 Feb 2009)
+
+ 18 Feb 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/stardict-3.0.1-gucharmap2.patch, +stardict-3.0.1-r2.ebuild:
+ Add gucharmap2 compatibility patch, bug #240728. Fix typoe, bug #253438.
31 Aug 2008; Brent Baude <ranger@gentoo.org> stardict-3.0.1-r1.ebuild:
stable ppc64, bug 236096
diff --git a/app-dicts/stardict/files/stardict-3.0.1-gucharmap2.patch b/app-dicts/stardict/files/stardict-3.0.1-gucharmap2.patch
new file mode 100644
index 000000000000..dc8f9415e473
--- /dev/null
+++ b/app-dicts/stardict/files/stardict-3.0.1-gucharmap2.patch
@@ -0,0 +1,46 @@
+Index: configure.in
+===================================================================
+--- configure.in (revision 257)
++++ configure.in (working copy)
+@@ -12,6 +12,7 @@
+
+ AC_PATH_PROG(GCONFTOOL, gconftool-2)
+ AC_PROG_INTLTOOL([0.22])
++PKG_PROG_PKG_CONFIG
+
+ AC_CONFIG_MACRO_DIR(m4)
+ AM_PROG_LIBTOOL
+@@ -72,13 +73,17 @@
+ dnl gucharmap plugin checks.
+ dnl ================================================================
+
++GUCHARMAP_REQUIRED=1.4.0
+ AC_ARG_ENABLE([gucharmap],
+ AS_HELP_STRING([--disable-gucharmap],[Disable gucharmap plugin (default: enabled)]),
+ [enable_gucharmap=$enableval],
+ [enable_gucharmap=yes])
+
+ if test "x$enable_gucharmap" = "xyes" ; then
+- PKG_CHECK_MODULES(GUCHARMAP, [gucharmap >= 1.4.0], have_gucharmap=yes, have_gucharmap=no)
++ PKG_CHECK_MODULES(GUCHARMAP, [gucharmap >= $GUCHARMAP_REQUIRED], have_gucharmap=yes, have_gucharmap=no)
++ if test "x$have_gucharmap" != "xyes"; then
++ PKG_CHECK_MODULES(GUCHARMAP, [gucharmap-2 >= $GUCHARMAP_REQUIRED], have_gucharmap=yes, have_gucharmap=no)
++ fi
+ if test "x$have_gucharmap" = "xyes"; then
+ GUCHARMAP_CFLAGS="${GUCHARMAP_CFLAGS}"
+ GUCHARMAP_LIBS="${GUCHARMAP_LIBS}"
+Index: stardict-plugins/stardict-gucharmap-plugin/stardict_gucharmap.cpp
+===================================================================
+--- stardict-plugins/stardict-gucharmap-plugin/stardict_gucharmap.cpp (revision 257)
++++ stardict-plugins/stardict-gucharmap-plugin/stardict_gucharmap.cpp (working copy)
+@@ -238,7 +238,7 @@
+ /* canonical decomposition */
+ gunichar *decomposition;
+ gsize result_len;
+- decomposition = gucharmap_unicode_canonical_decomposition (uc, &result_len);
++ decomposition = g_unicode_canonical_decomposition (uc, &result_len);
+ if (result_len != 1) {
+ definition += _("Canonical decomposition:");
+ definition += " ";
+
+
diff --git a/app-dicts/stardict/stardict-3.0.1-r2.ebuild b/app-dicts/stardict/stardict-3.0.1-r2.ebuild
new file mode 100644
index 000000000000..cc9baa6169a5
--- /dev/null
+++ b/app-dicts/stardict/stardict-3.0.1-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-3.0.1-r2.ebuild,v 1.1 2009/02/18 22:45:44 eva Exp $
+
+inherit gnome2 eutils autotools
+
+# NOTE: Even though the *.dict.dz are the same as dictd/freedict's files,
+# their indexes seem to be in a different format. So we'll keep them
+# seperate for now.
+
+IUSE="festival espeak gnome gucharmap qqwry pronounce spell"
+DESCRIPTION="A GNOME2 international dictionary supporting fuzzy and glob style matching"
+HOMEPAGE="http://stardict.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stardict/${P}.tar.bz2
+ qqwry? ( mirror://sourceforge/stardict/QQWry.Dat.bz2 )
+ pronounce? ( mirror://sourceforge/stardict/WyabdcRealPeopleTTS.tar.bz2 )"
+
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEP="gnome? ( >=gnome-base/libbonobo-2.2.0
+ >=gnome-base/libgnome-2.2.0
+ >=gnome-base/libgnomeui-2.2.0
+ >=gnome-base/gconf-2
+ >=gnome-base/orbit-2.6
+ app-text/scrollkeeper )
+ spell? ( app-text/enchant )
+ gucharmap? ( >=gnome-extra/gucharmap-1.4.0 )
+ >=sys-libs/zlib-1.1.4
+ >=x11-libs/gtk+-2.12"
+
+RDEPEND="${DEP}
+ espeak? ( >=app-accessibility/espeak-1.29 )
+ festival? ( =app-accessibility/festival-1.96_beta )"
+
+DEPEND="${DEP}
+ >=dev-util/intltool-0.22
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if (use gnome && use pronounce && ! built_with_use gnome-base/libgnome esd); then
+ ewarn 'Note, being built with USE="gnome" stardict uses gnome_sound_play()'
+ ewarn 'to play RealPeopleTTS sounds, which plays sounds only in case'
+ ewarn 'gnome-base/libgnome was built with USE="esd".'
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-configure.in-EST.diff
+ epatch "${FILESDIR}"/${P}-gconf-m4.diff
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-transparent_trayicon.patch
+ epatch "${FILESDIR}"/${P}-changelog-minor-typo-fixes.patch
+
+ # Fix compatibility with gucharmap-2, bug #240728
+ epatch "${FILESDIR}/${P}-gucharmap2.patch"
+
+ AT_M4DIR="m4" eautoreconf
+ gnome2_omf_fix
+}
+
+src_compile() {
+ export PKG_CONFIG=$(type -P pkg-config)
+ # Festival plugin crashes, bug 188684. Disable for now.
+ G2CONF="$(use_enable gnome gnome-support)
+ $(use_enable spell)
+ $(use_enable gucharmap)
+ $(use_enable espeak)
+ $(use_enable qqwry)
+ --disable-festival
+ --disable-advertisement
+ --disable-updateinfo"
+ gnome2_src_compile
+}
+
+src_install() {
+ gnome2_src_install
+ if use qqwry; then
+ insinto /usr/share/stardict/data
+ doins ../QQWry.Dat
+ fi
+ if use pronounce; then
+ dodir /usr/share/
+ mv ../WyabdcRealPeopleTTS "${D}"/usr/share/
+ fi
+ dodoc doc/{FAQ,HowToCreateDictionary,StarDictFileFormat,Translation,HACKING}
+}
+
+pkg_postinst() {
+ if use festival; then
+ elog "Note: festival text to speech (TTS) plugin is not built. To use festival"
+ elog 'TTS plugin, please, enable "Use TTS program." at:'
+ elog '"Preferences -> Dictionary -> Sound" and fill in "Commandline" with:'
+ elog '"echo %s | festival --tts"'
+ elog
+ fi
+ elog "You will now need to install stardict dictionary files. If"
+ elog "you have not, execute the below to get a list of dictionaries:"
+ elog
+ elog " emerge -s stardict-"
+}