summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-03-06 04:26:28 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-03-06 04:26:28 +0000
commita5c4201550c08f5193f199a4ba8ffca32a996c9f (patch)
tree3ee8f51adfc6df07523e19f8e7f24ec8ae86c487 /app-dicts/opendict
parentEAPI 2 and fix python dep. (diff)
downloadgentoo-2-a5c4201550c08f5193f199a4ba8ffca32a996c9f.tar.gz
gentoo-2-a5c4201550c08f5193f199a4ba8ffca32a996c9f.tar.bz2
gentoo-2-a5c4201550c08f5193f199a4ba8ffca32a996c9f.zip
Drop use of deprecated python.eclass functions.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts/opendict')
-rw-r--r--app-dicts/opendict/ChangeLog7
-rw-r--r--app-dicts/opendict/opendict-0.6.3.ebuild33
2 files changed, 23 insertions, 17 deletions
diff --git a/app-dicts/opendict/ChangeLog b/app-dicts/opendict/ChangeLog
index 5c14d0b5a7a2..f3b27a593274 100644
--- a/app-dicts/opendict/ChangeLog
+++ b/app-dicts/opendict/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-dicts/opendict
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/ChangeLog,v 1.17 2009/11/23 00:22:01 dirtyepic Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/ChangeLog,v 1.18 2010/03/06 04:26:28 dirtyepic Exp $
+
+ 06 Mar 2010; Ryan Hill <dirtyepic@gentoo.org> opendict-0.6.3.ebuild:
+ Drop use of deprecated python.eclass functions.
*opendict-0.6.3 (23 Nov 2009)
diff --git a/app-dicts/opendict/opendict-0.6.3.ebuild b/app-dicts/opendict/opendict-0.6.3.ebuild
index ac8ad7e7ea5c..1f8b338e132e 100644
--- a/app-dicts/opendict/opendict-0.6.3.ebuild
+++ b/app-dicts/opendict/opendict-0.6.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/opendict-0.6.3.ebuild,v 1.1 2009/11/23 00:22:01 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/opendict-0.6.3.ebuild,v 1.2 2010/03/06 04:26:28 dirtyepic Exp $
EAPI=2
-inherit eutils python gnome2
+inherit eutils gnome2 python
DESCRIPTION="OpenDict is a free cross-platform dictionary program."
HOMEPAGE="http://opendict.sourceforge.net/"
@@ -14,27 +14,28 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND=">=virtual/python-2.3
- dev-python/wxpython:2.8
+RDEPEND="dev-python/wxpython:2.8
dev-python/pyxml"
+PYTHON_DEPEND="2"
+
src_prepare() {
- #epatch "${FILESDIR}/${PN}-0.6.1-desktop.patch"
sed -e "s:), '..')):), '../../../../..', 'share', 'opendict')):g" \
-i "${S}/lib/info.py"
}
src_configure() {
- :
+ # override gnome2_src_configure
+ default
}
src_compile() {
+ # evil makefile
:
}
src_install() {
- python_version
- DHOME="/usr/lib/python${PYVER}/site-packages/opendict"
+ # makefile is broken, do it manually
dodir /usr/share/${PN}/dictionaries/plugins # global dictionary plugins folder
@@ -42,12 +43,12 @@ src_install() {
insinto /usr/share/${PN}
doins "${S}"/copying.html
- insinto "${DHOME}/lib"
- doins -r "${S}"/lib/*
-
insinto /usr/share/${PN}/pixmaps
doins "${S}"/pixmaps/*
+ DHOME="$(python_get_sitedir)/opendict"
+ insinto "${DHOME}/lib"
+ doins -r "${S}"/lib/*
exeinto "${DHOME}"
doexe opendict.py
@@ -69,16 +70,18 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize \
- /usr/$(get_libdir)/python${PYVER}/site-packages/opendict
+ python_mod_optimize $(python_get_sitedir)/opendict
gnome2_icon_cache_update
+ echo
elog "If you want system-wide plugins, unzip them into"
elog "${ROOT}usr/share/${PN}/dictionaries/plugins"
+ elog
elog "Some are available from http://opendict.sourceforge.net/?cid=3"
+ echo
}
pkg_postrm() {
- python_mod_cleanup
+ python_mod_cleanup $(python_get_sitedir)/opendict
gnome2_icon_cache_update
}