summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-03-08 02:22:36 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-03-08 02:22:36 +0000
commit31ace905e2a5792c0f824961603424a27ee69d4c (patch)
tree8073db4a29b046e1968d700a0ce6e2f30b901cd9 /app-dicts/opendict
parentstable amd64, bug 306273 (diff)
downloadgentoo-2-31ace905e2a5792c0f824961603424a27ee69d4c.tar.gz
gentoo-2-31ace905e2a5792c0f824961603424a27ee69d4c.tar.bz2
gentoo-2-31ace905e2a5792c0f824961603424a27ee69d4c.zip
More python fixes for bug #308351.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts/opendict')
-rw-r--r--app-dicts/opendict/ChangeLog5
-rw-r--r--app-dicts/opendict/opendict-0.6.3.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/app-dicts/opendict/ChangeLog b/app-dicts/opendict/ChangeLog
index e9875c92d9fd..0a09f36eadec 100644
--- a/app-dicts/opendict/ChangeLog
+++ b/app-dicts/opendict/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-dicts/opendict
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/ChangeLog,v 1.19 2010/03/08 00:47:47 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/ChangeLog,v 1.20 2010/03/08 02:22:36 dirtyepic Exp $
+
+ 08 Mar 2010; Ryan Hill <dirtyepic@gentoo.org> opendict-0.6.3.ebuild:
+ More python fixes for bug #308351.
08 Mar 2010; Jonathan Callen <abcd@gentoo.org> opendict-0.6.3.ebuild:
Move PYTHON_DEPEND before inherit(), so that the dep is actually added
diff --git a/app-dicts/opendict/opendict-0.6.3.ebuild b/app-dicts/opendict/opendict-0.6.3.ebuild
index 9ca137004d4d..a8dcd069cfe1 100644
--- a/app-dicts/opendict/opendict-0.6.3.ebuild
+++ b/app-dicts/opendict/opendict-0.6.3.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/opendict-0.6.3.ebuild,v 1.3 2010/03/08 00:47:47 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/opendict-0.6.3.ebuild,v 1.4 2010/03/08 02:22:36 dirtyepic Exp $
EAPI=2
-
-PYTHON_DEPEND="2"
+PYTHON_DEPEND=2
inherit eutils gnome2 python
@@ -19,6 +18,10 @@ IUSE=""
RDEPEND="dev-python/wxpython:2.8
dev-python/pyxml"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
sed -e "s:), '..')):), '../../../../..', 'share', 'opendict')):g" \
-i "${S}/lib/info.py"
@@ -50,6 +53,7 @@ src_install() {
insinto "${DHOME}/lib"
doins -r "${S}"/lib/*
exeinto "${DHOME}"
+ python_convert_shebangs 2 opendict.py
doexe opendict.py
dosym "${DHOME}/opendict.py" /usr/bin/opendict