summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2006-05-16 13:48:12 +0000
committerAkinori Hattori <hattya@gentoo.org>2006-05-16 13:48:12 +0000
commit71eba9cdbd7bf64b956b59f3f7736bf597f5c97e (patch)
treecaf9d1fea21c3d2092c34d429f962b2769b4e2e3 /app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20060408.ebuild
parentnew upstream release. (diff)
downloadgentoo-2-71eba9cdbd7bf64b956b59f3f7736bf597f5c97e.tar.gz
gentoo-2-71eba9cdbd7bf64b956b59f3f7736bf597f5c97e.tar.bz2
gentoo-2-71eba9cdbd7bf64b956b59f3f7736bf597f5c97e.zip
Initial revision
(Portage version: 2.0.54-r2)
Diffstat (limited to 'app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20060408.ebuild')
-rw-r--r--app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20060408.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20060408.ebuild b/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20060408.ebuild
new file mode 100644
index 000000000000..a79cf8afeb35
--- /dev/null
+++ b/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20060408.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/mecab-ipadic/mecab-ipadic-2.7.0.20060408.ebuild,v 1.1 2006/05/16 13:48:12 hattya Exp $
+
+IUSE="unicode"
+
+MY_P="${PN}-${PV%.*}-${PV/*.}"
+
+DESCRIPTION="IPA dictionary for MeCab"
+HOMEPAGE="http://mecab.sourceforge.jp/"
+SRC_URI="http://prdownloads.sourceforge.jp/mecab/19691/${MY_P}.tar.gz"
+
+LICENSE="ipadic"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=app-text/mecab-0.90"
+
+src_compile() {
+
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+}