summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-12-04 07:04:34 +0000
committerMamoru Komachi <usata@gentoo.org>2003-12-04 07:04:34 +0000
commitdf9b0684a85f8e25ae366482278b9223d5ee9607 (patch)
tree603af198b581fe0f8b0748ec3c9ee05dbdcae746 /app-dicts/kannadic/kannadic-1.7.0.ebuild
parentVersion bumped. Marked 1.1.1 as stable for x86. (diff)
downloadgentoo-2-df9b0684a85f8e25ae366482278b9223d5ee9607.tar.gz
gentoo-2-df9b0684a85f8e25ae366482278b9223d5ee9607.tar.bz2
gentoo-2-df9b0684a85f8e25ae366482278b9223d5ee9607.zip
Version bumped. Marked 1.1.1 as stable for x86.
Diffstat (limited to 'app-dicts/kannadic/kannadic-1.7.0.ebuild')
-rw-r--r--app-dicts/kannadic/kannadic-1.7.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-dicts/kannadic/kannadic-1.7.0.ebuild b/app-dicts/kannadic/kannadic-1.7.0.ebuild
new file mode 100644
index 000000000000..3ec75f006667
--- /dev/null
+++ b/app-dicts/kannadic/kannadic-1.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kannadic/kannadic-1.7.0.ebuild,v 1.1 2003/12/04 07:04:29 usata Exp $
+
+IUSE="debug xinerama"
+
+DESCRIPTION="Graphical Canna style dictionary editor written for KDE"
+HOMEPAGE="http://linux-life.net/program/cc/kde/app/kannadic/"
+SRC_URI="http://linux-life.net/program/cc/kde/app/kannadic/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+S="${WORKDIR}/${P}"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ kde-base/kde
+ x11-libs/qt
+ app-i18n/canna"
+
+src_compile() {
+
+ econf `use_enable debug` \
+ `use_with xinerama` || die
+ emake || die
+}
+
+src_install() {
+
+ einstall || die
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Currently KannaDic doesn't create a dictionary for you,"
+ einfo "so you need to create one manually."
+ einfo "e.g) If you are going to add user dictionary named \"personal\", run"
+ einfo
+ einfo "\t% mkdic user"
+ einfo
+ einfo "and add :user \"personal\" to (use-dictionary ...) in your ~/.canna"
+ einfo "You may need to restart canna server in order to use your dictionary."
+ einfo
+}