summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-04-10 20:49:05 +0000
committerBen de Groot <yngwin@gentoo.org>2010-04-10 20:49:05 +0000
commitaae3c6db7ba159b298dfa12d7ef4bef59bf978c7 (patch)
tree695deb0ccc880ae140f1366c18a4da5c11f0809e /app-dicts/goldendict
parentSet SUPPORT_PYTHON_ABIS. Delete calls to deprecated python_version() (bug #31... (diff)
downloadgentoo-2-aae3c6db7ba159b298dfa12d7ef4bef59bf978c7.tar.gz
gentoo-2-aae3c6db7ba159b298dfa12d7ef4bef59bf978c7.tar.bz2
gentoo-2-aae3c6db7ba159b298dfa12d7ef4bef59bf978c7.zip
Pin Qt version to 4.5 for 0.9.0, as per bug #313059. Adding snapshot ebuild, based on the live git one in qting-edge overlay by Davide Pesavento.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts/goldendict')
-rw-r--r--app-dicts/goldendict/ChangeLog10
-rw-r--r--app-dicts/goldendict/goldendict-0.9.0.ebuild4
-rw-r--r--app-dicts/goldendict/goldendict-0.9.0_p20100410.ebuild45
3 files changed, 56 insertions, 3 deletions
diff --git a/app-dicts/goldendict/ChangeLog b/app-dicts/goldendict/ChangeLog
index 1160004badaf..4c4318196a58 100644
--- a/app-dicts/goldendict/ChangeLog
+++ b/app-dicts/goldendict/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-dicts/goldendict
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/goldendict/ChangeLog,v 1.1 2010/01/23 13:04:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/goldendict/ChangeLog,v 1.2 2010/04/10 20:49:05 yngwin Exp $
+
+*goldendict-0.9.0_p20100410 (10 Apr 2010)
+
+ 10 Apr 2010; Ben de Groot <yngwin@gentoo.org> goldendict-0.9.0.ebuild,
+ +goldendict-0.9.0_p20100410.ebuild:
+ Pin Qt version to 4.5 for 0.9.0, as per bug #313059. Adding snapshot
+ ebuild, based on the live git one in qting-edge overlay by Davide
+ Pesavento.
*goldendict-0.9.0 (23 Jan 2010)
diff --git a/app-dicts/goldendict/goldendict-0.9.0.ebuild b/app-dicts/goldendict/goldendict-0.9.0.ebuild
index a25ddf0a67b2..3778b4f6c40c 100644
--- a/app-dicts/goldendict/goldendict-0.9.0.ebuild
+++ b/app-dicts/goldendict/goldendict-0.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/goldendict/goldendict-0.9.0.ebuild,v 1.1 2010/01/23 13:04:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/goldendict/goldendict-0.9.0.ebuild,v 1.2 2010/04/10 20:49:05 yngwin Exp $
EAPI="2"
LANGS="ru"
@@ -21,7 +21,7 @@ RDEPEND=">=app-text/hunspell-1.2
media-libs/libogg
media-libs/libvorbis
x11-libs/libXtst
- >=x11-libs/qt-webkit-4.5:4"
+ =x11-libs/qt-webkit-4.5*:4"
DEPEND="${RDEPEND}"
src_prepare() {
diff --git a/app-dicts/goldendict/goldendict-0.9.0_p20100410.ebuild b/app-dicts/goldendict/goldendict-0.9.0_p20100410.ebuild
new file mode 100644
index 000000000000..0bd84f708de1
--- /dev/null
+++ b/app-dicts/goldendict/goldendict-0.9.0_p20100410.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/goldendict/goldendict-0.9.0_p20100410.ebuild,v 1.1 2010/04/10 20:49:05 yngwin Exp $
+
+EAPI="3"
+LANGSLONG="ar_SA bg_BG cs_CZ de_DE el_GR lt_LT ru_RU zh_CN"
+
+inherit qt4-r2
+
+DESCRIPTION="Feature-rich dictionary lookup program"
+HOMEPAGE="http://goldendict.berlios.de/"
+SRC_URI="http://omploader.org/vNDQ1cQ/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kde"
+
+RDEPEND=">=app-text/hunspell-1.2
+ media-libs/libogg
+ media-libs/libvorbis
+ sys-libs/zlib
+ x11-libs/libXtst
+ >=x11-libs/qt-core-4.5:4[exceptions]
+ >=x11-libs/qt-gui-4.5:4[exceptions]
+ >=x11-libs/qt-webkit-4.5:4[exceptions]
+ !kde? ( || (
+ >=x11-libs/qt-phonon-4.5:4[exceptions]
+ media-sound/phonon
+ ) )
+ kde? ( media-sound/phonon )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ qt4-r2_src_install
+
+ # install translations
+ insinto /usr/share/apps/${PN}/locale
+ for lang in ${LANGSLONG}; do
+ if use linguas_${lang%_*}; then
+ doins locale/${lang}.qm || die
+ fi
+ done
+}