summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-10-12 23:55:24 +0000
committerNaohiro Aota <naota@gentoo.org>2012-10-12 23:55:24 +0000
commit6ac48a23f77acbd96bc2afe919008ccceba7dcf0 (patch)
treeae41afd69348ab0414c07388dd2b94d0194be3df /app-dicts/gjiten
parentFix paths for prefix, bug 435718 by jlec. (diff)
downloadgentoo-2-6ac48a23f77acbd96bc2afe919008ccceba7dcf0.tar.gz
gentoo-2-6ac48a23f77acbd96bc2afe919008ccceba7dcf0.tar.bz2
gentoo-2-6ac48a23f77acbd96bc2afe919008ccceba7dcf0.zip
Add patch to fix segfault. #292365
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts/gjiten')
-rw-r--r--app-dicts/gjiten/ChangeLog9
-rw-r--r--app-dicts/gjiten/files/gjiten-2.6-pref.patch13
-rw-r--r--app-dicts/gjiten/gjiten-2.6-r2.ebuild57
3 files changed, 77 insertions, 2 deletions
diff --git a/app-dicts/gjiten/ChangeLog b/app-dicts/gjiten/ChangeLog
index 08956eedbc62..aba0eaad270d 100644
--- a/app-dicts/gjiten/ChangeLog
+++ b/app-dicts/gjiten/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-dicts/gjiten
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/gjiten/ChangeLog,v 1.22 2012/05/03 02:18:36 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gjiten/ChangeLog,v 1.23 2012/10/12 23:55:24 naota Exp $
+
+*gjiten-2.6-r2 (12 Oct 2012)
+
+ 12 Oct 2012; <naota@gentoo.org> +files/gjiten-2.6-pref.patch,
+ +gjiten-2.6-r2.ebuild:
+ Add patch to fix segfault. #292365
03 May 2012; Jeff Horelick <jdhore@gentoo.org> gjiten-2.3.ebuild,
gjiten-2.6-r1.ebuild:
@@ -86,4 +92,3 @@
04 Jun 2003; Masatomo Nakano <nakano@gentoo.org> gjiten-2.1.ebuild:
Initial import as unstable
-
diff --git a/app-dicts/gjiten/files/gjiten-2.6-pref.patch b/app-dicts/gjiten/files/gjiten-2.6-pref.patch
new file mode 100644
index 000000000000..f06d833e87c3
--- /dev/null
+++ b/app-dicts/gjiten/files/gjiten-2.6-pref.patch
@@ -0,0 +1,13 @@
+diff --git a/src/pref.c b/src/pref.c
+index 9c5e07d..6c0e13d 100644
+--- a/src/pref.c
++++ b/src/pref.c
+@@ -271,7 +271,7 @@ static void up_dict(GtkWidget *button) {
+ gtk_list_store_swap(GTK_LIST_STORE(model), &iter, &tmpiter);
+ }
+ }
+- g_free(treepath);
++ gtk_tree_path_free(treepath);
+ }
+
+
diff --git a/app-dicts/gjiten/gjiten-2.6-r2.ebuild b/app-dicts/gjiten/gjiten-2.6-r2.ebuild
new file mode 100644
index 000000000000..aefa32251e53
--- /dev/null
+++ b/app-dicts/gjiten/gjiten-2.6-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gjiten/gjiten-2.6-r2.ebuild,v 1.1 2012/10/12 23:55:24 naota Exp $
+
+EAPI=2
+inherit autotools eutils gnome2
+
+DESCRIPTION="A Japanese dictionary program for Gnome"
+HOMEPAGE="http://gjiten.sourceforge.net/"
+SRC_URI="http://gjiten.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND=">=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libglade-2"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ dev-util/intltool
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.1.2
+ virtual/pkgconfig"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+src_prepare() {
+ gnome2_src_prepare
+ epatch "${FILESDIR}"/${P}-pref.patch
+ # bug #124631
+ intltoolize --copy --automake --force || die "intltoolize failed"
+ AM_OPTS="--foreign" eautoreconf
+}
+
+pkg_postinst() {
+ elog
+ elog "Dictionary files are necessary in order for"
+ elog "Gjiten to function."
+ elog
+ elog "Download dictionary files from:"
+ elog "http://ftp.cc.monash.edu.au/pub/nihongo/00INDEX.html#dic_fil"
+ elog "You need kanjidic and edict at a minimum. Dictionary files"
+ elog "must be converted to UTF-8 format - check the Gjiten help"
+ elog "and README files for details."
+ elog
+ elog "A shell script is available from "
+ elog "the Gjiten homepage(${HOMEPAGE}) to"
+ elog "download and convert the dictionary files, but you need"
+ elog "to put the files in /usr/share/gjiten after running the script."
+ elog
+
+ gnome2_pkg_postinst
+}