summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-05 23:03:07 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-05 23:03:07 +0000
commit5bb93a91cbda82c776d8f25799419650879fcc2e (patch)
tree7573a855133f9202eec6bddc0bc84fa3b5594667 /app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild
parentBump to 1.3.4, closing #249569 (diff)
downloadgentoo-2-5bb93a91cbda82c776d8f25799419650879fcc2e.tar.gz
gentoo-2-5bb93a91cbda82c776d8f25799419650879fcc2e.tar.bz2
gentoo-2-5bb93a91cbda82c776d8f25799419650879fcc2e.zip
Version bumped. Added gnome USE flag, bug #200991.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild')
-rw-r--r--app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild b/app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild
new file mode 100644
index 000000000000..82f6cbd8e9aa
--- /dev/null
+++ b/app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/fantasdic/fantasdic-1.0_beta6.ebuild,v 1.1 2008/12/05 23:03:07 matsuu Exp $
+
+inherit eutils ruby
+
+MY_P="${P/_/-}"
+DESCRIPTION="Fantasdic is a client for the DICT protocol"
+HOMEPAGE="http://www.gnome.org/projects/fantasdic/"
+SRC_URI="http://www.mblondel.org/files/fantasdic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome nls"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=dev-lang/ruby-1.8"
+RDEPEND="${DEPEND}
+ >=dev-ruby/ruby-libglade2-0.14.1
+ gnome? (
+ >=dev-ruby/ruby-gnome2-0.14.1
+ >=dev-ruby/ruby-gconf2-0.14.1
+ )
+ nls? ( >=dev-ruby/ruby-gettext-0.6.1 )"
+
+src_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
+
+ domenu fantasdic.desktop
+
+ erubydoc
+}