summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2009-07-10 14:02:19 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2009-07-10 14:02:19 +0000
commitf37c170051526a8fb124234c15ada5ec9c448fee (patch)
tree81b3947c9b5564ccc9b07983c4fa2755e38ce14a /app-crypt
parentdev-util/efence is no more (diff)
downloadgentoo-2-f37c170051526a8fb124234c15ada5ec9c448fee.tar.gz
gentoo-2-f37c170051526a8fb124234c15ada5ec9c448fee.tar.bz2
gentoo-2-f37c170051526a8fb124234c15ada5ec9c448fee.zip
Fix buils of seahorse against gpgme with LFS. Bug #275445
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/ChangeLog6
-rw-r--r--app-crypt/seahorse/files/seahorse-2.26.2-gpgme-lfs.patch39
-rw-r--r--app-crypt/seahorse/seahorse-2.26.2.ebuild7
3 files changed, 49 insertions, 3 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index 6bce1f6fb216..e5dff4ad5e64 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/seahorse
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.116 2009/05/23 20:21:23 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.117 2009/07/10 14:02:18 dang Exp $
+
+ 10 Jul 2009; Daniel Gryniewicz <dang@gentoo.org> seahorse-2.26.2.ebuild,
+ +files/seahorse-2.26.2-gpgme-lfs.patch:
+ Fix buils of seahorse against gpgme with LFS. Bug #275445
*seahorse-2.26.2 (23 May 2009)
diff --git a/app-crypt/seahorse/files/seahorse-2.26.2-gpgme-lfs.patch b/app-crypt/seahorse/files/seahorse-2.26.2-gpgme-lfs.patch
new file mode 100644
index 000000000000..1c72b39d7dae
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-2.26.2-gpgme-lfs.patch
@@ -0,0 +1,39 @@
+diff --exclude-from=/opt/home/dang/.scripts/diffrc -up -ruN seahorse-2.26.2.orig/pgp/seahorse-gpg-op.c seahorse-2.26.2/pgp/seahorse-gpg-op.c
+--- seahorse-2.26.2.orig/pgp/seahorse-gpg-op.c 2009-04-20 11:35:00.000000000 -0400
++++ seahorse-2.26.2/pgp/seahorse-gpg-op.c 2009-07-10 09:43:31.550476889 -0400
+@@ -18,7 +18,9 @@
+ * 59 Temple Place, Suite 330,
+ * Boston, MA 02111-1307, USA.
+ */
+-
++
++#include "config.h"
++
+ #include <glib.h>
+ #include <gpgme.h>
+ #include <string.h>
+diff --exclude-from=/opt/home/dang/.scripts/diffrc -up -ruN seahorse-2.26.2.orig/pgp/seahorse-gpg-options.c seahorse-2.26.2/pgp/seahorse-gpg-options.c
+--- seahorse-2.26.2.orig/pgp/seahorse-gpg-options.c 2009-04-20 11:35:00.000000000 -0400
++++ seahorse-2.26.2/pgp/seahorse-gpg-options.c 2009-07-10 09:36:16.012409729 -0400
+@@ -19,6 +19,11 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
++#include "config.h"
++
++#include "seahorse-util.h"
++#include "seahorse-context.h"
++
+ #include <sys/param.h>
+ #include <sys/wait.h>
+ #include <sys/file.h>
+@@ -31,9 +36,6 @@
+ #include <unistd.h>
+ #include <sys/stat.h>
+
+-#include "seahorse-util.h"
+-#include "seahorse-context.h"
+-
+ #include "pgp/seahorse-gpgme.h"
+ #include "pgp/seahorse-gpg-options.h"
+
diff --git a/app-crypt/seahorse/seahorse-2.26.2.ebuild b/app-crypt/seahorse/seahorse-2.26.2.ebuild
index 2e4710f6786e..f2cef20b7daf 100644
--- a/app-crypt/seahorse/seahorse-2.26.2.ebuild
+++ b/app-crypt/seahorse/seahorse-2.26.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.26.2.ebuild,v 1.1 2009/05/23 20:21:23 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.26.2.ebuild,v 1.2 2009/07/10 14:02:18 dang Exp $
EAPI="2"
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="A GNOME application for managing encryption keys"
HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
@@ -62,6 +62,9 @@ src_prepare() {
# Fix intltoolize broken file, see upstream #577133
sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+
+ # fix building with gpgme with lfs Bug #275445
+ epatch "${FILESDIR}"/${P}-gpgme-lfs.patch
}
pkg_postinst() {