summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-11-01 00:37:41 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-11-01 00:37:41 +0000
commitb71a0ebd2f4fc901ae363f655dcc0523924d7649 (patch)
tree1d48145242bac9de9fe73af817f3838dd8276ef1 /app-crypt
parentBump to version 1.0.0. Major cleanup. (diff)
downloadgentoo-2-b71a0ebd2f4fc901ae363f655dcc0523924d7649.tar.gz
gentoo-2-b71a0ebd2f4fc901ae363f655dcc0523924d7649.tar.bz2
gentoo-2-b71a0ebd2f4fc901ae363f655dcc0523924d7649.zip
fix, i didnt investigate that thoroughly enough.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/Manifest2
-rw-r--r--app-crypt/gnupg/gnupg-1.2.3-r3.ebuild32
2 files changed, 14 insertions, 20 deletions
diff --git a/app-crypt/gnupg/Manifest b/app-crypt/gnupg/Manifest
index 99a9531a29ea..67e89d1fab0f 100644
--- a/app-crypt/gnupg/Manifest
+++ b/app-crypt/gnupg/Manifest
@@ -1,5 +1,5 @@
MD5 0761192752d3ed8c1ced6a858261eff6 gnupg-1.2.3-r2.ebuild 1626
-MD5 b9753968537e069430e5e0ed54ba117e gnupg-1.2.3-r3.ebuild 3656
+MD5 0fc1ae46ef01ebf4609274fc819a5f6c gnupg-1.2.3-r3.ebuild 3552
MD5 95d9ba72ebb3d327a76a7b871aad85ed ChangeLog 5583
MD5 5ffa87354a03beae320d15a7be997529 gnupg-1.2.2-r1.ebuild 1629
MD5 773ecd19392b8f793d7626c9814e1e0b files/digest-gnupg-1.2.2-r1 65
diff --git a/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild b/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild
index bf0ad348059b..4f9bee52c33e 100644
--- a/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild
+++ b/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild,v 1.3 2003/10/31 23:51:40 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.3-r3.ebuild,v 1.4 2003/11/01 00:37:36 taviso Exp $
DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
HOMEPAGE="http://www.gnupg.org/"
@@ -101,28 +101,22 @@ src_install() {
dohtml doc/faq.html
# please see glsa 200307-06
- chmod u+s "${D}/usr/bin/gpg"
+ if ! use caps; then
+ chmod u+s "${D}/usr/bin/gpg"
+ fi
}
pkg_postinst() {
- einfo "gpg is installed suid root to make use of protected memory space"
- einfo "This is needed in order to have a secure place to store your"
- einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
-
- if use caps; then
- echo
+ if ! use caps; then
+ einfo "gpg is installed suid root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your"
+ einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
+ else
# a quick blurb to explain the linux capabilities.
- # $ /sbin/getpcaps `pidof gpg`
- # Capabilities for `31677': = cap_ipc_lock+p
- #
- # useful reference in the comments from
- # /usr/include/linux/capability.h
-
- einfo "gpg will use the linux capabilities system to minimise the"
- einfo "security risks associated with running setuid root."
- einfo "you can confirm the capabilities have been set with the"
- einfo "getpcaps application."
- einfo " # getpcaps \`pidof gpg\`"
+ einfo "gpg has not been installed setuid, as you have the \"caps\" USE flag"
+ einfo "set, you should now configure gpg to use cap_ipc_lock+p capability"
+ einfo "to give non-root users access to locked memory pages."
+ einfo "please refer to the capabilities(7) manpage for more information."
fi
}