summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@gentoo.org>2001-05-09 23:45:12 +0000
committerRyan Tolboom <ryan@gentoo.org>2001-05-09 23:45:12 +0000
commitb5f7aaa8be7d38017fc595f028a89086614f74e4 (patch)
treecfe73ed32975bc32655ad2c2ddab39969106334f /app-crypt
parentUpdate (diff)
downloadgentoo-2-b5f7aaa8be7d38017fc595f028a89086614f74e4.tar.gz
gentoo-2-b5f7aaa8be7d38017fc595f028a89086614f74e4.tar.bz2
gentoo-2-b5f7aaa8be7d38017fc595f028a89086614f74e4.zip
*** empty log message ***
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.0.51
-rw-r--r--app-crypt/gnupg/gnupg-1.0.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.0.5 b/app-crypt/gnupg/files/digest-gnupg-1.0.5
new file mode 100644
index 000000000000..bb871cdbf691
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.0.5
@@ -0,0 +1 @@
+MD5 44c71c3f5a9edbf5738cafc37e8359e6 gnupg-1.0.5.tar.gz
diff --git a/app-crypt/gnupg/gnupg-1.0.5.ebuild b/app-crypt/gnupg/gnupg-1.0.5.ebuild
new file mode 100644
index 000000000000..92a9e727e027
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens
+# $Header: /home/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.4.ebuild,v 1.0
+# 2001/04/21 12:45 CST blutgens Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+SRC_URI="ftp://ftp.gnupg.org/pub/gcrypt/gnupg/${A}"
+HOMEPAGE="http://www.gnupg.org/"
+
+DEPEND=">=sys-devel/gettext-0.10.35
+ >=sys-libs/zlib-1.1.3"
+
+src_compile() {
+
+# Check to see if we're using nls
+ local myconf
+ if [ -z "`use nls`" ]; then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share \
+ --enable-static-rnd=linux --enable-m-guard --host=${CHOST}\
+ ${myconf}
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
+ dodoc README TODO VERSION
+ docinto doc
+ cd doc
+ dodoc faq.html faq.raw gpg.sgml gpgv.sgml FAQ HACKING DETAILS ChangeLog
+ chmod +s ${D}/usr/bin/gpg
+}
+