summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-12-15 18:33:51 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-12-15 18:33:51 +0000
commita9d8343265f727f009fa0e561c391e45a31c3846 (patch)
treee34e8a1226badd2493d4d148d6399d701585a981 /app-crypt
parentAdd policing. (diff)
downloadgentoo-2-a9d8343265f727f009fa0e561c391e45a31c3846.tar.gz
gentoo-2-a9d8343265f727f009fa0e561c391e45a31c3846.tar.bz2
gentoo-2-a9d8343265f727f009fa0e561c391e45a31c3846.zip
Add 2.6.24 support, bug#198394, thanks to elschner.net
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog6
-rw-r--r--app-crypt/truecrypt/files/truecrypt-4.3a-2.6.24.patch15
-rw-r--r--app-crypt/truecrypt/truecrypt-4.3a.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 89657d2c72d8..6ac38d8cd1dd 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.26 2007/11/02 06:50:13 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.27 2007/12/15 18:33:50 alonbl Exp $
+
+ 15 Dec 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/truecrypt-4.3a-2.6.24.patch, truecrypt-4.3a.ebuild:
+ Add 2.6.24 support, bug#198394, thanks to elschner.net
02 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org> truecrypt-4.3a.ebuild:
Remove requirement to unload modules, test not use the modules anyway,
diff --git a/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.24.patch b/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.24.patch
new file mode 100644
index 000000000000..55b0c5a1c477
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.24.patch
@@ -0,0 +1,15 @@
+--- truecrypt-4.3a-source-code.org/Linux/Kernel/Dm-target.c 2007-04-24 18:32:06.000000000 +0200
++++ truecrypt-4.3a-source-code/Linux/Kernel/Dm-target.c 2007-12-15 18:22:39.000000000 +0100
+@@ -375,7 +375,12 @@ static void dereference_bio_ctx (struct
+ if (!atomic_dec_and_test (&bc->ref_count))
+ return;
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
+ bio_endio (bc->orig_bio, bc->orig_bio->bi_size, bc->error);
++#else
++ bio_endio (bc->orig_bio, bc->orig_bio->bi_size);
++#endif
++
+ mempool_free (bc, tc->bio_ctx_pool);
+ }
+
diff --git a/app-crypt/truecrypt/truecrypt-4.3a.ebuild b/app-crypt/truecrypt/truecrypt-4.3a.ebuild
index 212e8e2f5103..21572af82473 100644
--- a/app-crypt/truecrypt/truecrypt-4.3a.ebuild
+++ b/app-crypt/truecrypt/truecrypt-4.3a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-4.3a.ebuild,v 1.5 2007/11/02 06:50:13 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-4.3a.ebuild,v 1.6 2007/12/15 18:33:50 alonbl Exp $
#
# NOTES:
@@ -44,6 +44,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-2.6.23.patch"
+ epatch "${FILESDIR}/${P}-2.6.24.patch"
}
src_compile() {