summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-12-28 20:50:48 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-12-28 20:50:48 +0000
commita86378ab2ffc43ecb22f1fb699341e7445637c54 (patch)
tree622ab255770971bbbd0196094dcbe62c7405845b /app-crypt
parentAdd app-crypt/ccid:twinserial (diff)
downloadgentoo-2-a86378ab2ffc43ecb22f1fb699341e7445637c54.tar.gz
gentoo-2-a86378ab2ffc43ecb22f1fb699341e7445637c54.tar.bz2
gentoo-2-a86378ab2ffc43ecb22f1fb699341e7445637c54.zip
Add twinserial support, closes bug#157716, thanks to Jerome
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/ccid/ChangeLog8
-rw-r--r--app-crypt/ccid/ccid-1.1.0-r1.ebuild48
-rw-r--r--app-crypt/ccid/files/ccid-1.1.0-build.patch42
-rw-r--r--app-crypt/ccid/files/digest-ccid-1.1.0-r13
4 files changed, 100 insertions, 1 deletions
diff --git a/app-crypt/ccid/ChangeLog b/app-crypt/ccid/ChangeLog
index 94bcdaf243eb..2592292761b1 100644
--- a/app-crypt/ccid/ChangeLog
+++ b/app-crypt/ccid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/ccid
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ChangeLog,v 1.10 2006/12/02 23:33:04 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ChangeLog,v 1.11 2006/12/28 20:50:48 alonbl Exp $
+
+*ccid-1.1.0-r1 (28 Dec 2006)
+
+ 28 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/ccid-1.1.0-build.patch, +ccid-1.1.0-r1.ebuild:
+ Add twinserial support, closes bug#157716, thanks to Jerome
02 Dec 2006; Steve Dibb <beandog@gentoo.org> ccid-1.0.1.ebuild,
ccid-1.0.1-r1.ebuild, ccid-1.1.0.ebuild:
diff --git a/app-crypt/ccid/ccid-1.1.0-r1.ebuild b/app-crypt/ccid/ccid-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..3df534ee1d06
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ccid-1.1.0-r1.ebuild,v 1.1 2006/12/28 20:50:48 alonbl Exp $
+
+inherit eutils autotools
+
+DL_NUM="1740"
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
+SRC_URI="http://alioth.debian.org/download.php/${DL_NUM}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="chipcard2 twinserial"
+RDEPEND="
+ !chipcard2? (
+ >=sys-apps/pcsc-lite-1.3.2
+ >=dev-libs/libusb-0.1.4
+ )
+ chipcard2? sys-libs/libchipcard"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ # bug 131421 - allow ccid to work with sys-libs/libchipcard
+ use chipcard2 && myconf="${myconf} \
+ --enable-usbdropdir=/usr/lib/chipcard2-server/lowlevel/ifd \
+ --enable-ccidtwindir=/usr/lib/chipcard2-server/lowlevel/ifd"
+
+ use nousb && myconf="${myconf} --disable-pcsclite"
+
+ econf \
+ ${myconf} \
+ $(use_enable twinserial) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Cannot install"
+ dodoc README AUTHORS
+}
diff --git a/app-crypt/ccid/files/ccid-1.1.0-build.patch b/app-crypt/ccid/files/ccid-1.1.0-build.patch
new file mode 100644
index 000000000000..2840593c69b0
--- /dev/null
+++ b/app-crypt/ccid/files/ccid-1.1.0-build.patch
@@ -0,0 +1,42 @@
+diff -urNp ccid-1.1.0.org/configure.in ccid-1.1.0/configure.in
+--- ccid-1.1.0.org/configure.in 2006-08-11 20:22:30.000000000 +0300
++++ ccid-1.1.0/configure.in 2006-12-28 22:28:37.000000000 +0200
+@@ -211,13 +211,9 @@ fi
+ # --enable-twinserial
+ AC_ARG_ENABLE(twinserial,
+ AC_HELP_STRING([--enable-twinserial],[also compile and install the serial Twin driver]),
+- [twinserial="${enableval}"], [twinserial=false])
++ [twinserial="${enableval}"], [twinserial=no])
+ AC_MSG_RESULT([build and install serial Twin driver : $twinserial])
+-if test "${twinserial}" = false ; then
+- AM_CONDITIONAL(WITH_TWIN_SERIAL, false)
+-else
+- AM_CONDITIONAL(WITH_TWIN_SERIAL, true)
+-fi
++AM_CONDITIONAL(WITH_TWIN_SERIAL, test "${twinserial}" != "no")
+
+ # --enable-ccidtwindir=DIR
+ AC_ARG_ENABLE(ccidtwindir,
+@@ -234,9 +230,7 @@ AC_ARG_ENABLE(pcsclite,
+ AC_HELP_STRING([--disable-pcsclite],[do not use pcsc-lite debug support]),
+ [ pcsclite="${enableval}" ], [ pcsclite=yes ] )
+
+-if test "${pcsclite}" = no ; then
+- AM_CONDITIONAL(WITHOUT_PCSC, true)
+-else
++if test "${pcsclite}" != "no" ; then
+ # check that pcsc-lite is installed
+ OLD_LIBS="$LIBS"
+ LIBS="$LIBS $PCSC_LIBS"
+@@ -244,10 +238,9 @@ else
+ [AC_MSG_ERROR([SCardEstablishContext() not found, install pcsc-lite 1.2.9-beta9 or later, or use PCSC_LIBS=... ./configure])])
+ LIBS="$OLD_LIBS"
+
+- AM_CONDITIONAL(WITHOUT_PCSC, false)
+-
+ pcsclite=yes
+ fi
++AM_CONDITIONAL(WITHOUT_PCSC, test "${pcsclite}" != "no")
+ AC_MSG_RESULT([compiled for pcsc-lite : $pcsclite])
+
+
diff --git a/app-crypt/ccid/files/digest-ccid-1.1.0-r1 b/app-crypt/ccid/files/digest-ccid-1.1.0-r1
new file mode 100644
index 000000000000..94b385228506
--- /dev/null
+++ b/app-crypt/ccid/files/digest-ccid-1.1.0-r1
@@ -0,0 +1,3 @@
+MD5 3d216cb89030c6a74fb6851bcc80b08e ccid-1.1.0.tar.gz 540628
+RMD160 9569d64e597b1f6248e394517434ef170a1e5662 ccid-1.1.0.tar.gz 540628
+SHA256 a11c6df683a529d7101cf1dbcf1e376e9e01a9f7b3e73a1b19f335dd32c93093 ccid-1.1.0.tar.gz 540628